iproute2: update to 2.6.37

This commit is contained in:
Juergen Daubert 2011-01-08 17:25:00 +01:00
parent 8c04325eb5
commit b96bc65651
3 changed files with 5 additions and 21 deletions

View File

@ -1,2 +1,2 @@
b0f281b3124bf04669e18f5fe16d4934 iproute2-2.6.35.tar.bz2
9774ff9d74ebd301bf56bd8d74473786 iproute2-2.6.37.tar.bz2
0b01b0404718d043adf55cfa314c80bd net.iproute2

View File

@ -1,17 +1,18 @@
# Description: A collection of utilites for controlling TCP/IP networking and traffic in Linux
# URL: http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2
# Maintainer: CRUX System Team, core-ports at crux dot nu
# Depends on: db
# Depends on: db iptables
name=iproute2
version=2.6.35
version=2.6.37
release=1
source=(http://devresources.linuxfoundation.org/dev/iproute2/download/$name-$version.tar.bz2 \
net.iproute2)
build() {
cd $name-$version
sed -i "s|-O2|$CFLAGS -DIPT_LIB_DIR=\\\\\"/usr/lib/xtables\\\\\"|" Makefile
sed -i "s|-O2|$CFLAGS|" Makefile
./configure
make
make MANDIR=/usr/man DESTDIR=$PKG install
rm -r $PKG/share

View File

@ -1,17 +0,0 @@
diff -pruN iproute2-2.6.34.orig/tc/Makefile iproute2-2.6.34/tc/Makefile
--- iproute2-2.6.34.orig/tc/Makefile 2010-06-03 12:46:19.597183871 +1000
+++ iproute2-2.6.34/tc/Makefile 2010-06-03 12:47:28.332176460 +1000
@@ -99,10 +99,10 @@ libtc.a: $(TCLIB)
$(AR) rcs $@ $(TCLIB)
install: all
- echo mkdir -p $(MODDESTDIR)
- echo install -m 0755 tc $(DESTDIR)$(SBINDIR)
+ mkdir -p $(MODDESTDIR)
+ install -m 0755 tc $(DESTDIR)$(SBINDIR)
for i in $(TCSO); \
- do echo install -m 755 $$i $(MODDESTDIR); \
+ do install -m 755 $$i $(MODDESTDIR); \
done
if [ ! -f $(MODDESTDIR)/m_ipt.so ]; then \
if [ -f $(MODDESTDIR)/m_xt.so ]; \