tzdata: initial release, version 2012e

This commit is contained in:
Juergen Daubert 2012-08-08 09:53:29 +02:00
parent eebe6d4eee
commit bc6c81046a
4 changed files with 1979 additions and 0 deletions

1829
tzdata/.footprint Normal file

File diff suppressed because it is too large Load Diff

3
tzdata/.md5sum Normal file
View File

@ -0,0 +1,3 @@
8b87388ac1e850b5111f039e9c1d1db8 tzcode-makefile.patch
cc56398842289807a80791f1f654181f tzcode2012e.tar.gz
cb74e1f7bcc9a968a891a471e72e47b8 tzdata2012e.tar.gz

16
tzdata/Pkgfile Normal file
View File

@ -0,0 +1,16 @@
# Description: Sources for Time Zone and Daylight Saving Time Data
# URL: ftp://ftp.iana.org/tz/code/tz-link.htm
# Maintainer: CRUX System Team, core-ports at crux dot nu
name=tzdata
version=2012e
release=1
source=(http://www.iana.org/time-zones/repository/releases/$name$version.tar.gz
http://www.iana.org/time-zones/repository/releases/tzcode$version.tar.gz
tzcode-makefile.patch)
build() {
patch -p1 -i $SRC/tzcode-makefile.patch
make
make DESTDIR=$PKG install
}

View File

@ -0,0 +1,131 @@
diff -Nru tzcode.orig/Makefile tzcode/Makefile
--- tzcode.orig/Makefile 2012-08-03 19:21:09.713863123 +0200
+++ tzcode/Makefile 2012-08-03 19:21:31.769750400 +0200
@@ -39,17 +39,17 @@
# Everything gets put in subdirectories of. . .
-TOPDIR= /usr/local
+TOPDIR= $(DESTDIR)/usr
# "Compiled" time zone information is placed in the "TZDIR" directory
# (and subdirectories).
# Use an absolute path name for TZDIR unless you're just testing the software.
-TZDIR= $(TOPDIR)/etc/zoneinfo
+TZDIR= $(TOPDIR)/share/zoneinfo
# The "tzselect", "zic", and "zdump" commands get installed in. . .
-ETCDIR= $(TOPDIR)/etc
+SBINDIR= $(TOPDIR)/sbin
# If you "make INSTALL", the "date" command gets installed in. . .
@@ -88,7 +88,7 @@
# Non-default libraries needed to link.
# Add -lintl if you want to use `gettext' on Solaris.
-LDLIBS=
+LDLIBS=$(LDFLAGS)
# Add the following to the end of the "CFLAGS=" line as needed.
# -DHAVE_ADJTIME=0 if `adjtime' does not exist (SVR0?)
@@ -214,7 +214,7 @@
# before the first Monday in January when a "%V" format is used and January 1
# falls on a Friday, Saturday, or Sunday.
-CFLAGS=
+CFLAGS += -std=gnu99
# If you want zic's -s option used when installing, uncomment the next line
# ZFLAGS= -s
@@ -223,7 +223,7 @@
ZIC= $(zic) $(ZFLAGS)
# The name of a Posix-compliant `awk' on your system.
-AWK= nawk
+AWK= awk
# The path where SGML DTDs are kept.
# The default is appropriate for Ubuntu.
@@ -257,8 +257,10 @@
###############################################################################
-cc= cc
-CC= $(cc) -DTZDIR=\"$(TZDIR)\"
+CC+= -DTZDIR=\"$(TZDIR)\"
+ifeq ($(NLS),1)
+CC += -DHAVE_GETTEXT=1 -DTZ_DOMAIN=\"libc\"
+endif
TZCSRCS= zic.c localtime.c asctime.c scheck.c ialloc.c
TZCOBJS= zic.o localtime.o asctime.o scheck.o ialloc.o
@@ -298,14 +300,16 @@
ALL: all date
-install: all $(DATA) $(REDO) $(TZLIB) $(MANS) $(TABDATA)
+install: all $(DATA) $(REDO) $(MANS) $(TABDATA)
$(ZIC) -y $(YEARISTYPE) \
-d $(TZDIR) -l $(LOCALTIME) -p $(POSIXRULES)
-rm -f $(TZDIR)/iso3166.tab $(TZDIR)/zone.tab
cp iso3166.tab zone.tab $(TZDIR)/.
- -mkdir $(TOPDIR) $(ETCDIR)
- cp tzselect zic zdump $(ETCDIR)/.
- -mkdir $(TOPDIR) $(MANDIR) \
+ -mkdir -p $(TOPDIR) $(SBINDIR)
+ cp zic zdump $(SBINDIR)/.
+ -mkdir -p $(TOPDIR) $(BINDIR)
+ cp tzselect $(BINDIR)/.
+ -mkdir -p $(TOPDIR) $(MANDIR) \
$(MANDIR)/man3 $(MANDIR)/man5 $(MANDIR)/man8
-rm -f $(MANDIR)/man3/newctime.3 \
$(MANDIR)/man3/newtzset.3 \
@@ -314,13 +318,11 @@
$(MANDIR)/man8/zdump.8 \
$(MANDIR)/man8/zic.8
cp newctime.3 newtzset.3 $(MANDIR)/man3/.
- cp tzfile.5 $(MANDIR)/man5/.
- cp tzselect.8 zdump.8 zic.8 $(MANDIR)/man8/.
INSTALL: ALL install date.1
- -mkdir $(TOPDIR) $(BINDIR)
+ -mkdir -p $(TOPDIR) $(BINDIR)
cp date $(BINDIR)/.
- -mkdir $(TOPDIR) $(MANDIR) $(MANDIR)/man1
+ -mkdir -p $(TOPDIR) $(MANDIR) $(MANDIR)/man1
-rm -f $(MANDIR)/man1/date.1
cp date.1 $(MANDIR)/man1/.
@@ -354,9 +356,9 @@
# You must replace all of $(TZDIR) to switch from not using leap seconds
# to using them, or vice versa.
other_two: zic leapseconds $(TDATA)
- $(ZIC) -y $(YEARISTYPE) -d $(TZDIR)-posix -L /dev/null $(TDATA)
+ $(ZIC) -y $(YEARISTYPE) -d $(TZDIR)/posix -L /dev/null $(TDATA)
$(ZIC) -y $(YEARISTYPE) \
- -d $(TZDIR)-leaps -L leapseconds $(TDATA)
+ -d $(TZDIR)/right -L leapseconds $(TDATA)
posix_right: posix_only other_two
@@ -382,7 +384,7 @@
<$? >$@
chmod +x $@
-check: check_tables check_web
+check: check_tables
check_tables: checktab.awk $(PRIMARY_YDATA)
$(AWK) -f checktab.awk $(PRIMARY_YDATA)
diff -Nru tzcode.orig/tzselect.ksh tzcode/tzselect.ksh
--- tzcode.orig/tzselect.ksh 2012-08-03 19:21:09.713863123 +0200
+++ tzcode/tzselect.ksh 2012-08-03 19:21:31.773083616 +0200
@@ -1,4 +1,4 @@
-#! /bin/ksh
+#! /bin/bash
TZVERSION=see_Makefile