libarchive: updated to version 3.7.3

This commit is contained in:
Juergen Daubert 2024-04-08 15:16:40 +02:00
parent eb409dca46
commit bef9aa7c50
3 changed files with 6 additions and 49 deletions

View File

@ -1,6 +1,5 @@
untrusted comment: verify with /etc/ports/core.pub
RWRJc1FUaeVeqrG9uutGWP6Pevs2GjvVrFAjzplIdI/O/FdPmyN3FZd283Iu1MPyKwpOZOaWUVK3Yc46mpWNKibQHFJ8kcIPzQ0=
SHA256 (Pkgfile) = f0a9ed1e345c630ae26637a350cbdf0df292d3db29dce6c4cb595fcc1b0e09af
RWRJc1FUaeVeqp5KWvTGUWk/m6hTpPUoxRw4IXI/yhv6y6ipSDcgVATjrgfB59LwH6garDLxUPX8nRzH4vpOz3Ot0qFZ+iAzHwI=
SHA256 (Pkgfile) = 4570d772c7f829872e322ccfc618080aa57fe1dfd3e7d4b056fdfa2c03f742b3
SHA256 (.footprint) = d29a69eb36c351c70aecd8daa017736c3849dad5a2445fe682a50540a787c042
SHA256 (libarchive-3.7.2.tar.xz) = 04357661e6717b6941682cde02ad741ae4819c67a260593dfb2431861b251acb
SHA256 (lzma_stream.patch) = 0ef35ac67530d5ae3e4e39d968c4ba72a7a9806e4d98aa16aa8b608c76eb32c8
SHA256 (libarchive-3.7.3.tar.xz) = 63e7a7174638fc7d6b79b4c8b0ad954e0f4f45abe7239c1ecb200232aa9a43d2

View File

@ -4,14 +4,11 @@
# Depends on: acl bzip2 lzo zstd
name=libarchive
version=3.7.2
release=2
source=(https://github.com/libarchive/libarchive/releases/download/v$version/$name-$version.tar.xz
lzma_stream.patch)
version=3.7.3
release=1
source=(https://github.com/libarchive/libarchive/releases/download/v$version/$name-$version.tar.xz)
build() {
patch -Np1 -d $name-$version -i $SRC/lzma_stream.patch
cmake -S $name-$version -B build -G Ninja \
-D CMAKE_INSTALL_PREFIX=/usr \
-D CMAKE_BUILD_TYPE=Release \

View File

@ -1,39 +0,0 @@
From 2ba3d92706384be14cd376734f3f7ebe5648591e Mon Sep 17 00:00:00 2001
From: alice <alice@ayaya.dev>
Date: Sat, 23 Sep 2023 01:57:55 +0200
Subject: [PATCH] fix detection of lzma_stream_encoder_mt with Werror (#1965)
the function is marked as warn-unused-result, so by default in a Debug
build with cmake, when Werror is set, this fails to detect. do the same
for autotools.
---
CMakeLists.txt | 2 +-
configure.ac | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dc1fcc72a..6211fd8ac 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -523,7 +523,7 @@ IF(LIBLZMA_FOUND)
"#include <lzma.h>\nint main() {return (int)lzma_version_number(); }"
"WITHOUT_LZMA_API_STATIC;LZMA_API_STATIC")
CHECK_C_SOURCE_COMPILES(
- "#include <lzma.h>\n#if LZMA_VERSION < 50020000\n#error unsupported\n#endif\nint main(void){lzma_stream_encoder_mt(0, 0); return 0;}"
+ "#include <lzma.h>\n#if LZMA_VERSION < 50020000\n#error unsupported\n#endif\nint main(void){int ignored __attribute__((unused)); ignored = lzma_stream_encoder_mt(0, 0); return 0;}"
HAVE_LZMA_STREAM_ENCODER_MT)
IF(NOT WITHOUT_LZMA_API_STATIC AND LZMA_API_STATIC)
ADD_DEFINITIONS(-DLZMA_API_STATIC)
diff --git a/configure.ac b/configure.ac
index 67235c5d9..79a13b53d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -482,7 +482,7 @@ if test "x$with_lzma" != "xno"; then
[#if LZMA_VERSION < 50020000]
[#error unsupported]
[#endif]],
- [[lzma_stream_encoder_mt(0, 0);]])],
+ [[int ignored __attribute__((unused)); ignored = lzma_stream_encoder_mt(0, 0);]])],
[ac_cv_lzma_has_mt=yes], [ac_cv_lzma_has_mt=no])])
if test "x$ac_cv_lzma_has_mt" != xno; then
AC_DEFINE([HAVE_LZMA_STREAM_ENCODER_MT], [1], [Define to 1 if you have the `lzma_stream_encoder_mt' function.])