exim: added as the replacement for sendmail

This commit is contained in:
Juergen Daubert 2006-11-25 16:20:25 +01:00
parent 6307291b7b
commit cdfe88c5ea
5 changed files with 278 additions and 0 deletions

38
exim/.footprint Normal file
View File

@ -0,0 +1,38 @@
drwxr-xr-x root/root etc/
drwxr-xr-x root/root etc/exim/
-rw-r--r-- root/root etc/exim/aliases
-rw-r--r-- root/root etc/exim/exim.conf
drwxr-xr-x root/root etc/rc.d/
-rwxr-xr-x root/root etc/rc.d/exim
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
lrwxrwxrwx root/root usr/bin/mailq -> ../sbin/exim-4.63-1
drwxr-xr-x root/root usr/man/
drwxr-xr-x root/root usr/man/man8/
-rw-r--r-- root/root usr/man/man8/exim.8.gz
drwxr-xr-x root/root usr/sbin/
-rwxr-xr-x root/root usr/sbin/exicyclog
-rwxr-xr-x root/root usr/sbin/exigrep
lrwxrwxrwx root/root usr/sbin/exim -> exim-4.63-1
-rwsr-xr-x root/root usr/sbin/exim-4.63-1
-rwxr-xr-x root/root usr/sbin/exim_checkaccess
-rwxr-xr-x root/root usr/sbin/exim_dbmbuild
-rwxr-xr-x root/root usr/sbin/exim_dumpdb
-rwxr-xr-x root/root usr/sbin/exim_fixdb
-rwxr-xr-x root/root usr/sbin/exim_lock
-rwxr-xr-x root/root usr/sbin/exim_tidydb
-rwxr-xr-x root/root usr/sbin/eximstats
-rwxr-xr-x root/root usr/sbin/exinext
-rwxr-xr-x root/root usr/sbin/exipick
-rwxr-xr-x root/root usr/sbin/exiqgrep
-rwxr-xr-x root/root usr/sbin/exiqsumm
-rwxr-xr-x root/root usr/sbin/exiwhat
lrwxrwxrwx root/root usr/sbin/sendmail -> exim-4.63-1
drwxr-xr-x root/root var/
drwxr-xr-x root/root var/log/
drwxr-x--- mail/mail var/log/exim/
-rw-r----- mail/mail var/log/exim/exim_mainlog (EMPTY)
-rw-r----- mail/mail var/log/exim/exim_paniclog (EMPTY)
-rw-r----- mail/mail var/log/exim/exim_rejectlog (EMPTY)
drwxr-xr-x root/root var/spool/
drwxr-x--- mail/mail var/spool/exim/

3
exim/.md5sum Normal file
View File

@ -0,0 +1,3 @@
f1682811a7fd2897153c5b0e33177509 exim
dde2d5f7106d51607409af94174db46c exim-4.63.tar.bz2
acc159b50022cb2e1574df1bde2d9784 exim-config.patch

33
exim/Pkgfile Normal file
View File

@ -0,0 +1,33 @@
# Description: Mail transfer agent
# URL: http://www.exim.org
# Maintainer: Juergen Daubert, juergen dot daubert at t-online dot de
# Depends on: db, openssl
name=exim
version=4.63
release=2
source=(ftp://ftp.exim.org/pub/exim/exim4/$name-$version.tar.bz2 \
$name $name-config.patch)
build() {
cd $name-$version
sed "s/#CFLAGS#/$CFLAGS/" $SRC/$name-config.patch | patch -p1
cp src/EDITME Local/Makefile
make
make DESTDIR=$PKG install
install -D -m 755 $SRC/exim $PKG/etc/rc.d/exim
install -D -m 644 doc/exim.8 $PKG/usr/man/man8/exim.8
install -d $PKG/var/{log,spool} $PKG/usr/bin
install -d -m 0750 -o mail -g mail $PKG/var/{log,spool}/exim
touch $PKG/var/log/exim/exim_{mainlog,paniclog,rejectlog}
chown mail:mail $PKG/var/log/exim/*
chmod 640 $PKG/var/log/exim/*
ln -sf $name-$version-1 $PKG/usr/sbin/sendmail
ln -sf ../sbin/$name-$version-1 $PKG/usr/bin/mailq
}

26
exim/exim Normal file
View File

@ -0,0 +1,26 @@
#!/bin/sh
#
# /etc/rc.d/exim: start/stop exim daemon
#
case $1 in
start)
/usr/sbin/exim -bd -q15m
;;
stop)
killall -q /usr/sbin/exim
;;
restart)
$0 stop
sleep 2
$0 start
;;
reload)
kill -s SIGHUP `pidof exim`
;;
*)
echo "usage: $0 [start|stop|restart|reload]"
;;
esac
# End of file

178
exim/exim-config.patch Normal file
View File

@ -0,0 +1,178 @@
diff -Nru exim-4.63.orig/src/EDITME exim-4.63/src/EDITME
--- exim-4.63.orig/src/EDITME 2006-11-10 17:10:12.000000000 +0100
+++ exim-4.63/src/EDITME 2006-11-10 17:10:25.000000000 +0100
@@ -74,7 +74,7 @@
# this would be wanted.
###############################################################################
-
+CFLAGS=#CFLAGS#
###############################################################################
# THESE ARE THINGS YOU MUST SPECIFY #
@@ -100,7 +100,7 @@
# /usr/local/sbin. The installation script will try to create this directory,
# and any superior directories, if they do not exist.
-BIN_DIRECTORY=/usr/exim/bin
+BIN_DIRECTORY=/usr/sbin
#------------------------------------------------------------------------------
@@ -116,7 +116,7 @@
# don't exist. It will also install a default runtime configuration if this
# file does not exist.
-CONFIGURE_FILE=/usr/exim/configure
+CONFIGURE_FILE=/etc/exim/exim.conf
# It is possible to specify a colon-separated list of files for CONFIGURE_FILE.
# In this case, Exim will use the first of them that exists when it is run.
@@ -134,7 +134,7 @@
# owner of a local mailbox.) Specifying these values as root is very strongly
# discouraged.
-EXIM_USER=
+EXIM_USER=ref:mail
# If you specify EXIM_USER as a name, this is looked up at build time, and the
# uid number is built into the binary. However, you can specify that this
@@ -244,7 +244,7 @@
# MBX, is included only when requested. If you do not know what this is about,
# leave these settings commented out.
-# SUPPORT_MAILDIR=yes
+SUPPORT_MAILDIR=yes
# SUPPORT_MAILSTORE=yes
# SUPPORT_MBX=yes
@@ -261,9 +261,9 @@
LOOKUP_DBM=yes
LOOKUP_LSEARCH=yes
-# LOOKUP_CDB=yes
+LOOKUP_CDB=yes
# LOOKUP_DNSDB=yes
-# LOOKUP_DSEARCH=yes
+LOOKUP_DSEARCH=yes
# LOOKUP_IBASE=yes
# LOOKUP_LDAP=yes
# LOOKUP_MYSQL=yes
@@ -320,7 +320,7 @@
# files are defaulted in the OS/Makefile-Default file, but can be overridden in
# local OS-specific make files.
-EXIM_MONITOR=eximon.bin
+# EXIM_MONITOR=eximon.bin
#------------------------------------------------------------------------------
@@ -473,9 +473,9 @@
# included in the Exim binary. You will then need to set up the run time
# configuration to make use of the mechanism(s) selected.
-# AUTH_CRAM_MD5=yes
+AUTH_CRAM_MD5=yes
# AUTH_CYRUS_SASL=yes
-# AUTH_PLAINTEXT=yes
+AUTH_PLAINTEXT=yes
# AUTH_SPA=yes
@@ -562,10 +562,10 @@
# leave these settings commented out.
# This setting is required for any TLS support (either OpenSSL or GnuTLS)
-# SUPPORT_TLS=yes
+SUPPORT_TLS=yes
# Uncomment this setting if you are using OpenSSL
-# TLS_LIBS=-lssl -lcrypto
+TLS_LIBS=-lssl -lcrypto
# Uncomment these settings if you are using GnuTLS
# USE_GNUTLS=yes
@@ -629,7 +629,7 @@
# %s. This will be replaced by one of the strings "main", "panic", or "reject"
# to form the final file names. Some installations may want something like this:
-# LOG_FILE_PATH=/var/log/exim_%slog
+LOG_FILE_PATH=/var/log/exim/exim_%slog
# which results in files with names /var/log/exim_mainlog, etc. The directory
# in which the log files are placed must exist; Exim does not try to create
@@ -678,7 +678,7 @@
# files. Both the name of the command and the suffix that it adds to files
# need to be defined here. See also the EXICYCLOG_MAX configuration.
-COMPRESS_COMMAND=/usr/bin/gzip
+COMPRESS_COMMAND=/bin/gzip
COMPRESS_SUFFIX=gz
@@ -686,7 +686,7 @@
# If the exigrep utility is fed compressed log files, it tries to uncompress
# them using this command.
-ZCAT_COMMAND=/usr/bin/zcat
+ZCAT_COMMAND=/bin/zcat
#------------------------------------------------------------------------------
@@ -796,9 +796,9 @@
# You may well also have to specify a local "include" file and an additional
# library for TCP wrappers, so you probably need something like this:
#
-# USE_TCP_WRAPPERS=yes
+USE_TCP_WRAPPERS=yes
# CFLAGS=-O -I/usr/local/include
-# EXTRALIBS_EXIM=-L/usr/local/lib -lwrap
+EXTRALIBS_EXIM=-lwrap
#
# but of course there may need to be other things in CFLAGS and EXTRALIBS_EXIM
# as well.
@@ -824,7 +824,7 @@
# aliases). The following setting can be changed to specify a different
# location for the system alias file.
-SYSTEM_ALIASES_FILE=/etc/aliases
+SYSTEM_ALIASES_FILE=/etc/exim/aliases
#------------------------------------------------------------------------------
@@ -870,10 +870,10 @@
# haven't got Perl, Exim will still build and run; you just won't be able to
# use those utilities.
-# CHOWN_COMMAND=/usr/bin/chown
-# CHGRP_COMMAND=/usr/bin/chgrp
-# MV_COMMAND=/bin/mv
-# RM_COMMAND=/bin/rm
+CHOWN_COMMAND=/bin/chown
+CHGRP_COMMAND=/bin/chgrp
+MV_COMMAND=/bin/mv
+RM_COMMAND=/bin/rm
# PERL_COMMAND=/usr/bin/perl
@@ -1068,7 +1068,7 @@
# (process id) to a file so that it can easily be identified. The path of the
# file can be specified here. Some installations may want something like this:
-# PID_FILE_PATH=/var/lock/exim.pid
+PID_FILE_PATH=/var/run/exim.pid
# If PID_FILE_PATH is not defined, Exim writes a file in its spool directory
# using the name "exim-daemon.pid".
diff -Nru exim-4.63.orig/src/configure.default exim-4.63/src/configure.default
--- exim-4.63.orig/src/configure.default 2006-11-10 17:10:12.000000000 +0100
+++ exim-4.63/src/configure.default 2006-11-10 17:11:00.000000000 +0100
@@ -56,7 +56,7 @@
# +local_domains, +relay_to_domains, and +relay_from_hosts, respectively. They
# are all colon-separated lists:
-domainlist local_domains = @
+domainlist local_domains = @ : localhost
domainlist relay_to_domains =
hostlist relay_from_hosts = 127.0.0.1