bzip2: create the libbz2.so symlink, d'oh.

This commit is contained in:
Tilman Sauerbeck 2006-12-06 20:59:21 +01:00
parent f6bc2570ea
commit e147b05158
3 changed files with 6 additions and 4 deletions

View File

@ -15,6 +15,7 @@ drwxr-xr-x root/root usr/include/
-rw-r--r-- root/root usr/include/bzlib.h
drwxr-xr-x root/root usr/lib/
-rw-r--r-- root/root usr/lib/libbz2.a
lrwxrwxrwx root/root usr/lib/libbz2.so -> libbz2.so.1.0
lrwxrwxrwx root/root usr/lib/libbz2.so.1.0 -> libbz2.so.1.0.3
-rwxr-xr-x root/root usr/lib/libbz2.so.1.0.3
drwxr-xr-x root/root usr/man/

View File

@ -1,2 +1,2 @@
14bd083396fccc32b3cb5e9726e4fffe bzip2-1.0.3.patch
d64c8510a3f3e0ba5e821fc7df83997d bzip2-1.0.3.patch
8a716bebecb6e647d2e8a29ea5d8447f bzip2-1.0.3.tar.gz

View File

@ -1,6 +1,6 @@
diff -aur bzip2-1.0.3.orig/Makefile bzip2-1.0.3/Makefile
--- bzip2-1.0.3.orig/Makefile 2005-02-17 12:28:24.000000000 +0100
+++ bzip2-1.0.3/Makefile 2006-04-06 18:23:10.000000000 +0200
+++ bzip2-1.0.3/Makefile 2006-12-06 20:56:42.971829461 +0100
@@ -8,7 +8,7 @@
LDFLAGS=
@ -86,7 +86,7 @@ diff -aur bzip2-1.0.3.orig/Makefile bzip2-1.0.3/Makefile
rm -f *.o libbz2.a bzip2 bzip2recover \
diff -aur bzip2-1.0.3.orig/Makefile-libbz2_so bzip2-1.0.3/Makefile-libbz2_so
--- bzip2-1.0.3.orig/Makefile-libbz2_so 2004-10-17 19:32:13.000000000 +0200
+++ bzip2-1.0.3/Makefile-libbz2_so 2006-04-06 18:10:21.000000000 +0200
+++ bzip2-1.0.3/Makefile-libbz2_so 2006-12-06 20:57:09.201468711 +0100
@@ -9,7 +9,7 @@
SHELL=/bin/sh
CC=gcc
@ -96,7 +96,7 @@ diff -aur bzip2-1.0.3.orig/Makefile-libbz2_so bzip2-1.0.3/Makefile-libbz2_so
OBJS= blocksort.o \
huffman.o \
@@ -22,11 +22,14 @@
@@ -22,11 +22,15 @@
all: $(OBJS)
$(CC) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.3 $(OBJS)
$(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.3
@ -107,6 +107,7 @@ diff -aur bzip2-1.0.3.orig/Makefile-libbz2_so bzip2-1.0.3/Makefile-libbz2_so
+ install -d $(PREFIX)/lib
+ install -m 755 libbz2.so.1.0.3 $(PREFIX)/lib
+ ln -sf libbz2.so.1.0.3 $(PREFIX)/lib/libbz2.so.1.0
+ ln -sf libbz2.so.1.0 $(PREFIX)/lib/libbz2.so
clean:
- rm -f $(OBJS) bzip2.o libbz2.so.1.0.3 libbz2.so.1.0 bzip2-shared