[notify] openssl: update to 0.9.8j
Security fix, see http://www.openssl.org/news/secadv_20090107.txt
This commit is contained in:
parent
220ec5c41a
commit
fed8bf27d5
@ -1,3 +1,2 @@
|
||||
9d0df57845af8acd1027a7df5c18d017 mksslcert.sh
|
||||
58daa890c3bc19bd6ce3451b2e5e335c openssl-0.9.8b-parallel-build.patch
|
||||
561e00f18821c74b2b86c8c7786f9d8b openssl-0.9.8i.tar.gz
|
||||
a5cb5f6c3d11affb387ecf7a997cac0c openssl-0.9.8j.tar.gz
|
||||
|
@ -3,18 +3,17 @@
|
||||
# Maintainer: CRUX System Team, core-ports at crux dot nu
|
||||
|
||||
name=openssl
|
||||
version=0.9.8i
|
||||
version=0.9.8j
|
||||
release=1
|
||||
source=(http://www.openssl.org/source/$name-$version.tar.gz \
|
||||
mksslcert.sh openssl-0.9.8b-parallel-build.patch)
|
||||
mksslcert.sh)
|
||||
|
||||
build() {
|
||||
cd $name-$version
|
||||
patch -p1 -i $SRC/openssl-0.9.8b-parallel-build.patch
|
||||
./config --prefix=/usr --openssldir=/etc/ssl shared
|
||||
make
|
||||
make -j1
|
||||
make INSTALL_PREFIX=$PKG MANDIR=/usr/man MANSUFFIX=ssl install
|
||||
find $PKG -name "*fips*" -delete
|
||||
chmod -R +w $PKG
|
||||
install -D -m 755 ../mksslcert.sh $PKG/usr/bin/mksslcert
|
||||
install -D -m 755 $SRC/mksslcert.sh $PKG/usr/bin/mksslcert
|
||||
}
|
||||
|
@ -1,26 +0,0 @@
|
||||
Parallel make fix, from
|
||||
http://sources.gentoo.org/viewcvs.py/gentoo-x86/dev-libs/openssl/files/
|
||||
|
||||
--- openssl-0.9.8b/Makefile.org
|
||||
+++ openssl-0.9.8b/Makefile.org
|
||||
@@ -229,15 +229,15 @@
|
||||
|
||||
build_crypto:
|
||||
@dir=crypto; target=all; $(BUILD_ONE_CMD)
|
||||
-build_ssl:
|
||||
+build_ssl: build_crypto
|
||||
@dir=ssl; target=all; $(BUILD_ONE_CMD)
|
||||
-build_engines:
|
||||
+build_engines: build_crypto
|
||||
@dir=engines; target=all; $(BUILD_ONE_CMD)
|
||||
-build_apps:
|
||||
+build_apps: build_libs
|
||||
@dir=apps; target=all; $(BUILD_ONE_CMD)
|
||||
-build_tests:
|
||||
+build_tests: build_libs
|
||||
@dir=test; target=all; $(BUILD_ONE_CMD)
|
||||
-build_tools:
|
||||
+build_tools: build_libs
|
||||
@dir=tools; target=all; $(BUILD_ONE_CMD)
|
||||
|
||||
all_testapps: build_libs build_testapps
|
Loading…
x
Reference in New Issue
Block a user