core/tzdata/tzcode-makefile.patch

129 lines
3.8 KiB
Diff

# http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/sys-libs/timezone-data/files/timezone-data-2012a-makefile.patch
diff -Nru tzcode.orig/Makefile tzcode/Makefile
--- tzcode.orig/Makefile 2012-09-13 10:25:47.698561812 +0200
+++ tzcode/Makefile 2012-09-13 10:31:12.070115537 +0200
@@ -39,17 +39,17 @@
# Everything gets put in subdirectories of. . .
-TOPDIR= /usr/local
+TOPDIR= $(DESTDIR)/usr
# "Compiled" time zone information is placed in the "TZDIR" directory
# (and subdirectories).
# Use an absolute path name for TZDIR unless you're just testing the software.
-TZDIR= $(TOPDIR)/etc/zoneinfo
+TZDIR= $(TOPDIR)/share/zoneinfo
# The "tzselect", "zic", and "zdump" commands get installed in. . .
-ETCDIR= $(TOPDIR)/etc
+SBINDIR= $(TOPDIR)/sbin
# If you "make INSTALL", the "date" command gets installed in. . .
@@ -223,7 +223,7 @@
ZIC= $(zic) $(ZFLAGS)
# The name of a Posix-compliant `awk' on your system.
-AWK= nawk
+AWK= awk
# The path where SGML DTDs are kept.
# The default is appropriate for Ubuntu.
@@ -257,8 +257,10 @@
###############################################################################
-cc= cc
-CC= $(cc) -DTZDIR=\"$(TZDIR)\"
+CC+= -DTZDIR=\"$(TZDIR)\"
+ifeq ($(NLS),1)
+CC += -DHAVE_GETTEXT=1 -DTZ_DOMAIN=\"libc\"
+endif
TZCSRCS= zic.c localtime.c asctime.c scheck.c ialloc.c
TZCOBJS= zic.o localtime.o asctime.o scheck.o ialloc.o
@@ -298,13 +300,15 @@
ALL: all date
-install: all $(DATA) $(REDO) $(TZLIB) $(MANS) $(TABDATA)
+install: all $(DATA) $(REDO) $(MANS) $(TABDATA)
$(ZIC) -y $(YEARISTYPE) \
-d $(TZDIR) -l $(LOCALTIME) -p $(POSIXRULES)
-rm -f $(TZDIR)/iso3166.tab $(TZDIR)/zone.tab
cp iso3166.tab zone.tab $(TZDIR)/.
- -mkdir $(TOPDIR) $(ETCDIR)
- cp tzselect zic zdump $(ETCDIR)/.
+ -mkdir $(TOPDIR) $(SBINDIR)
+ cp zic zdump $(SBINDIR)/.
+ -mkdir $(TOPDIR) $(BINDIR)
+ cp tzselect $(BINDIR)/.
-mkdir $(TOPDIR) $(MANDIR) \
$(MANDIR)/man3 $(MANDIR)/man5 $(MANDIR)/man8
-rm -f $(MANDIR)/man3/newctime.3 \
@@ -314,8 +318,6 @@
$(MANDIR)/man8/zdump.8 \
$(MANDIR)/man8/zic.8
cp newctime.3 newtzset.3 $(MANDIR)/man3/.
- cp tzfile.5 $(MANDIR)/man5/.
- cp tzselect.8 zdump.8 zic.8 $(MANDIR)/man8/.
INSTALL: ALL install date.1
-mkdir $(TOPDIR) $(BINDIR)
@@ -329,10 +331,10 @@
'static char const TZVERSION[]="tz$(VERSION)";'
zdump: $(TZDOBJS)
- $(CC) $(CFLAGS) $(LFLAGS) $(TZDOBJS) $(LDLIBS) -o $@
+ $(CC) $(CFLAGS) $(LDFLAGS) $(TZDOBJS) $(LDLIBS) -o $@
zic: $(TZCOBJS) yearistype
- $(CC) $(CFLAGS) $(LFLAGS) $(TZCOBJS) $(LDLIBS) -o $@
+ $(CC) $(CFLAGS) $(LDFLAGS) $(TZCOBJS) $(LDLIBS) -o $@
yearistype: yearistype.sh
cp yearistype.sh yearistype
@@ -354,9 +356,9 @@
# You must replace all of $(TZDIR) to switch from not using leap seconds
# to using them, or vice versa.
other_two: zic leapseconds $(TDATA)
- $(ZIC) -y $(YEARISTYPE) -d $(TZDIR)-posix -L /dev/null $(TDATA)
+ $(ZIC) -y $(YEARISTYPE) -d $(TZDIR)/posix -L /dev/null $(TDATA)
$(ZIC) -y $(YEARISTYPE) \
- -d $(TZDIR)-leaps -L leapseconds $(TDATA)
+ -d $(TZDIR)/right -L leapseconds $(TDATA)
posix_right: posix_only other_two
@@ -371,7 +373,7 @@
then ranlib $@ ; fi
date: $(DATEOBJS)
- $(CC) $(CFLAGS) date.o localtime.o asctime.o strftime.o \
+ $(CC) $(CFLAGS) $(LDFLAGS) date.o localtime.o asctime.o strftime.o \
$(LDLIBS) -lc -o $@
tzselect: tzselect.ksh
@@ -382,7 +384,7 @@
<$? >$@
chmod +x $@
-check: check_tables check_web
+check: check_tables
check_tables: checktab.awk $(PRIMARY_YDATA)
$(AWK) -f checktab.awk $(PRIMARY_YDATA)
diff -Nru tzcode.orig/tzselect.ksh tzcode/tzselect.ksh
--- tzcode.orig/tzselect.ksh 2012-09-13 10:25:47.698561812 +0200
+++ tzcode/tzselect.ksh 2012-09-13 10:26:06.107893321 +0200
@@ -1,4 +1,4 @@
-#! /bin/ksh
+#! /bin/bash
TZVERSION=see_Makefile