core/glibc/glibc-fedora_i686.patch
2010-08-09 22:56:41 +02:00

41 lines
1.3 KiB
Diff

# http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=3aba072d90b500e76f7f1cb06c659fb3cf02c6b8
# 2010-08-03: reapplied for glibc 2.12.1
commit 3aba072d90b500e76f7f1cb06c659fb3cf02c6b8
Author: Jakub Jelinek <jakub@redhat.com>
Date: Wed Jul 22 13:23:08 2009 +0200
Undefine __i686 on x86.
diff -Nru glibc-2.12.1.orig/Makeconfig glibc-2.12.1/Makeconfig
--- glibc-2.12.1.orig/Makeconfig 2010-07-27 13:34:39.000000000 +0200
+++ glibc-2.12.1/Makeconfig 2010-08-03 23:10:22.519954554 +0200
@@ -789,12 +789,12 @@
# The assembler can generate debug information too.
ifndef ASFLAGS
ifeq ($(have-cpp-asm-debuginfo),yes)
-ASFLAGS := $(filter -g% -fdebug-prefix-map=%,$(CFLAGS))
+ASFLAGS = $(filter -g% -fdebug-prefix-map=%,$(CFLAGS))
else
-ASFLAGS :=
+ASFLAGS =
endif
endif
-ASFLAGS += $(ASFLAGS-config) $(asflags-cpu)
+ASFLAGS += $(ASFLAGS-config) $(asflags-cpu) $(sysdep-ASFLAGS)
ifndef BUILD_CC
BUILD_CC = $(CC)
diff -Nru glibc-2.12.1.orig/sysdeps/i386/Makefile glibc-2.12.1/sysdeps/i386/Makefile
--- glibc-2.12.1.orig/sysdeps/i386/Makefile 2010-07-27 13:34:39.000000000 +0200
+++ glibc-2.12.1/sysdeps/i386/Makefile 2010-08-03 23:12:02.319954272 +0200
@@ -2,6 +2,8 @@
# Every i386 port in use uses gas syntax (I think).
asm-CPPFLAGS += -DGAS_SYNTAX
+sysdep-ASFLAGS += -U__i686
+
# The i386 `long double' is a distinct type we support.
long-double-fcts = yes