75 lines
2.2 KiB
Diff
75 lines
2.2 KiB
Diff
diff -Nru lilo-23.1.orig/Makefile lilo-23.1/Makefile
|
|
--- lilo-23.1.orig/Makefile 2010-11-04 22:09:25.719135864 +0100
|
|
+++ lilo-23.1/Makefile 2010-11-04 22:22:16.818249883 +0100
|
|
@@ -31,7 +31,6 @@
|
|
#
|
|
all: test
|
|
make -C src all
|
|
- make -C images all
|
|
|
|
#
|
|
# everything above plus the statically linked version
|
|
@@ -98,11 +97,7 @@
|
|
#
|
|
install: all
|
|
make -C src install
|
|
- make -C images install
|
|
- make -C hooks install
|
|
- make -C sample install
|
|
make -C man install
|
|
- make -C dos install
|
|
|
|
tidy:
|
|
make -C src tidy
|
|
diff -Nru lilo-23.1.orig/make.vars lilo-23.1/make.vars
|
|
--- lilo-23.1.orig/make.vars 2010-11-04 22:09:25.729135204 +0100
|
|
+++ lilo-23.1/make.vars 2010-11-04 22:09:42.238043855 +0100
|
|
@@ -64,14 +64,14 @@
|
|
# XL_SECS=n Support for extra large (non-standard) floppies.
|
|
|
|
CONFIG=-DBDATA -DDSECS=3 -DEVMS -DIGNORECASE -DLVM -DNOKEYBOARD -DONE_SHOT \
|
|
- -DPASS160 -DREISERFS -DREWRITE_TABLE -DSOLO_CHAIN -DVERSION -DVIRTUAL \
|
|
+ -DPASS160 -DREISERFS -DREWRITE_TABLE -DSOLO_CHAIN -DVIRTUAL \
|
|
-DMDPRAID -DDEVMAPPER
|
|
|
|
# set the following if you wish LILO.COM to be installed
|
|
DOS_DIR=/dosC/boot
|
|
|
|
# select place for man pages
|
|
-MAN_DIR=/usr/share/man
|
|
+MAN_DIR=/usr/man
|
|
|
|
# set the compiler optimization level
|
|
OPT=-Os
|
|
diff -Nru lilo-23.1.orig/man/Makefile lilo-23.1/man/Makefile
|
|
--- lilo-23.1.orig/man/Makefile 2010-11-04 22:09:25.729135204 +0100
|
|
+++ lilo-23.1/man/Makefile 2010-11-04 22:11:03.362700117 +0100
|
|
@@ -10,7 +10,6 @@
|
|
mkdir -p $$DESTDIR$(MAN_DIR)/man8
|
|
|
|
install -m 0644 lilo.8 $$DESTDIR$(MAN_DIR)/man8
|
|
- install -m 0644 mkrescue.8 $$DESTDIR$(MAN_DIR)/man8
|
|
install -m 0644 lilo.conf.5 $$DESTDIR$(MAN_DIR)/man5
|
|
install -m 0644 keytab-lilo.8 $$DESTDIR$(MAN_DIR)/man8
|
|
|
|
diff -Nru lilo-23.1.orig/src/Makefile lilo-23.1/src/Makefile
|
|
--- lilo-23.1.orig/src/Makefile 2010-11-04 22:09:25.729135204 +0100
|
|
+++ lilo-23.1/src/Makefile 2010-11-04 22:12:14.048027820 +0100
|
|
@@ -41,7 +41,7 @@
|
|
#
|
|
# everything needed to run, just short of installation
|
|
#
|
|
-all: lilo bootsect.b
|
|
+all: lilo
|
|
|
|
#
|
|
# everything above plus the statically linked version
|
|
@@ -245,7 +245,6 @@
|
|
|
|
cp lilo $$DESTDIR$(SBIN_DIR)/lilo
|
|
strip $$DESTDIR$(SBIN_DIR)/lilo
|
|
- cp ../mkrescue $$DESTDIR$(USRSBIN_DIR)/mkrescue
|
|
cp ../keytab-lilo.pl $$DESTDIR$(USRSBIN_DIR)/keytab-lilo
|
|
|
|
dep:
|