207 lines
6.7 KiB
Diff
207 lines
6.7 KiB
Diff
diff -Nru exim-4.90.orig/src/EDITME exim-4.90/src/EDITME
|
|
--- exim-4.90.orig/src/EDITME 2017-12-20 16:30:35.245052912 +0100
|
|
+++ exim-4.90/src/EDITME 2017-12-20 16:31:00.290828590 +0100
|
|
@@ -72,7 +72,7 @@
|
|
# this would be wanted.
|
|
###############################################################################
|
|
|
|
-
|
|
+CFLAGS=#CFLAGS#
|
|
|
|
###############################################################################
|
|
# THESE ARE THINGS YOU MUST SPECIFY #
|
|
@@ -98,7 +98,7 @@
|
|
# /usr/local/sbin. The installation script will try to create this directory,
|
|
# and any superior directories, if they do not exist.
|
|
|
|
-BIN_DIRECTORY=/usr/exim/bin
|
|
+BIN_DIRECTORY=/usr/sbin
|
|
|
|
|
|
#------------------------------------------------------------------------------
|
|
@@ -114,7 +114,7 @@
|
|
# don't exist. It will also install a default runtime configuration if this
|
|
# file does not exist.
|
|
|
|
-CONFIGURE_FILE=/usr/exim/configure
|
|
+CONFIGURE_FILE=/etc/exim/exim.conf
|
|
|
|
# It is possible to specify a colon-separated list of files for CONFIGURE_FILE.
|
|
# In this case, Exim will use the first of them that exists when it is run.
|
|
@@ -131,7 +131,7 @@
|
|
# deliveries. (Local deliveries run as various non-root users, typically as the
|
|
# owner of a local mailbox.) Specifying these values as root is not supported.
|
|
|
|
-EXIM_USER=
|
|
+EXIM_USER=ref:mail
|
|
|
|
# If you specify EXIM_USER as a name, this is looked up at build time, and the
|
|
# uid number is built into the binary. However, you can specify that this
|
|
@@ -246,7 +246,7 @@
|
|
# MBX, is included only when requested. If you do not know what this is about,
|
|
# leave these settings commented out.
|
|
|
|
-# SUPPORT_MAILDIR=yes
|
|
+SUPPORT_MAILDIR=yes
|
|
# SUPPORT_MAILSTORE=yes
|
|
# SUPPORT_MBX=yes
|
|
|
|
@@ -306,8 +306,8 @@
|
|
LOOKUP_LSEARCH=yes
|
|
LOOKUP_DNSDB=yes
|
|
|
|
-# LOOKUP_CDB=yes
|
|
-# LOOKUP_DSEARCH=yes
|
|
+LOOKUP_CDB=yes
|
|
+LOOKUP_DSEARCH=yes
|
|
# LOOKUP_IBASE=yes
|
|
# LOOKUP_LDAP=yes
|
|
# LOOKUP_MYSQL=yes
|
|
@@ -386,7 +386,7 @@
|
|
# files are defaulted in the OS/Makefile-Default file, but can be overridden in
|
|
# local OS-specific make files.
|
|
|
|
-EXIM_MONITOR=eximon.bin
|
|
+# EXIM_MONITOR=eximon.bin
|
|
|
|
|
|
#------------------------------------------------------------------------------
|
|
@@ -629,7 +629,7 @@
|
|
# included in the Exim binary. You will then need to set up the run time
|
|
# configuration to make use of the mechanism(s) selected.
|
|
|
|
-# AUTH_CRAM_MD5=yes
|
|
+AUTH_CRAM_MD5=yes
|
|
# AUTH_CYRUS_SASL=yes
|
|
# AUTH_DOVECOT=yes
|
|
# AUTH_GSASL=yes
|
|
@@ -637,7 +637,7 @@
|
|
# AUTH_HEIMDAL_GSSAPI=yes
|
|
# AUTH_HEIMDAL_GSSAPI_PC=heimdal-gssapi
|
|
# AUTH_HEIMDAL_GSSAPI_PC=heimdal-gssapi heimdal-krb5
|
|
-# AUTH_PLAINTEXT=yes
|
|
+AUTH_PLAINTEXT=yes
|
|
# AUTH_SPA=yes
|
|
# AUTH_TLS=yes
|
|
|
|
@@ -752,10 +752,10 @@
|
|
# leave these settings commented out.
|
|
|
|
# This setting is required for any TLS support (either OpenSSL or GnuTLS)
|
|
-# SUPPORT_TLS=yes
|
|
+SUPPORT_TLS=yes
|
|
|
|
# Uncomment one of these settings if you are using OpenSSL; pkg-config vs not
|
|
-# USE_OPENSSL_PC=openssl
|
|
+USE_OPENSSL_PC=openssl
|
|
# TLS_LIBS=-lssl -lcrypto
|
|
|
|
# Uncomment the first and either the second or the third of these if you
|
|
@@ -838,7 +838,7 @@
|
|
# %s. This will be replaced by one of the strings "main", "panic", or "reject"
|
|
# to form the final file names. Some installations may want something like this:
|
|
|
|
-# LOG_FILE_PATH=/var/log/exim_%slog
|
|
+LOG_FILE_PATH=/var/log/exim/exim_%slog
|
|
|
|
# which results in files with names /var/log/exim_mainlog, etc. The directory
|
|
# in which the log files are placed must exist; Exim does not try to create
|
|
@@ -887,7 +887,7 @@
|
|
# files. Both the name of the command and the suffix that it adds to files
|
|
# need to be defined here. See also the EXICYCLOG_MAX configuration.
|
|
|
|
-COMPRESS_COMMAND=/usr/bin/gzip
|
|
+COMPRESS_COMMAND=/bin/gzip
|
|
COMPRESS_SUFFIX=gz
|
|
|
|
|
|
@@ -902,7 +902,7 @@
|
|
# ZCAT_COMMAND=zcat
|
|
#
|
|
# Or specify the full pathname:
|
|
-ZCAT_COMMAND=/usr/bin/zcat
|
|
+ZCAT_COMMAND=/bin/zcat
|
|
|
|
#------------------------------------------------------------------------------
|
|
# Compiling in support for embedded Perl: If you want to be able to
|
|
@@ -1043,7 +1043,7 @@
|
|
#
|
|
# USE_TCP_WRAPPERS=yes
|
|
# CFLAGS=-O -I/usr/local/include
|
|
-# EXTRALIBS_EXIM=-L/usr/local/lib -lwrap
|
|
+# EXTRALIBS_EXIM=-lwrap
|
|
#
|
|
# but of course there may need to be other things in CFLAGS and EXTRALIBS_EXIM
|
|
# as well.
|
|
@@ -1076,7 +1076,7 @@
|
|
# aliases). The following setting can be changed to specify a different
|
|
# location for the system alias file.
|
|
|
|
-SYSTEM_ALIASES_FILE=/etc/aliases
|
|
+SYSTEM_ALIASES_FILE=/etc/exim/aliases
|
|
|
|
|
|
#------------------------------------------------------------------------------
|
|
@@ -1112,7 +1112,7 @@
|
|
#------------------------------------------------------------------------------
|
|
# Uncomment this setting to include IPv6 support.
|
|
|
|
-# HAVE_IPV6=yes
|
|
+HAVE_IPV6=yes
|
|
|
|
###############################################################################
|
|
# THINGS YOU ALMOST NEVER NEED TO MENTION #
|
|
@@ -1133,13 +1133,13 @@
|
|
# haven't got Perl, Exim will still build and run; you just won't be able to
|
|
# use those utilities.
|
|
|
|
-# CHOWN_COMMAND=/usr/bin/chown
|
|
-# CHGRP_COMMAND=/usr/bin/chgrp
|
|
-# CHMOD_COMMAND=/usr/bin/chmod
|
|
-# MV_COMMAND=/bin/mv
|
|
-# RM_COMMAND=/bin/rm
|
|
-# TOUCH_COMMAND=/usr/bin/touch
|
|
-# PERL_COMMAND=/usr/bin/perl
|
|
+CHOWN_COMMAND=/bin/chown
|
|
+CHGRP_COMMAND=/bin/chgrp
|
|
+CHMOD_COMMAND=/bin/chmod
|
|
+MV_COMMAND=/bin/mv
|
|
+RM_COMMAND=/bin/rm
|
|
+TOUCH_COMMAND=/bin/touch
|
|
+PERL_COMMAND=/usr/bin/perl
|
|
|
|
|
|
#------------------------------------------------------------------------------
|
|
@@ -1341,7 +1341,7 @@
|
|
# (process id) to a file so that it can easily be identified. The path of the
|
|
# file can be specified here. Some installations may want something like this:
|
|
|
|
-# PID_FILE_PATH=/var/lock/exim.pid
|
|
+PID_FILE_PATH=/var/run/exim.pid
|
|
|
|
# If PID_FILE_PATH is not defined, Exim writes a file in its spool directory
|
|
# using the name "exim-daemon.pid".
|
|
diff -Nru exim-4.90.orig/src/configure.default exim-4.90/src/configure.default
|
|
--- exim-4.90.orig/src/configure.default 2017-12-20 16:30:35.248386126 +0100
|
|
+++ exim-4.90/src/configure.default 2017-12-20 16:31:00.294161806 +0100
|
|
@@ -55,7 +55,7 @@
|
|
# +local_domains, +relay_to_domains, and +relay_from_hosts, respectively. They
|
|
# are all colon-separated lists:
|
|
|
|
-domainlist local_domains = @
|
|
+domainlist local_domains = @ : localhost
|
|
domainlist relay_to_domains =
|
|
hostlist relay_from_hosts = localhost
|
|
# (We rely upon hostname resolution working for localhost, because the default
|
|
@@ -150,8 +150,8 @@
|
|
# need the first setting, or in separate files, in which case you need both
|
|
# options.
|
|
|
|
-# tls_certificate = /etc/ssl/exim.crt
|
|
-# tls_privatekey = /etc/ssl/exim.pem
|
|
+tls_certificate = /etc/ssl/certs/exim.crt
|
|
+tls_privatekey = /etc/ssl/keys/exim.key
|
|
|
|
# For OpenSSL, prefer EC- over RSA-authenticated ciphers
|
|
# tls_require_ciphers = ECDSA:RSA:!COMPLEMENTOFDEFAULT
|