core/libcap/libcap-2.25-gperf.patch

32 lines
1.6 KiB
Diff

From 13992f56d80c0ee20e08f99b8e8ff37d63e65f9d Mon Sep 17 00:00:00 2001
From: Mike Gilbert <floppym@gentoo.org>
Date: Mon, 16 Jan 2017 12:09:35 -0500
Subject: [PATCH] Fix build with gperf-3.1
gperf-3.1 lookup functions take a size_t instead of unsigned int.
To resolve this:
1. Pass --includes to gperf so that size_t is defined.
2. Remove __cap_lookup_name declaration.
---
libcap/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libcap/Makefile b/libcap/Makefile
index d189777..634a042 100644
--- a/libcap/Makefile
+++ b/libcap/Makefile
@@ -41,7 +41,7 @@ cap_names.h: _makenames
./_makenames > cap_names.h
$(GPERF_OUTPUT): cap_names.list.h
- perl -e 'print "struct __cap_token_s { const char *name; int index; };\n%{\nconst struct __cap_token_s *__cap_lookup_name(const char *, unsigned int);\n%}\n%%\n"; while ($$l = <>) { $$l =~ s/[\{\"]//g; $$l =~ s/\}.*// ; print $$l; }' < $< | gperf --ignore-case --language=ANSI-C --readonly --null-strings --global-table --hash-function-name=__cap_hash_name --lookup-function-name="__cap_lookup_name" -c -t -m20 $(INDENT) > $@
+ perl -e 'print "struct __cap_token_s { const char *name; int index; };\n%%\n"; while ($$l = <>) { $$l =~ s/[\{\"]//g; $$l =~ s/\}.*// ; print $$l; }' < $< | gperf --ignore-case --language=ANSI-C --includes --readonly --null-strings --global-table --hash-function-name=__cap_hash_name --lookup-function-name="__cap_lookup_name" -c -t -m20 $(INDENT) > $@
cap_names.list.h: Makefile $(KERNEL_HEADERS)/linux/capability.h
@echo "=> making $@ from $(KERNEL_HEADERS)/linux/capability.h"
--
2.11.0