core/lilo/lilo-config.patch

89 lines
2.6 KiB
Diff

diff -Nru lilo-24.0.orig/Makefile lilo-24.0/Makefile
--- lilo-24.0.orig/Makefile 2013-06-12 13:18:34.784566604 +0200
+++ lilo-24.0/Makefile 2013-06-12 13:18:54.080542493 +0200
@@ -38,7 +38,6 @@
#
all: test
$(MAKE) -C src all
- $(MAKE) -C images all
#
# everything above plus the statically linked version
@@ -104,12 +103,8 @@
#
install: all
$(MAKE) -C src install
- $(MAKE) -C images install
- $(MAKE) -C hooks install
- $(MAKE) -C sample install
$(MAKE) -C scripts install
$(MAKE) -C man install
- $(MAKE) -C dos install
tidy:
$(MAKE) -C src tidy
diff -Nru lilo-24.0.orig/make.vars lilo-24.0/make.vars
--- lilo-24.0.orig/make.vars 2013-06-12 13:18:34.787899817 +0200
+++ lilo-24.0/make.vars 2013-06-12 13:18:54.080542493 +0200
@@ -70,14 +70,14 @@
# XL_SECS=n Support for extra large (non-standard) floppies.
CONFIG=-DBDATA -DDSECS=3 -DEVMS -DIGNORECASE -DLVM -DNOKEYBOARD -DONE_SHOT \
- -DPASS160 -DREISERFS -DREWRITE_TABLE -DSOLO_CHAIN -DVERSION -DVIRTUAL \
+ -DPASS160 -DREISERFS -DREWRITE_TABLE -DSOLO_CHAIN -DVIRTUAL \
-DMDPRAID -DDEVMAPPER
# set the following if you wish LILO.COM to be installed
DOS_DIR=/dosC/boot
# select place for man pages
-MAN_DIR=/usr/share/man
+MAN_DIR=/usr/man
# set the compiler optimization level
OPT=-Os
diff -Nru lilo-24.0.orig/man/Makefile lilo-24.0/man/Makefile
--- lilo-24.0.orig/man/Makefile 2013-06-12 13:18:34.791233030 +0200
+++ lilo-24.0/man/Makefile 2013-06-12 13:41:18.675519397 +0200
@@ -6,7 +6,7 @@
PODFILES := lilo-uuid-diskid lilo liloconfig
MANFILES5 := lilo.conf
-MANFILES8 := keytab-lilo lilo-uuid-diskid lilo liloconfig mkrescue
+MANFILES8 := keytab-lilo lilo-uuid-diskid lilo
all:
diff -Nru lilo-24.0.orig/scripts/Makefile lilo-24.0/scripts/Makefile
--- lilo-24.0.orig/scripts/Makefile 2013-06-12 13:18:34.791233030 +0200
+++ lilo-24.0/scripts/Makefile 2013-06-12 13:18:54.080542493 +0200
@@ -8,7 +8,6 @@
install:
mkdir -p $$DESTDIR$(USRSBIN_DIR)
- install -m 0755 liloconfig $$DESTDIR$(USRSBIN_DIR)
install -m 0755 lilo-uuid-diskid $$DESTDIR$(USRSBIN_DIR)
clean:
diff -Nru lilo-24.0.orig/src/Makefile lilo-24.0/src/Makefile
--- lilo-24.0.orig/src/Makefile 2013-06-12 13:18:34.784566604 +0200
+++ lilo-24.0/src/Makefile 2013-06-12 13:40:05.981468832 +0200
@@ -48,7 +48,7 @@
#
# everything needed to run, just short of installation
#
-all: lilo bootsect.b
+all: lilo
#
# everything above plus the statically linked version
@@ -245,8 +245,6 @@
strip lilo
cp lilo $$DESTDIR$(SBIN_DIR)/lilo
- [ -x lilo.static ] && strip lilo.static
- cp ../mkrescue $$DESTDIR$(USRSBIN_DIR)/mkrescue
cp ../keytab-lilo.pl $$DESTDIR$(USRSBIN_DIR)/keytab-lilo
dep: