core/dcron/dcron-3.2.patch

55 lines
1.8 KiB
Diff

diff -Nru dcron.orig/Makefile dcron/Makefile
--- dcron.orig/Makefile 2008-09-24 10:10:19.000000000 +0200
+++ dcron/Makefile 2008-09-24 14:48:17.000000000 +0200
@@ -3,7 +3,7 @@
DESTDIR ?= /usr/local
CC = gcc
-CFLAGS = -O2 -Wall -Wstrict-prototypes
+CFLAGS += -Wall -Wstrict-prototypes -D_GNU_SOURCE -DSENDMAIL="\"/usr/sbin/sendmail\""
LIB =
SRCS = main.c subs.c database.c job.c
OBJS = main.o subs.o database.o job.o
@@ -15,12 +15,10 @@
all: ${PROTOS} crond crontab
crond: ${OBJS}
- ${CC} ${CFLAGS} -o crond ${OBJS} ${LIB}
- strip crond
+ ${CC} ${CFLAGS} -o crond ${OBJS} ${LIB} ${LDFLAGS}
crontab: ${D_OBJS}
- ${CC} ${CFLAGS} -o crontab ${D_OBJS}
- strip crontab
+ ${CC} ${CFLAGS} -o crontab ${D_OBJS} ${LDFLAGS}
protos.h: ${SRCS} ${D_SRCS}
fgrep -h Prototype ${SRCS} ${D_SRCS} >protos.h
@@ -32,10 +30,10 @@
rm -f *.o dcron.tgz ${PROTOS}
install:
- install -o root -g wheel -m 0755 crond ${DESTDIR}/sbin/crond
- install -o root -g wheel -m 4755 crontab ${DESTDIR}/bin/crontab
- install -o root -g wheel -m 0644 crontab.1 ${DESTDIR}/man/man1/crontab.1
- install -o root -g wheel -m 0644 crond.8 ${DESTDIR}/man/man8/crond.8
+ install -o root -g root -m 0755 -D crond $(DESTDIR)/usr/sbin/crond
+ install -o root -g root -m 4755 -D crontab $(DESTDIR)/usr/bin/crontab
+ install -o root -g root -m 0644 -D crontab.1 $(DESTDIR)/usr/man/man1/crontab.1
+ install -o root -g root -m 0644 -D crond.8 $(DESTDIR)/usr/man/man8/crond.8
# dillon-specific
#
diff -Nru dcron.orig/subs.c dcron/subs.c
--- dcron.orig/subs.c 2008-09-24 10:10:19.000000000 +0200
+++ dcron/subs.c 2008-09-24 14:44:30.000000000 +0200
@@ -79,7 +79,7 @@
buf[0] = 0;
if (useDate)
- strftime(buf, 128, "%d-%b-%y %H:%M ", tp);
+ strftime(buf, 128, "%d-%b-%Y %H:%M ", tp);
vsnprintf(buf + strlen(buf), nmax, ctl, va);
return(strlen(buf));
}