python3-libxml2: update to 2.9.12
This commit is contained in:
parent
e5c51657a6
commit
00bce9e195
@ -7,5 +7,5 @@ drwxr-xr-x root/root usr/lib/python3.9/site-packages/__pycache__/
|
||||
-rw-r--r-- root/root usr/lib/python3.9/site-packages/__pycache__/libxml2.cpython-39.pyc
|
||||
-rw-r--r-- root/root usr/lib/python3.9/site-packages/drv_libxml2.py
|
||||
-rw-r--r-- root/root usr/lib/python3.9/site-packages/libxml2.py
|
||||
-rw-r--r-- root/root usr/lib/python3.9/site-packages/libxml2_python-2.9.10-py3.9.egg-info
|
||||
-rw-r--r-- root/root usr/lib/python3.9/site-packages/libxml2_python-2.9.12-py3.9.egg-info
|
||||
-rwxr-xr-x root/root usr/lib/python3.9/site-packages/libxml2mod.cpython-39-x86_64-linux-gnu.so
|
||||
|
@ -1,6 +1,5 @@
|
||||
untrusted comment: verify with /etc/ports/opt.pub
|
||||
RWSE3ohX2g5d/S8T8JmBaR7dxN/DCezZD246WpiuIiEq6jbo/+d01Gp24270nou5RP4oOOahjefk8dCLr16Odsu5m2EDtX++nA0=
|
||||
SHA256 (Pkgfile) = cfb24f486aac36710d7ab01fbb4f27475df60ef175843189572cf8741a0a01b1
|
||||
SHA256 (.footprint) = 1c25762c69245ad543c9cdf58b304085b225e0cac2a759f22db56f923f10d46e
|
||||
SHA256 (libxml2-2.9.10.tar.gz) = aafee193ffb8fe0c82d4afef6ef91972cbaf5feea100edc2f262750611b4be1f
|
||||
SHA256 (python3.9.patch) = 8150a23d01966bff1dbf110294012756f5a3a29bf4f671f0e07b84d4307e4bce
|
||||
RWSE3ohX2g5d/a9bz5MLNPH5qPdvLlzdUHiMCRsWBaTXtkbi82SHsIJ5yo+YafaToFjDaIZmMQAKY8873kcjmSJfZ8mEmeqjhQw=
|
||||
SHA256 (Pkgfile) = b07f26021d5f1fb659c9170a43d7131dbac4360f04035691ebc11576323fde95
|
||||
SHA256 (.footprint) = 357ae60072518c4904172d61785ac72f27a47e7eeb0146a2e379047dcc33744a
|
||||
SHA256 (libxml2-2.9.12.tar.gz) = c8d6681e38c56f172892c85ddc0852e1fd4b53b4209e7f4ebf17f7e2eae71d92
|
||||
|
@ -1,17 +1,15 @@
|
||||
# Description: Python bindings for the XML library version 2
|
||||
# URL: http://xmlsoft.org/
|
||||
# Maintainer: Juergen Daubert, jue at crux dot nu
|
||||
# Depends on: python3-setuptools libxml2
|
||||
# URL: http://xmlsoft.org/
|
||||
# Maintainer: Juergen Daubert, jue at crux dot nu
|
||||
# Depends on: python3-setuptools libxml2
|
||||
|
||||
name=python3-libxml2
|
||||
version=2.9.10
|
||||
release=2
|
||||
source=(ftp://xmlsoft.org/libxml2/libxml2-$version.tar.gz
|
||||
python3.9.patch)
|
||||
version=2.9.12
|
||||
release=1
|
||||
source=(ftp://xmlsoft.org/libxml2/libxml2-$version.tar.gz)
|
||||
|
||||
build () {
|
||||
cd libxml2-$version/python
|
||||
patch -p2 -i $SRC/python3.9.patch
|
||||
/usr/bin/python3 setup.py build
|
||||
/usr/bin/python3 setup.py install --root=$PKG
|
||||
build() {
|
||||
cd libxml2-$version/python
|
||||
/usr/bin/python3 setup.py build
|
||||
/usr/bin/python3 setup.py install --root=$PKG
|
||||
}
|
||||
|
@ -1,86 +0,0 @@
|
||||
commit e4fb36841800038c289997432ca547c9bfef9db1
|
||||
Author: Miro Hrončok <miro@hroncok.cz>
|
||||
Date: Fri Feb 28 12:48:14 2020 +0100
|
||||
|
||||
Parenthesize Py<type>_Check() in ifs
|
||||
|
||||
In C, if expressions should be parenthesized.
|
||||
PyLong_Check, PyUnicode_Check etc. happened to expand to a parenthesized
|
||||
expression before, but that's not API to rely on.
|
||||
|
||||
Since Python 3.9.0a4 it needs to be parenthesized explicitly.
|
||||
|
||||
Fixes https://gitlab.gnome.org/GNOME/libxml2/issues/149
|
||||
|
||||
diff --git a/python/libxml.c b/python/libxml.c
|
||||
index bc676c4e..81e709f3 100644
|
||||
--- a/python/libxml.c
|
||||
+++ b/python/libxml.c
|
||||
@@ -294,7 +294,7 @@ xmlPythonFileReadRaw (void * context, char * buffer, int len) {
|
||||
lenread = PyBytes_Size(ret);
|
||||
data = PyBytes_AsString(ret);
|
||||
#ifdef PyUnicode_Check
|
||||
- } else if PyUnicode_Check (ret) {
|
||||
+ } else if (PyUnicode_Check (ret)) {
|
||||
#if PY_VERSION_HEX >= 0x03030000
|
||||
Py_ssize_t size;
|
||||
const char *tmp;
|
||||
@@ -359,7 +359,7 @@ xmlPythonFileRead (void * context, char * buffer, int len) {
|
||||
lenread = PyBytes_Size(ret);
|
||||
data = PyBytes_AsString(ret);
|
||||
#ifdef PyUnicode_Check
|
||||
- } else if PyUnicode_Check (ret) {
|
||||
+ } else if (PyUnicode_Check (ret)) {
|
||||
#if PY_VERSION_HEX >= 0x03030000
|
||||
Py_ssize_t size;
|
||||
const char *tmp;
|
||||
diff --git a/python/types.c b/python/types.c
|
||||
index c2bafeb1..ed284ec7 100644
|
||||
--- a/python/types.c
|
||||
+++ b/python/types.c
|
||||
@@ -602,16 +602,16 @@ libxml_xmlXPathObjectPtrConvert(PyObject *obj)
|
||||
if (obj == NULL) {
|
||||
return (NULL);
|
||||
}
|
||||
- if PyFloat_Check (obj) {
|
||||
+ if (PyFloat_Check (obj)) {
|
||||
ret = xmlXPathNewFloat((double) PyFloat_AS_DOUBLE(obj));
|
||||
- } else if PyLong_Check(obj) {
|
||||
+ } else if (PyLong_Check(obj)) {
|
||||
#ifdef PyLong_AS_LONG
|
||||
ret = xmlXPathNewFloat((double) PyLong_AS_LONG(obj));
|
||||
#else
|
||||
ret = xmlXPathNewFloat((double) PyInt_AS_LONG(obj));
|
||||
#endif
|
||||
#ifdef PyBool_Check
|
||||
- } else if PyBool_Check (obj) {
|
||||
+ } else if (PyBool_Check (obj)) {
|
||||
|
||||
if (obj == Py_True) {
|
||||
ret = xmlXPathNewBoolean(1);
|
||||
@@ -620,14 +620,14 @@ libxml_xmlXPathObjectPtrConvert(PyObject *obj)
|
||||
ret = xmlXPathNewBoolean(0);
|
||||
}
|
||||
#endif
|
||||
- } else if PyBytes_Check (obj) {
|
||||
+ } else if (PyBytes_Check (obj)) {
|
||||
xmlChar *str;
|
||||
|
||||
str = xmlStrndup((const xmlChar *) PyBytes_AS_STRING(obj),
|
||||
PyBytes_GET_SIZE(obj));
|
||||
ret = xmlXPathWrapString(str);
|
||||
#ifdef PyUnicode_Check
|
||||
- } else if PyUnicode_Check (obj) {
|
||||
+ } else if (PyUnicode_Check (obj)) {
|
||||
#if PY_VERSION_HEX >= 0x03030000
|
||||
xmlChar *str;
|
||||
const char *tmp;
|
||||
@@ -650,7 +650,7 @@ libxml_xmlXPathObjectPtrConvert(PyObject *obj)
|
||||
ret = xmlXPathWrapString(str);
|
||||
#endif
|
||||
#endif
|
||||
- } else if PyList_Check (obj) {
|
||||
+ } else if (PyList_Check (obj)) {
|
||||
int i;
|
||||
PyObject *node;
|
||||
xmlNodePtr cur;
|
Loading…
x
Reference in New Issue
Block a user