libgudev: 3.2.1 -> 230
This commit is contained in:
parent
731d203e53
commit
04f7694335
@ -1,4 +1,3 @@
|
||||
drwxr-xr-x root/root lib/
|
||||
drwxr-xr-x root/root usr/
|
||||
drwxr-xr-x root/root usr/include/
|
||||
drwxr-xr-x root/root usr/include/gudev-1.0/
|
||||
@ -11,13 +10,9 @@ drwxr-xr-x root/root usr/include/gudev-1.0/gudev/
|
||||
-rw-r--r-- root/root usr/include/gudev-1.0/gudev/gudevenumtypes.h
|
||||
-rw-r--r-- root/root usr/include/gudev-1.0/gudev/gudevtypes.h
|
||||
drwxr-xr-x root/root usr/lib/
|
||||
-rw-r--r-- root/root usr/lib/libgudev-1.0.a
|
||||
-rwxr-xr-x root/root usr/lib/libgudev-1.0.la
|
||||
lrwxrwxrwx root/root usr/lib/libgudev-1.0.so -> libgudev-1.0.so.0.2.0
|
||||
lrwxrwxrwx root/root usr/lib/libgudev-1.0.so.0 -> libgudev-1.0.so.0.2.0
|
||||
-rwxr-xr-x root/root usr/lib/libgudev-1.0.so.0.2.0
|
||||
drwxr-xr-x root/root usr/lib/pkgconfig/
|
||||
-rw-r--r-- root/root usr/lib/pkgconfig/gudev-1.0.pc
|
||||
drwxr-xr-x root/root usr/share/
|
||||
drwxr-xr-x root/root usr/share/gir-1.0/
|
||||
-rw-r--r-- root/root usr/share/gir-1.0/GUdev-1.0.gir
|
||||
|
@ -1,3 +1 @@
|
||||
07ab33fe310d250f06fc28f010e3fde2 eudev-3.1.2.tar.gz
|
||||
ea3abf3fb868f69fa34efa8772ea4e86 eudev-remove_gperf_dep.patch
|
||||
1dcada037857d727e7d1efb5d8777055 keyboard-keys.tar.xz
|
||||
e4dee8f3f349e9372213d33887819a4d libgudev-230.tar.xz
|
||||
|
@ -1,46 +1,19 @@
|
||||
# Description: Gobject interface for udev.
|
||||
# Description: GObject bindings for libudev
|
||||
# URL: http://gudev.sourceforge.net/
|
||||
# Maintainer: Danny Rawlins, crux at romster dot me
|
||||
# Packager: Jose V Beneyto, sepen at crux dot nu
|
||||
# Depends on: gobject-introspection gperf eudev
|
||||
# Depends on: glib
|
||||
# Optional: gobject-introspection
|
||||
|
||||
name=gudev
|
||||
version=3.1.2
|
||||
name=libgudev
|
||||
version=230
|
||||
release=1
|
||||
source=(http://dev.gentoo.org/~blueness/eudev/eudev-$version.tar.gz
|
||||
eudev-remove_gperf_dep.patch
|
||||
keyboard-keys.tar.xz)
|
||||
source=(http://ftp.gnome.org/pub/gnome/sources/$name/$version/$name-$version.tar.xz)
|
||||
|
||||
build() {
|
||||
cd eudev-$version
|
||||
cd $name-$version
|
||||
|
||||
# See https://github.com/gentoo/eudev/issues/75
|
||||
# remove build-time dependency to gperf for now
|
||||
cp $SRC/keyboard-keys-{from,to}-name.h src/udev
|
||||
patch -p1 -i $SRC/eudev-remove_gperf_dep.patch
|
||||
|
||||
# needed for static linking, e.g. dmsetup.static
|
||||
sed -i '/^Libs:/s/-ludev/-ludev -lrt/' src/libudev/libudev.pc.in
|
||||
|
||||
autoreconf --force --install
|
||||
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--sbindir=/sbin \
|
||||
--bindir=/sbin \
|
||||
--sysconfdir=/etc \
|
||||
--with-rootprefix= \
|
||||
--with-rootlibdir=/lib \
|
||||
--libexecdir=/lib \
|
||||
--disable-manpages \
|
||||
--enable-split-usr
|
||||
|
||||
make CFLAGS="$CFLAGS -D_GNU_SOURCE"
|
||||
make install DESTDIR=$SRC/tmp
|
||||
|
||||
install -d $PKG/{lib,usr/{include,lib/pkgconfig,share/gir-1.0}}
|
||||
mv $SRC/tmp/usr/include/gudev* $PKG/usr/include
|
||||
mv $SRC/tmp/usr/lib/libgudev* $PKG/usr/lib
|
||||
mv $SRC/tmp/usr/lib/pkgconfig/$name-1.0.pc $PKG/usr/lib/pkgconfig
|
||||
mv $SRC/tmp/usr/share/gir-1.0/* $PKG/usr/share/gir-1.0/
|
||||
./configure --prefix=/usr
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
}
|
||||
|
@ -1,36 +0,0 @@
|
||||
diff -Nru eudev-3.1.1.orig/configure.ac eudev-3.1.1/configure.ac
|
||||
--- eudev-3.1.1.orig/configure.ac 2015-06-08 13:46:49.535952811 +0200
|
||||
+++ eudev-3.1.1/configure.ac 2015-06-08 13:47:03.698782701 +0200
|
||||
@@ -244,10 +244,6 @@
|
||||
AM_CONDITIONAL([ENABLE_GUDEV], [test "x$enable_gudev" = "xyes"])
|
||||
|
||||
# ------------------------------------------------------------------------------
|
||||
-AC_PATH_TOOL(GPERF, gperf)
|
||||
-if test -z "$GPERF" ; then
|
||||
- AC_MSG_ERROR([*** gperf not found])
|
||||
-fi
|
||||
|
||||
# ------------------------------------------------------------------------------
|
||||
GTK_DOC_CHECK([1.18],[--flavour no-tmpl])
|
||||
diff -Nru eudev-3.1.1.orig/src/udev/Makefile.am eudev-3.1.1/src/udev/Makefile.am
|
||||
--- eudev-3.1.1.orig/src/udev/Makefile.am 2015-06-08 13:46:49.532619596 +0200
|
||||
+++ eudev-3.1.1/src/udev/Makefile.am 2015-06-08 13:47:03.698782701 +0200
|
||||
@@ -112,18 +112,6 @@
|
||||
keyboard-keys-from-name.h \
|
||||
keyboard-keys-to-name.h
|
||||
|
||||
-keyboard-keys.txt: Makefile
|
||||
- $(AM_V_at)$(MKDIR_P) $(dir $@)
|
||||
- $(AM_V_GEN)$(CPP) $(CFLAGS) $(AM_CPPFLAGS) $(CPPFLAGS) -dM -include linux/input.h - < /dev/null | $(AWK) '/^#define[ \t]+KEY_[^ ]+[ \t]+[0-9]/ { if ($$2 != "KEY_MAX") { print $$2 } }' | sed 's/^KEY_COFFEE$$/KEY_SCREENLOCK/' > $@
|
||||
-
|
||||
-keyboard-keys-from-name.gperf: keyboard-keys.txt Makefile
|
||||
- $(AM_V_GEN)$(AWK) 'BEGIN{ print "struct key { const char* name; unsigned short id; };"; print "%null-strings"; print "%%";} { print tolower(substr($$1 ,5)) ", " $$1 }' < $< > $@
|
||||
-
|
||||
-keyboard-keys-from-name.h: keyboard-keys-from-name.gperf Makefile
|
||||
- $(AM_V_GPERF)$(GPERF) -L ANSI-C -t -N keyboard_lookup_key -H hash_key_name -p -C < $< > $@
|
||||
-
|
||||
-keyboard-keys-to-name.h: keyboard-keys.txt Makefile
|
||||
- $(AM_V_GEN)$(AWK) 'BEGIN{ print "const char* const key_names[KEY_CNT] = { "} { print "[" $$1 "] = \"" $$1 "\"," } END{print "};"}' < $< > $@
|
||||
|
||||
|
||||
BUILT_SOURCES = \
|
Binary file not shown.
Loading…
x
Reference in New Issue
Block a user