mathopd: update to 1.5p6

This commit is contained in:
Juergen Daubert 2007-07-22 11:43:21 +02:00
parent 1edb9bf0a1
commit 08d520b05c
3 changed files with 54 additions and 7 deletions

View File

@ -1,6 +1,7 @@
ec0d71c0c75986c1c4974320788945cc dir_cgi-1.1.tar.gz
56ed28d0c582903a2c29c9c5f9153e57 mathopd
48b54bf1e9673203a8f18a4fefab4730 mathopd-1.5p5.tar.gz
c26b466f20ddcdc6b68180a248f3156c mathopd-1.5p6.tar.gz
3e318e6add3583d90373cc335e5ea75e mathopd-config.patch
dd645079a41380fbb301da6d5559de84 mathopd.8.gz
2f0f28b786a555bbd800c0cbcf0d7057 mathopd.conf
30b3213864d035989dacd1d256880e81 mathopd.conf.5.gz

View File

@ -3,18 +3,19 @@
# Maintainer: Jürgen Daubert, juergen dot daubert at t-online dot de
name=mathopd
version=1.5p5
release=3
version=1.5p6
release=1
source=(http://www.mathopd.org/dist/$name-$version.tar.gz \
http://jue.li/misc/dir_cgi/dir_cgi-1.1.tar.gz \
http://jue.li/misc/dir_cgi/dir_cgi-1.1.tar.gz \
http://www.mathopd.org/doc/mathopd.8.gz \
http://www.mathopd.org/doc/mathopd.conf.5.gz \
mathopd.conf mathopd)
mathopd-config.patch mathopd.conf mathopd)
build () {
cd $name-$version/src
sed -i '37s/# //' Makefile
make -e CPPFLAGS="-DHAVE_CRYPT_H -DHAVE_VFORK -DLINUX_SENDFILE -Wall"
patch -p2 -i $SRC/mathopd-config.patch
make
install -d $PKG/{var/log,etc/rc.d,usr/{bin,sbin,man/man{8,5}}}
install -m 755 mathopd $PKG/usr/sbin

View File

@ -0,0 +1,45 @@
diff -Nru mathopd-1.5p6.orig/src/Makefile mathopd-1.5p6/src/Makefile
--- mathopd-1.5p6.orig/src/Makefile 2007-07-21 14:56:57.000000000 +0200
+++ mathopd-1.5p6/src/Makefile 2007-07-21 14:58:26.000000000 +0200
@@ -1,6 +1,6 @@
BIN = mathopd
CC = gcc
-CFLAGS = -O -Wall
+CFLAGS += -Wall
CPPFLAGS =
LDFLAGS =
LIBS = -lcrypt
@@ -12,12 +12,12 @@
# LIBS = -lsocket -lnsl -lresolv
# On Linux, uncomment the following
-# CPPFLAGS = -DHAVE_CRYPT_H
+CPPFLAGS = -DHAVE_CRYPT_H
# For Linux or Solaris:
# To add support for large files (>2GB), uncomment the following.
# You do not need this for 64-bit executables.
-# CPPFLAGS += -D_FILE_OFFSET_BITS=64
+CPPFLAGS += -D_FILE_OFFSET_BITS=64
OBJS = base64.o cgi.o config.o core.o dump.o imap.o log.o main.o \
redirect.o request.o util.o stub.o $(EXTRA_OBJS)
@@ -31,15 +31,15 @@
# CPPFLAGS += -DNEED_SOCKLEN_T
# Unomment the following if your system has a working vfork() function
-# CPPFLAGS += -DHAVE_VFORK
+CPPFLAGS += -DHAVE_VFORK
# Currently, sendfile support is available in two flavours: Linux and FreeBSD
# Uncomment one of the following two to enable sendfile() support
-# CPPFLAGS += -DLINUX_SENDFILE
+CPPFLAGS += -DLINUX_SENDFILE
# CPPFLAGS += -DFREEBSD_SENDFILE
# If you define any of the SENDFILE conditionals, make sure to uncomment
# the next line as well.
-# EXTRA_OBJS += sendfile.o
+EXTRA_OBJS += sendfile.o
all: $(BIN)
install: $(BIN)