stunnel: update to 4.15
This commit is contained in:
parent
ca1d913ebd
commit
0951477ffc
@ -5,7 +5,7 @@ drwxr-xr-x root/root etc/ssl/
|
||||
drwxr-xr-x root/root etc/ssl/certs/
|
||||
-rw-r--r-- root/root etc/ssl/certs/stunnel.crt (EMPTY)
|
||||
drwxr-xr-x root/root etc/ssl/keys/
|
||||
-rw-r--r-- root/root etc/ssl/keys/stunnel.key (EMPTY)
|
||||
-rw------- root/root etc/ssl/keys/stunnel.key (EMPTY)
|
||||
-rw-r--r-- root/root etc/stunnel.conf
|
||||
drwxr-xr-x root/root usr/
|
||||
drwxr-xr-x root/root usr/man/
|
||||
@ -15,4 +15,4 @@ drwxr-xr-x root/root usr/sbin/
|
||||
-rwxr-xr-x root/root usr/sbin/stunnel
|
||||
drwxr-xr-x root/root var/
|
||||
drwxr-xr-x root/root var/run/
|
||||
drwxr-xr-x nobody/nobody var/run/stunnel/
|
||||
drwxrwx--- nobody/nobody var/run/stunnel/
|
||||
|
@ -1,3 +1,3 @@
|
||||
20d8078911733e4de22903034e725db6 stunnel
|
||||
0969cc4868dfd75f22792ecccc9ec555 stunnel-4.14.tar.gz
|
||||
a01072c2a3a1ff0d2b83834d5fa5557e stunnel.patch
|
||||
2c00153ad099a5f9c5609e8d1dbbe470 stunnel-4.15.tar.gz
|
||||
19f91ef9788c54bdb38fb0fa2e3791c4 stunnel-config.patch
|
||||
|
@ -2,17 +2,17 @@
|
||||
# Description: Stunnel wraps normal socket connections with SSL/TLS
|
||||
# URL: http://www.stunnel.org
|
||||
# Maintainer: Jürgen Daubert, juergen dot daubert at t-online dot de
|
||||
# Depends on: openssl zlib
|
||||
# Depends on: openssl, zlib, tcp_wrappers
|
||||
|
||||
name=stunnel
|
||||
version=4.14
|
||||
version=4.15
|
||||
release=1
|
||||
source=(http://www.stunnel.org/download/stunnel/src/$name-$version.tar.gz \
|
||||
$name.patch $name)
|
||||
$name-config.patch $name)
|
||||
|
||||
build () {
|
||||
cd $name-$version
|
||||
patch -p1 < $SRC/$name.patch
|
||||
patch -p1 < $SRC/$name-config.patch
|
||||
./configure --prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
@ -24,9 +24,10 @@ build () {
|
||||
make
|
||||
install -D -m 0755 src/stunnel $PKG/usr/sbin/stunnel
|
||||
install -D -m 0644 doc/stunnel.8 $PKG/usr/man/man8/stunnel.8
|
||||
install -D -m 0755 $SRC/$name $PKG/etc/rc.d/$name
|
||||
install -D -m 0755 $SRC/stunnel $PKG/etc/rc.d/stunnel
|
||||
install -m 0644 tools/stunnel.conf-sample $PKG/etc/stunnel.conf
|
||||
install -d $PKG/{var/run,etc/ssl/{certs,keys}}
|
||||
install -d -o nobody -g nobody $PKG/var/run/stunnel
|
||||
touch $PKG/etc/ssl/{certs/$name.crt,keys/$name.key}
|
||||
install -d -m 770 -o nobody -g nobody $PKG/var/run/stunnel
|
||||
touch $PKG/etc/ssl/{certs/stunnel.crt,keys/stunnel.key}
|
||||
chmod 0600 $PKG/etc/ssl/keys/stunnel.key
|
||||
}
|
||||
|
42
stunnel/stunnel-config.patch
Normal file
42
stunnel/stunnel-config.patch
Normal file
@ -0,0 +1,42 @@
|
||||
diff -Nru stunnel-4.15.orig/src/Makefile.in stunnel-4.15/src/Makefile.in
|
||||
--- stunnel-4.15.orig/src/Makefile.in 2006-03-12 12:49:36.000000000 +0100
|
||||
+++ stunnel-4.15/src/Makefile.in 2006-03-12 13:19:19.000000000 +0100
|
||||
@@ -222,7 +222,7 @@
|
||||
INCLUDES = -I/usr/kerberos/include
|
||||
|
||||
# Additional compiler flags
|
||||
-AM_CPPFLAGS = -DLIBDIR='"$(libdir)"' -DCONFDIR='"$(sysconfdir)/stunnel"' -DPIDFILE='"$(prefix)/var/run/stunnel/stunnel.pid"'
|
||||
+AM_CPPFLAGS = -DLIBDIR='"$(libdir)"' -DCONFDIR='"$(sysconfdir)"' -DPIDFILE='"/var/run/stunnel/stunnel.pid"'
|
||||
|
||||
# Win32 executable
|
||||
EXTRA_DIST = stunnel.exe make.bat mingw.mak makece.bat evc.mak vc.mak nogui.c
|
||||
diff -Nru stunnel-4.15.orig/tools/stunnel.conf-sample.in stunnel-4.15/tools/stunnel.conf-sample.in
|
||||
--- stunnel-4.15.orig/tools/stunnel.conf-sample.in 2006-03-12 12:49:36.000000000 +0100
|
||||
+++ stunnel-4.15/tools/stunnel.conf-sample.in 2006-03-12 13:19:47.000000000 +0100
|
||||
@@ -3,13 +3,13 @@
|
||||
; Please make sure you understand them (especially the effect of chroot jail)
|
||||
|
||||
; Certificate/key is needed in server mode and optional in client mode
|
||||
-cert = @prefix@/etc/stunnel/mail.pem
|
||||
-;key = @prefix@/etc/stunnel/mail.pem
|
||||
+cert = /etc/ssl/certs/stunnel.crt
|
||||
+key = /etc/ssl/keys/stunnel.key
|
||||
|
||||
; Some security enhancements for UNIX systems - comment them out on Win32
|
||||
-chroot = @prefix@/var/lib/stunnel/
|
||||
+chroot = /var/run/stunnel/
|
||||
setuid = nobody
|
||||
-setgid = nogroup
|
||||
+setgid = nobody
|
||||
; PID is created inside chroot jail
|
||||
pid = /stunnel.pid
|
||||
|
||||
@@ -36,7 +36,7 @@
|
||||
|
||||
; Some debugging stuff useful for troubleshooting
|
||||
;debug = 7
|
||||
-;output = stunnel.log
|
||||
+output = /var/log/stunnel.log
|
||||
|
||||
; Use it for client mode
|
||||
;client = yes
|
@ -1,42 +0,0 @@
|
||||
diff -Nru stunnel-4.14.orig/configure stunnel-4.14/configure
|
||||
--- stunnel-4.14.orig/configure 2005-11-03 08:01:22.000000000 +0100
|
||||
+++ stunnel-4.14/configure 2005-11-03 08:10:51.000000000 +0100
|
||||
@@ -23339,7 +23339,7 @@
|
||||
|
||||
{ echo "$as_me:$LINENO: **************************************** write the results" >&5
|
||||
echo "$as_me: **************************************** write the results" >&6;}
|
||||
-CPPFLAGS="$CPPFLAGS -DLIBDIR=\\\"$libdir\\\" -DCONFDIR=\\\"$sysconfdir/stunnel\\\" -DPIDFILE=\\\"$localstatedir/stunnel/stunnel.pid\\\""
|
||||
+CPPFLAGS="$CPPFLAGS -DLIBDIR=\\\"$libdir\\\" -DCONFDIR=\\\"$sysconfdir\\\" -DPIDFILE=\\\"$localstatedir/run/stunnel/stunnel.pid\\\""
|
||||
ac_config_files="$ac_config_files Makefile src/Makefile src/stunnel3 doc/Makefile tools/Makefile tools/stunnel.conf-sample tools/stunnel.init"
|
||||
|
||||
cat >confcache <<\_ACEOF
|
||||
diff -Nru stunnel-4.14.orig/tools/stunnel.conf-sample.in stunnel-4.14/tools/stunnel.conf-sample.in
|
||||
--- stunnel-4.14.orig/tools/stunnel.conf-sample.in 2005-11-03 08:01:22.000000000 +0100
|
||||
+++ stunnel-4.14/tools/stunnel.conf-sample.in 2005-11-03 08:01:40.000000000 +0100
|
||||
@@ -3,13 +3,13 @@
|
||||
; Please make sure you understand them (especially the effect of chroot jail)
|
||||
|
||||
; Certificate/key is needed in server mode and optional in client mode
|
||||
-cert = @prefix@/etc/stunnel/mail.pem
|
||||
-;key = @prefix@/etc/stunnel/mail.pem
|
||||
+cert = /etc/ssl/certs/stunnel.crt
|
||||
+key = /etc/ssl/keys/stunnel.key
|
||||
|
||||
; Some security enhancements for UNIX systems - comment them out on Win32
|
||||
-chroot = @prefix@/var/stunnel/
|
||||
+chroot = /var/run/stunnel/
|
||||
setuid = nobody
|
||||
-setgid = nogroup
|
||||
+setgid = nobody
|
||||
; PID is created inside chroot jail
|
||||
pid = /stunnel.pid
|
||||
|
||||
@@ -36,7 +36,7 @@
|
||||
|
||||
; Some debugging stuff useful for troubleshooting
|
||||
;debug = 7
|
||||
-;output = stunnel.log
|
||||
+;output = /var/log/stunnel.log
|
||||
|
||||
; Use it for client mode
|
||||
;client = yes
|
Loading…
x
Reference in New Issue
Block a user