libtxc_dxtn: updated to 060508

This commit is contained in:
Tilman Sauerbeck 2006-05-09 06:26:41 +00:00
parent 3ea5a91f6c
commit 124e7d457a
3 changed files with 3 additions and 37 deletions

View File

@ -1,2 +1 @@
75154a561a3d2ed811a91e9b47f5e3fd libtxc_dxtn.diff
640041753b43d94bf2a09986c79b383c libtxc_dxtn050908.tar.gz
2b6533617012f5aab52f7f31bd28a8b0 libtxc_dxtn060508.tar.gz

View File

@ -3,16 +3,13 @@
# Maintainer: Tilman Sauerbeck, tilman at crux dot nu
name=libtxc_dxtn
version=050908
version=060508
release=1
source=(http://homepage.hispeed.ch/rscheidegger/dri_experimental/$name$version.tar.gz \
$name.diff)
source=(http://homepage.hispeed.ch/rscheidegger/dri_experimental/$name$version.tar.gz)
build() {
cd $name
patch -Np1 -i ../$name.diff
make
make DESTDIR=$PKG install
}

View File

@ -1,30 +0,0 @@
diff -aur libtxc_dxtn.orig/Makefile libtxc_dxtn/Makefile
--- libtxc_dxtn.orig/Makefile 2004-04-23 00:19:21.000000000 +0200
+++ libtxc_dxtn/Makefile 2005-12-29 17:43:18.365917000 +0100
@@ -1,14 +1,17 @@
-libtxc_dxtn.so: txc_compress_dxtn.o txc_fetch_dxtn.o
- gcc -v -O3 -Wall -pedantic -fPIC -lpthread -shared -o libtxc_dxtn.so txc_compress_dxtn.o txc_fetch_dxtn.o
+CFLAGS += -pedantic -fPIC -Wall
+LDFLAGS += -shared
+OBJS = txc_compress_dxtn.o txc_fetch_dxtn.o
+LIB = libtxc_dxtn.so
-txc_compress_dxtn.o : txc_compress_dxtn.c txc_dxtn.h
- gcc -c -O3 -Wall -pedantic -fPIC -o txc_compress_dxtn.o txc_compress_dxtn.c
+$(LIB): $(OBJS)
+ $(CC) $(LDFLAGS) -o $@ $(OBJS)
-txc_fetch_dxtn.o : txc_fetch_dxtn.c txc_dxtn.h
- gcc -c -O3 -Wall -pedantic -fPIC -o txc_fetch_dxtn.o txc_fetch_dxtn.c
+.c.o:
+ $(CC) $(CFLAGS) -c $< -o $@
clean:
- rm txc_fetch_dxtn.o txc_compress_dxtn.o libtxc_dxtn.so
+ rm -f $(OBJS) $(LIB)
-install: libtxc_dxtn.so
- install libtxc_dxtn.so /usr/lib/
+install: $(LIB)
+ install -d $(DESTDIR)/usr/lib
+ install $(LIB) $(DESTDIR)/usr/lib