python: fix for linker problem, reported by Matt
This commit is contained in:
parent
ac38cf559c
commit
1b95f86cd6
@ -1,2 +1,2 @@
|
||||
ddb7401e711354ca83b7842b733825a3 Python-2.5.tar.bz2
|
||||
cc6b0643c9397f953f6811a9b9311890 python-2.5.patch
|
||||
3e31bd8cd171b942b523a894ef9204a4 python-2.5.patch
|
||||
|
@ -1,15 +1,27 @@
|
||||
diff -Nru Python-2.5.orig/Lib/cgi.py Python-2.5/Lib/cgi.py
|
||||
--- Python-2.5.orig/Lib/cgi.py 2006-10-05 22:07:10.000000000 +0200
|
||||
+++ Python-2.5/Lib/cgi.py 2006-10-05 22:08:34.000000000 +0200
|
||||
--- Python-2.5.orig/Lib/cgi.py 2007-01-03 14:31:57.000000000 +0100
|
||||
+++ Python-2.5/Lib/cgi.py 2007-01-03 14:32:13.000000000 +0100
|
||||
@@ -1,4 +1,4 @@
|
||||
-#! /usr/local/bin/python
|
||||
+#! /usr/bin/python
|
||||
|
||||
# NOTE: the above "/usr/local/bin/python" is NOT a mistake. It is
|
||||
# intentionally NOT "/usr/bin/env python". On many systems
|
||||
diff -Nru Python-2.5.orig/Makefile.pre.in Python-2.5/Makefile.pre.in
|
||||
--- Python-2.5.orig/Makefile.pre.in 2007-01-03 14:32:02.000000000 +0100
|
||||
+++ Python-2.5/Makefile.pre.in 2007-01-03 14:32:33.000000000 +0100
|
||||
@@ -62,7 +62,7 @@
|
||||
# be able to build extension modules using the directories specified in the
|
||||
# environment variables
|
||||
CPPFLAGS= -I. -I$(srcdir)/Include @CPPFLAGS@
|
||||
-LDFLAGS= @LDFLAGS@
|
||||
+LDFLAGS= -L. @LDFLAGS@
|
||||
LDLAST= @LDLAST@
|
||||
SGI_ABI= @SGI_ABI@
|
||||
CCSHARED= @CCSHARED@
|
||||
diff -Nru Python-2.5.orig/Modules/Setup.dist Python-2.5/Modules/Setup.dist
|
||||
--- Python-2.5.orig/Modules/Setup.dist 2006-10-05 22:07:10.000000000 +0200
|
||||
+++ Python-2.5/Modules/Setup.dist 2006-10-05 22:08:59.000000000 +0200
|
||||
--- Python-2.5.orig/Modules/Setup.dist 2007-01-03 14:32:02.000000000 +0100
|
||||
+++ Python-2.5/Modules/Setup.dist 2007-01-03 14:32:13.000000000 +0100
|
||||
@@ -149,7 +149,7 @@
|
||||
# modules are to be built as shared libraries (see above for more
|
||||
# detail; also note that *static* reverses this effect):
|
||||
@ -29,8 +41,8 @@ diff -Nru Python-2.5.orig/Modules/Setup.dist Python-2.5/Modules/Setup.dist
|
||||
# Anthony Baxter's gdbm module. GNU dbm(3) will require -lgdbm:
|
||||
#
|
||||
diff -Nru Python-2.5.orig/configure Python-2.5/configure
|
||||
--- Python-2.5.orig/configure 2006-10-05 22:07:10.000000000 +0200
|
||||
+++ Python-2.5/configure 2006-10-05 22:10:15.000000000 +0200
|
||||
--- Python-2.5.orig/configure 2007-01-03 14:31:58.000000000 +0100
|
||||
+++ Python-2.5/configure 2007-01-03 14:32:13.000000000 +0100
|
||||
@@ -3800,7 +3800,7 @@
|
||||
# debug builds.
|
||||
OPT="-g -Wall $STRICT_PROTO"
|
||||
|
Loading…
x
Reference in New Issue
Block a user