mysql-python: update to 1.2.3
This commit is contained in:
parent
b48afc3b01
commit
25b4fe5f46
@ -1,2 +1,3 @@
|
||||
39d76e35b3b2abc22431ab0631353bc6 MySQL-python-1.2-r641.tar.xz
|
||||
ca37b1ff16fa2ede6e19383e7b59245a setuptools-0.6c9-py2.6.egg
|
||||
215eddb6d853f6f4be5b4afc4154292f MySQL-python-1.2.3.tar.gz
|
||||
82ffc569d2f8270cdbc9b89bc60dc06f mysql-python-setup.diff
|
||||
bfa92100bd772d5a213eedd356d64086 setuptools-0.6c11-py2.6.egg
|
||||
|
@ -4,14 +4,16 @@
|
||||
# Depends on: python, mysql
|
||||
|
||||
name=mysql-python
|
||||
version=1.2-r641
|
||||
version=1.2.3
|
||||
release=1
|
||||
source=(http://crux.s3.amazonaws.com/dist/MySQL-python-$version.tar.xz \
|
||||
http://cheeseshop.python.org/packages/2.6/s/setuptools/setuptools-0.6c9-py2.6.egg)
|
||||
source=(http://downloads.sourceforge.net/project/$name/$name/$version/MySQL-python-$version.tar.gz
|
||||
http://pypi.python.org/packages/2.6/s/setuptools/setuptools-0.6c11-py2.6.egg
|
||||
$name-setup.diff)
|
||||
|
||||
build () {
|
||||
cd MySQL-python-$version
|
||||
cp $SRC/setuptools-0.6c9-py2.6.egg .
|
||||
patch -p1 -i $SRC/$name-setup.diff
|
||||
cp $SRC/setuptools-0.6c11-py2.6.egg .
|
||||
python setup.py install --root=$PKG --prefix=/usr
|
||||
rm -r $PKG/usr/lib/python2.6/site-packages/*.egg-info
|
||||
}
|
||||
|
12
mysql-python/mysql-python-setup.diff
Normal file
12
mysql-python/mysql-python-setup.diff
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru MySQL-python-1.2.3.orig/setup.py MySQL-python-1.2.3/setup.py
|
||||
--- MySQL-python-1.2.3.orig/setup.py 2010-06-17 15:05:12.954472025 +0200
|
||||
+++ MySQL-python-1.2.3/setup.py 2010-04-27 10:00:04.000000000 +0200
|
||||
@@ -2,6 +2,8 @@
|
||||
|
||||
import os
|
||||
import sys
|
||||
+from ez_setup import use_setuptools
|
||||
+use_setuptools()
|
||||
from setuptools import setup, Extension
|
||||
|
||||
if not hasattr(sys, "hexversion") or sys.hexversion < 0x02030000:
|
Loading…
x
Reference in New Issue
Block a user