popa3d: dropped

This commit is contained in:
Juergen Daubert 2012-10-18 14:34:06 +02:00
parent 67d6706b3f
commit 28a83ae09b
5 changed files with 0 additions and 119 deletions

View File

@ -1,9 +0,0 @@
drwxr-xr-x root/root etc/
drwxr-xr-x root/root etc/rc.d/
-rwxr-xr-x root/root etc/rc.d/popa3d
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/man/
drwxr-xr-x root/root usr/man/man8/
-rw-r--r-- root/root usr/man/man8/popa3d.8.gz
drwxr-xr-x root/root usr/sbin/
-rwx------ root/root usr/sbin/popa3d

View File

@ -1,3 +0,0 @@
3baf2cb939f1783406096bc7bf4742f7 popa3d
cebdc56b6fa0655a5688c89cb7703b66 popa3d-1.0.2.tar.gz
9c5e5760429b5d0cb24f55240c666090 popa3d-config.patch

View File

@ -1,17 +0,0 @@
# Description: A tiny POP3 daemon designed with security as the primary goal
# URL: http://www.openwall.com/popa3d
# Maintainer: Juergen Daubert, jue at crux dot nu
name=popa3d
version=1.0.2
release=1
source=(http://www.openwall.com/popa3d/$name-$version.tar.gz \
$name-config.patch popa3d)
build () {
cd $name-$version
patch -p1 < $SRC/$name-config.patch
make
make DESTDIR=$PKG install
install -D -m 755 $SRC/popa3d $PKG/etc/rc.d/popa3d
}

View File

@ -1,23 +0,0 @@
#!/bin/sh
#
# /etc/rc.d/popa3d: start/stop popa3d daemon
#
case $1 in
start)
/usr/sbin/popa3d -D
;;
stop)
killall -q /usr/sbin/popa3d
;;
restart)
$0 stop
sleep 2
$0 start
;;
*)
echo "usage: $0 [start|stop|restart]"
;;
esac
# End of file

View File

@ -1,67 +0,0 @@
diff -Nru popa3d-1.0.1.orig/Makefile popa3d-1.0.1/Makefile
--- popa3d-1.0.1.orig/Makefile 2006-03-12 11:39:29.000000000 +0100
+++ popa3d-1.0.1/Makefile 2006-03-12 11:39:40.000000000 +0100
@@ -3,13 +3,13 @@
RM = rm -f
MKDIR = mkdir -p
INSTALL = install -c
-CFLAGS = -Wall -O2 -fomit-frame-pointer
+CFLAGS += -Wall -fomit-frame-pointer
# You may use OpenSSL's MD5 routines instead of the ones supplied here
#CFLAGS += -DHAVE_OPENSSL
LDFLAGS = -s
LIBS =
# Linux with glibc, FreeBSD, NetBSD
-#LIBS += -lcrypt
+LIBS += -lcrypt
# HP-UX trusted system
#LIBS += -lsec
# Solaris (POP_STANDALONE, POP_VIRTUAL)
@@ -24,7 +24,7 @@
#LIBS += -lcrypto
DESTDIR =
-PREFIX = /usr/local
+PREFIX = /usr
SBINDIR = $(PREFIX)/sbin
MANDIR = $(PREFIX)/man
diff -Nru popa3d-1.0.1.orig/params.h popa3d-1.0.1/params.h
--- popa3d-1.0.1.orig/params.h 2006-03-12 11:39:29.000000000 +0100
+++ popa3d-1.0.1/params.h 2006-03-12 11:39:40.000000000 +0100
@@ -13,7 +13,7 @@
/*
* Are we going to be a standalone server or start via an inetd clone?
*/
-#define POP_STANDALONE 0
+#define POP_STANDALONE 1
#if POP_STANDALONE
@@ -103,7 +103,7 @@
* A pseudo-user to run as before authentication. The user and its UID
* must not be used for any other purpose.
*/
-#define POP_USER POP_SERVER
+#define POP_USER "mail"
/*
* An empty directory to chroot to before authentication. The directory
@@ -191,7 +191,7 @@
*
* #undef this for qmail-style $HOME/Mailbox mailboxes.
*/
-#define MAIL_SPOOL_PATH "/var/mail"
+#define MAIL_SPOOL_PATH "/var/spool/mail"
#ifndef MAIL_SPOOL_PATH
/*
@@ -216,7 +216,7 @@
*/
#define SYSLOG_IDENT POP_SERVER
#define SYSLOG_OPTIONS LOG_PID
-#define SYSLOG_FACILITY LOG_DAEMON
+#define SYSLOG_FACILITY LOG_MAIL
#define SYSLOG_PRI_LO LOG_INFO
#define SYSLOG_PRI_HI LOG_NOTICE
#define SYSLOG_PRI_ERROR LOG_CRIT