upower: 0.99.11 -> 0.99.12
This commit is contained in:
parent
fe3880d4b0
commit
31cf1d9229
@ -4,9 +4,7 @@ drwxr-xr-x root/root etc/UPower/
|
||||
drwxr-xr-x root/root lib/
|
||||
drwxr-xr-x root/root lib/udev/
|
||||
drwxr-xr-x root/root lib/udev/rules.d/
|
||||
-rw-r--r-- root/root lib/udev/rules.d/95-upower-csr.rules
|
||||
-rw-r--r-- root/root lib/udev/rules.d/95-upower-hid.rules
|
||||
-rw-r--r-- root/root lib/udev/rules.d/95-upower-hidpp.rules
|
||||
-rw-r--r-- root/root lib/udev/rules.d/95-upower-wup.rules
|
||||
drwxr-xr-x root/root usr/
|
||||
drwxr-xr-x root/root usr/bin/
|
||||
|
@ -1,8 +1,9 @@
|
||||
untrusted comment: verify with /etc/ports/opt.pub
|
||||
RWSE3ohX2g5d/f5fKUA6MhluxlVm5YTmRunVIu3HjjG2GlKtGX7P5tJEU+6fcb5d5n8MnLEbnp4ixF5sj+3MSHBPQD119bvssgk=
|
||||
SHA256 (Pkgfile) = 5c636356bf16aa4efb0b1c6c8c68430efbcebbb029b941a39462cc7402c10285
|
||||
SHA256 (.footprint) = f0e2f2153f4348add384180806a7425aa512ff4404508fa952457f1f48d1dfde
|
||||
SHA256 (upower-0.99.11.tar.xz) = 64b5ffbfccd5bdb15d925777979a4dbee1a957f9eaeb158dc76175267eddbdef
|
||||
RWSE3ohX2g5d/bkhtDmuiMcfruVlmWoMl4+bv7Fdhv197J0EhJTDTnqCOgLpW2ZZYouAT+zgp+ppjjVK8ewlhS26CYMUxyT6fwc=
|
||||
SHA256 (Pkgfile) = d93467328cc545d653ae47ae5345fb847d6e114e2e680e0059e98a85d3be9e6d
|
||||
SHA256 (.footprint) = 75b0f0a649894c258c1ffef1c60f8dd0fcf3bc889254adf6832c180b68517f6a
|
||||
SHA256 (upower-UPOWER_0_99_12.tar.bz2) = 21940a61bb84d9eb5b885b47b217a8d08c2ff1d00c8eaaad3a191a8fa55e527c
|
||||
SHA256 (upower.1) = c4e05bc89b31c9ddc206a33d97c15c2babbce5330f79e0849c84fb878e896c6b
|
||||
SHA256 (UPower.7) = 50b3e3b2cec513492c88e270fcf3dee2f98d11f52130827740f804a1492b6dd8
|
||||
SHA256 (upowerd.8) = d31cd082985a171a92d63126304964453d5dc3c1431960885f2fe2259784786f
|
||||
SHA256 (disable-gtk-docs.patch) = 7aadf5aeea7f667beadfec29febfc0cd63a5b7ec6b725b3af9a16242ce0dd7c9
|
||||
|
@ -5,14 +5,16 @@
|
||||
# Optional: gtk-doc
|
||||
|
||||
name=upower
|
||||
version=0.99.11
|
||||
version=0.99.12
|
||||
release=1
|
||||
source=(https://$name.freedesktop.org/releases/$name-$version.tar.xz
|
||||
upower.1 UPower.7 upowerd.8)
|
||||
source=(https://gitlab.freedesktop.org/upower/upower/-/archive/UPOWER_${version//[\.]/_}/upower-UPOWER_${version//[\.]/_}.tar.bz2
|
||||
upower.1 UPower.7 upowerd.8 disable-gtk-docs.patch)
|
||||
|
||||
build() {
|
||||
cd $name-$version
|
||||
cd $name-UPOWER_${version//[\.]/_}
|
||||
patch -Np1 -i $SRC/disable-gtk-docs.patch
|
||||
|
||||
NOCONFIGURE=1 ./autogen.sh
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
|
71
upower/disable-gtk-docs.patch
Normal file
71
upower/disable-gtk-docs.patch
Normal file
@ -0,0 +1,71 @@
|
||||
diff -Naur upower-UPOWER_0_99_12.orig/Makefile.am upower-UPOWER_0_99_12/Makefile.am
|
||||
--- upower-UPOWER_0_99_12.orig/Makefile.am 2021-08-06 16:26:55.755525389 +0200
|
||||
+++ upower-UPOWER_0_99_12/Makefile.am 2021-08-06 16:30:22.687472177 +0200
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
|
||||
|
||||
-SUBDIRS = etc dbus libupower-glib src doc tools po
|
||||
+SUBDIRS = etc dbus libupower-glib src tools po
|
||||
|
||||
if BACKEND_TYPE_LINUX
|
||||
SUBDIRS += rules
|
||||
@@ -35,7 +35,6 @@
|
||||
build-aux \
|
||||
ChangeLog \
|
||||
config.h.in \
|
||||
- gtk-doc.make \
|
||||
po/Makefile.in.in~ \
|
||||
po/Makevars.template \
|
||||
po/Rules-quot \
|
||||
@@ -51,12 +50,6 @@
|
||||
pkgconfigdir = $(libdir)/pkgconfig
|
||||
pkgconfig_DATA = upower-glib.pc
|
||||
|
||||
-# xsltproc barfs on 'make distcheck'; disable for now
|
||||
-DISTCHECK_CONFIGURE_FLAGS=--enable-man-pages --enable-gtk-doc \
|
||||
- --with-systemdsystemunitdir=$$dc_install_base/$(systemdsystemunitdir) \
|
||||
- --with-udevrulesdir='$${libdir}/udev/rules.d-distcheck' \
|
||||
- --enable-introspection=yes
|
||||
-
|
||||
clean-local :
|
||||
rm -f *~
|
||||
|
||||
diff -Naur upower-UPOWER_0_99_12.orig/autogen.sh upower-UPOWER_0_99_12/autogen.sh
|
||||
--- upower-UPOWER_0_99_12.orig/autogen.sh 2021-08-06 16:26:55.755525389 +0200
|
||||
+++ upower-UPOWER_0_99_12/autogen.sh 2021-08-06 16:27:13.529153011 +0200
|
||||
@@ -13,13 +13,6 @@
|
||||
exit 1
|
||||
fi
|
||||
|
||||
-GTKDOCIZE=`which gtkdocize`
|
||||
-if test -z $GTKDOCIZE; then
|
||||
- echo "*** No GTK-Doc found, please install it ***"
|
||||
- exit 1
|
||||
-fi
|
||||
-
|
||||
-gtkdocize --copy || exit 1
|
||||
autoreconf --verbose --force --install || exit 1
|
||||
|
||||
cd $olddir
|
||||
diff -Naur upower-UPOWER_0_99_12.orig/configure.ac upower-UPOWER_0_99_12/configure.ac
|
||||
--- upower-UPOWER_0_99_12.orig/configure.ac 2021-08-06 16:26:55.755525389 +0200
|
||||
+++ upower-UPOWER_0_99_12/configure.ac 2021-08-06 16:30:32.639222344 +0200
|
||||
@@ -80,8 +80,6 @@
|
||||
fi
|
||||
AM_CONDITIONAL(MAN_PAGES_ENABLED, test x$enable_man_pages = xyes)
|
||||
|
||||
-GTK_DOC_CHECK([1.11],[--flavour no-tmpl])
|
||||
-
|
||||
AC_ARG_WITH([udevrulesdir],
|
||||
AS_HELP_STRING([--with-udevrulesdir=DIR], [Directory for udev rules]),
|
||||
[],
|
||||
@@ -249,8 +247,6 @@
|
||||
src/linux/Makefile
|
||||
src/bsd/Makefile
|
||||
tools/Makefile
|
||||
-doc/Makefile
|
||||
-doc/version.xml
|
||||
doc/man/Makefile
|
||||
rules/Makefile
|
||||
libupower-glib/Makefile
|
Loading…
x
Reference in New Issue
Block a user