wvdial: update to 1.61

This commit is contained in:
Juergen Daubert 2009-09-30 10:28:20 +02:00
parent 88ee282f6c
commit 37212a541b
5 changed files with 83 additions and 72 deletions

View File

@ -1,4 +1,3 @@
64a1d235c64cc607aac25f9ceb3e4083 wvdial-1.60-scandir.patch
6fede1ca598a9905983a059f985807d5 wvdial-1.60.patch
27fbbde89f8fd9f6e735a8efa5217fc9 wvdial-1.60.tar.gz
4ee8ccfe6dfc29bf952d58fa23626c97 wvstreams-4.6.tar.gz
03c2263f4c4cdde3a0f82d983f7ab35c wvdial-1.61.patch
acd3b2050c9b65fff2aecda6576ee7bc wvdial-1.61.tar.gz
2760dac31a43d452a19a3147bfde571c wvstreams-4.6.1.tar.gz

View File

@ -1,23 +1,23 @@
# Description: Weave Dial - PPP dialer
# URL: http://open.nit.ca/wiki/?page=WvDial
# Maintainer: Juergen Daubert, juergen dot daubert at t-online dot de
# Depends on: ppp, openssl
# Depends on: ppp
name=wvdial
version=1.60
release=6
source=(http://alumnit.ca/download/$name-$version.tar.gz \
http://wvstreams.googlecode.com/files/wvstreams-4.6.tar.gz \
$name-$version.patch $name-$version-scandir.patch)
version=1.61
release=1
source=(http://wvstreams.googlecode.com/files/$name-$version.tar.gz \
http://wvstreams.googlecode.com/files/wvstreams-4.6.1.tar.gz \
$name-$version.patch)
build() {
cd wvstreams-4.6
cd wvstreams-4.6.1
./configure --prefix=/usr --without-{pam,tcl,qt,dbus}
make -j1
cd $SRC/$name-$version
patch -p1 -i $SRC/$name-$version-scandir.patch
patch -p1 -i $SRC/$name-$version.patch
make -j1 CXXOPTS="$CXXFLAGS" WVS=$SRC/wvstreams-4.6
./configure
make -j1 WVS=$SRC/wvstreams-4.6.1
make DESTDIR=$PKG install
}

View File

@ -1,14 +0,0 @@
# http://bugs.gentoo.org/show_bug.cgi?&id=271477
diff -Nru wvdial-1.60.orig/wvmodemscan.cc wvdial-1.60/wvmodemscan.cc
--- wvdial-1.60.orig/wvmodemscan.cc 2009-06-04 10:40:35.913426298 +0000
+++ wvdial-1.60/wvmodemscan.cc 2009-06-04 10:40:55.723426715 +0000
@@ -496,7 +496,7 @@
}
-static int filesort(const void *_e1, const void *_e2)
+static int filesort(const dirent **_e1, const dirent **_e2)
{
dirent const * const *e1 = (dirent const * const *)_e1;
dirent const * const *e2 = (dirent const * const *)_e2;

View File

@ -1,45 +0,0 @@
diff -Nru wvdial-1.60.orig/Makefile wvdial-1.60/Makefile
--- wvdial-1.60.orig/Makefile 2007-07-21 11:24:37.000000000 +0200
+++ wvdial-1.60/Makefile 2007-07-21 11:42:43.000000000 +0200
@@ -1,25 +1,17 @@
-prefix=/usr/local
-WVSTREAMS_INC=
-WVSTREAMS_LIB=
+prefix=$(DESTDIR)/usr
+WVSTREAMS_INC=$(WVS)/include
+WVSTREAMS_LIB=$(WVS)
WVSTREAMS_BIN=$(prefix)/bin
WVSTREAMS_SRC=.
-PC_CFLAGS=$(shell pkg-config --cflags libwvstreams)
-ifeq ($(PC_CFLAGS),)
- $(error WvStreams does not appear to be installed)
-endif
-CPPFLAGS+=$(PC_CFLAGS)
-
-PC_LIBS=$(shell pkg-config --libs libwvstreams)
-ifeq ($(PC_LIBS),)
- $(error WvStreams does not appear to be installed)
-endif
-LIBS+=$(PC_LIBS)
+LIBS = $(WVS)/libwvstatic.a -lstdc++ -lcrypto -lssl
BINDIR=${prefix}/bin
-MANDIR=${prefix}/share/man
-PPPDIR=/etc/ppp/peers
+MANDIR=${prefix}/man
+PPPDIR=$(DESTDIR)/etc/ppp/peers
+
+VERBOSE=1
include wvrules.mk
@@ -30,7 +22,6 @@
wvdial.a: wvdialer.o wvmodemscan.o wvpapchap.o wvdialbrain.o \
wvdialmon.o
-wvdial: LDFLAGS+=-luniconf
wvdial wvdialconf papchaptest pppmon: wvdial.a

71
wvdial/wvdial-1.61.patch Normal file
View File

@ -0,0 +1,71 @@
diff -Nru wvdial-1.61.orig/Makefile.in wvdial-1.61/Makefile.in
--- wvdial-1.61.orig/Makefile.in 2009-09-30 09:28:10.000000000 +0200
+++ wvdial-1.61/Makefile.in 2009-09-30 09:31:22.000000000 +0200
@@ -3,27 +3,19 @@
WVPACKAGE_TARNAME=@PACKAGE_TARNAME@
WVPACKAGE_VERSION=@PACKAGE_VERSION@
-prefix=/usr/local
-WVSTREAMS_INC=
-WVSTREAMS_LIB=
+prefix=$(DESTDIR)/usr
+WVSTREAMS_INC=$(WVS)/include
+WVSTREAMS_LIB=$(WVS)
WVSTREAMS_BIN=$(prefix)/bin
WVSTREAMS_SRC=.
-PC_CFLAGS=$(shell pkg-config --cflags libwvstreams)
-ifeq ($(PC_CFLAGS),)
- $(error WvStreams does not appear to be installed)
-endif
-CPPFLAGS+=$(PC_CFLAGS)
-
-PC_LIBS=$(shell pkg-config --libs libwvstreams)
-ifeq ($(PC_LIBS),)
- $(error WvStreams does not appear to be installed)
-endif
-LIBS+=$(PC_LIBS)
+LIBS = $(WVS)/libwvstatic.a -lstdc++ -lcrypto -lssl
BINDIR=${prefix}/bin
-MANDIR=${prefix}/share/man
-PPPDIR=/etc/ppp/peers
+MANDIR=${prefix}/man
+PPPDIR=$(DESTDIR)/etc/ppp/peers
+
+VERBOSE=1
include wvrules.mk
@@ -33,9 +25,6 @@
wvdial.a: wvdialer.o wvmodemscan.o wvpapchap.o wvdialbrain.o \
wvdialmon.o
-wvdial wvdialconf papchaptest pppmon: \
- LDFLAGS+=-luniconf -lwvstreams -lwvutils -lwvbase
-
wvdial wvdialconf papchaptest pppmon: wvdial.a
install-bin: all
diff -Nru wvdial-1.61.orig/config.defaults.mk wvdial-1.61/config.defaults.mk
--- wvdial-1.61.orig/config.defaults.mk 2009-09-30 09:28:10.000000000 +0200
+++ wvdial-1.61/config.defaults.mk 2009-09-30 10:06:24.000000000 +0200
@@ -13,7 +13,6 @@
LIBS_PAM=-lpam
LIBS_TCL=
-prefix=/usr/local
datadir=${prefix}/share
includedir=${prefix}/include
infodir=${prefix}/share/info
@@ -28,8 +27,8 @@
libexecdir=${exec_prefix}/libexec
sbindir=${exec_prefix}/sbin
-enable_debug=yes
-enable_optimization=no
+enable_debug=no
+enable_optimization=yes
enable_resolver_fork=
enable_warnings=
enable_testgui=