Merge branch '3.1' into 3.2

Conflicts:
	firefox/.footprint
	firefox/Pkgfile
This commit is contained in:
Juergen Daubert 2015-11-04 12:34:21 +01:00
commit 3a4a6d5cb3
30 changed files with 182 additions and 141 deletions

View File

@ -29,6 +29,7 @@ drwxr-xr-x root/root usr/include/tirpc/rpc/
-rw-r--r-- root/root usr/include/tirpc/rpc/svc.h
-rw-r--r-- root/root usr/include/tirpc/rpc/svc_auth.h
-rw-r--r-- root/root usr/include/tirpc/rpc/svc_dg.h
-rw-r--r-- root/root usr/include/tirpc/rpc/svc_mt.h
-rw-r--r-- root/root usr/include/tirpc/rpc/svc_soc.h
-rw-r--r-- root/root usr/include/tirpc/rpc/types.h
-rw-r--r-- root/root usr/include/tirpc/rpc/xdr.h
@ -38,9 +39,9 @@ drwxr-xr-x root/root usr/include/tirpc/rpcsvc/
drwxr-xr-x root/root usr/lib/
-rw-r--r-- root/root usr/lib/libtirpc.a
-rwxr-xr-x root/root usr/lib/libtirpc.la
lrwxrwxrwx root/root usr/lib/libtirpc.so -> libtirpc.so.1.0.10
lrwxrwxrwx root/root usr/lib/libtirpc.so.1 -> libtirpc.so.1.0.10
-rwxr-xr-x root/root usr/lib/libtirpc.so.1.0.10
lrwxrwxrwx root/root usr/lib/libtirpc.so -> libtirpc.so.3.0.0
lrwxrwxrwx root/root usr/lib/libtirpc.so.3 -> libtirpc.so.3.0.0
-rwxr-xr-x root/root usr/lib/libtirpc.so.3.0.0
drwxr-xr-x root/root usr/lib/pkgconfig/
-rw-r--r-- root/root usr/lib/pkgconfig/libtirpc.pc
drwxr-xr-x root/root usr/man/

View File

@ -1,2 +1 @@
373d5ad46b1d19759ec763a9f0afcf4d libtirpc-0.3.2.tar.bz2
5b974a1204defec51255b83a029bbb2b rpc_get_default_domain.patch
36ce1c0ff80863bb0839d54aa0b94014 libtirpc-1.0.1.tar.bz2

View File

@ -3,17 +3,13 @@
# URL: http://nfsv4.bullopensource.org/doc/tirpc_rpcbind.php
name=libtirpc
version=0.3.2
release=2
source=(http://downloads.sourceforge.net/project/$name/$name/$version/$name-$version.tar.bz2
rpc_get_default_domain.patch)
version=1.0.1
release=1
source=(http://downloads.sourceforge.net/project/$name/$name/$version/$name-$version.tar.bz2)
build() {
cd $name-$version
patch -p1 -i $SRC/rpc_get_default_domain.patch
autoreconf
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/man \

View File

@ -1,104 +0,0 @@
commit f7f6d01a83d136c98acbc1d7f098da25097bd0b6
Author: Armin K <krejzi@email.com>
Date: Thu Jun 18 11:59:18 2015 -0400
__rpc_get_default_domain is undefined with LDFLAGS=-Wl,--no-undefined
commit 109ccb9fe removed the __rpc_get_default_domain()
interface which is not defined in the glibc. This
brings the interface back.
Reviewed-by: Chuck Lever <chuck.lever@oracle.com>
Signed-off-by: Steve Dickson <steved@redhat.com>
diff --git a/src/Makefile.am b/src/Makefile.am
index 6cc567a..66fcc6c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -69,7 +69,7 @@ if GSS
endif
libtirpc_la_SOURCES += key_call.c key_prot_xdr.c getpublickey.c
-libtirpc_la_SOURCES += netname.c netnamer.c rtime.c
+libtirpc_la_SOURCES += netname.c netnamer.c rpcdname.c rtime.c
CLEANFILES = cscope.* *~
DISTCLEANFILES = Makefile.in
diff --git a/src/rpcdname.c b/src/rpcdname.c
new file mode 100644
index 0000000..3e6a988
--- /dev/null
+++ b/src/rpcdname.c
@@ -0,0 +1,72 @@
+/*
+ * Copyright (c) 2009, Sun Microsystems, Inc.
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions are met:
+ * - Redistributions of source code must retain the above copyright notice,
+ * this list of conditions and the following disclaimer.
+ * - Redistributions in binary form must reproduce the above copyright notice,
+ * this list of conditions and the following disclaimer in the documentation
+ * and/or other materials provided with the distribution.
+ * - Neither the name of Sun Microsystems, Inc. nor the names of its
+ * contributors may be used to endorse or promote products derived
+ * from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+ * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE
+ * LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+ * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+ * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+ * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+ * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
+
+/*
+ * rpcdname.c
+ * Gets the default domain name
+ */
+
+#include <stdlib.h>
+#include <unistd.h>
+#include <string.h>
+
+static char *default_domain = 0;
+
+static char *
+get_default_domain()
+{
+ char temp[256];
+
+ if (default_domain)
+ return (default_domain);
+ if (getdomainname(temp, sizeof(temp)) < 0)
+ return (0);
+ if ((int) strlen(temp) > 0) {
+ default_domain = (char *)malloc((strlen(temp)+(unsigned)1));
+ if (default_domain == 0)
+ return (0);
+ (void) strcpy(default_domain, temp);
+ return (default_domain);
+ }
+ return (0);
+}
+
+/*
+ * This is a wrapper for the system call getdomainname which returns a
+ * ypclnt.h error code in the failure case. It also checks to see that
+ * the domain name is non-null, knowing that the null string is going to
+ * get rejected elsewhere in the NIS client package.
+ */
+int
+__rpc_get_default_domain(domain)
+ char **domain;
+{
+ if ((*domain = get_default_domain()) != 0)
+ return (0);
+ return (-1);
+}

View File

@ -1 +1 @@
80af5af726949bbbb2aceb15b24b7d20 LVM2.2.02.132.tgz
48db435ed0ed6229a765b2644565c9c1 LVM2.2.02.133.tgz

View File

@ -4,7 +4,7 @@
# Depends on: libdevmapper
name=lvm2
version=2.02.132
version=2.02.133
release=1
source=(http://mirrors.kernel.org/sources.redhat.com/lvm2/releases/LVM2.$version.tgz)

View File

@ -1 +1 @@
ef6d848756ea9d19b7a7e1a9d824d7c1 php-5.5.30.tar.xz
c726a86238017c2d9db0171b14d300e7 php-5.6.15.tar.xz

View File

@ -4,7 +4,7 @@
# Depends on: xz apache libxml2
name=mod_php
version=5.5.30
version=5.6.15
release=1
source=(http://php.net/distributions/php-$version.tar.xz)

View File

@ -1,2 +1,2 @@
ef6d848756ea9d19b7a7e1a9d824d7c1 php-5.5.30.tar.xz
c726a86238017c2d9db0171b14d300e7 php-5.6.15.tar.xz
cdaab91680ba17cbf31b21d1b64dcd6a php-fcgi

View File

@ -4,7 +4,7 @@
# Depends on: xz libpcre libxml2
name=php-fcgi
version=5.5.30
version=5.6.15
release=1
source=(http://php.net/distributions/php-$version.tar.xz
php-fcgi)

View File

@ -1,2 +1,2 @@
ef6d848756ea9d19b7a7e1a9d824d7c1 php-5.5.30.tar.xz
c726a86238017c2d9db0171b14d300e7 php-5.6.15.tar.xz
954d95b7f645f3435815195aeeac6949 php-fpm

View File

@ -4,7 +4,7 @@
# Depends on: xz libpcre libxml2
name=php-fpm
version=5.5.30
version=5.6.15
release=1
source=(http://php.net/distributions/php-$version.tar.xz
php-fpm)

View File

@ -1 +1 @@
ef6d848756ea9d19b7a7e1a9d824d7c1 php-5.5.30.tar.xz
c726a86238017c2d9db0171b14d300e7 php-5.6.15.tar.xz

View File

@ -4,7 +4,7 @@
# Depends on: mysql
name=php-mysql
version=5.5.30
version=5.6.15
release=1
source=(http://php.net/distributions/php-$version.tar.xz)

View File

@ -1 +1 @@
ef6d848756ea9d19b7a7e1a9d824d7c1 php-5.5.30.tar.xz
c726a86238017c2d9db0171b14d300e7 php-5.6.15.tar.xz

View File

@ -4,7 +4,7 @@
# Depends on: sqlite3
name=php-sqlite3
version=5.5.30
version=5.6.15
release=1
source=(http://php.net/distributions/php-$version.tar.xz)

View File

@ -21,12 +21,12 @@ drwxr-xr-x root/root usr/include/php/TSRM/
-rw-r--r-- root/root usr/include/php/TSRM/tsrm_config_common.h
-rw-r--r-- root/root usr/include/php/TSRM/tsrm_nw.h
-rw-r--r-- root/root usr/include/php/TSRM/tsrm_strtok_r.h
-rw-r--r-- root/root usr/include/php/TSRM/tsrm_virtual_cwd.h
-rw-r--r-- root/root usr/include/php/TSRM/tsrm_win32.h
drwxr-xr-x root/root usr/include/php/Zend/
-rw-r--r-- root/root usr/include/php/Zend/zend.h
-rw-r--r-- root/root usr/include/php/Zend/zend_API.h
-rw-r--r-- root/root usr/include/php/Zend/zend_alloc.h
-rw-r--r-- root/root usr/include/php/Zend/zend_ast.h
-rw-r--r-- root/root usr/include/php/Zend/zend_build.h
-rw-r--r-- root/root usr/include/php/Zend/zend_builtin_functions.h
-rw-r--r-- root/root usr/include/php/Zend/zend_closures.h
@ -79,6 +79,7 @@ drwxr-xr-x root/root usr/include/php/Zend/
-rw-r--r-- root/root usr/include/php/Zend/zend_ts_hash.h
-rw-r--r-- root/root usr/include/php/Zend/zend_types.h
-rw-r--r-- root/root usr/include/php/Zend/zend_variables.h
-rw-r--r-- root/root usr/include/php/Zend/zend_virtual_cwd.h
-rw-r--r-- root/root usr/include/php/Zend/zend_vm.h
-rw-r--r-- root/root usr/include/php/Zend/zend_vm_def.h
-rw-r--r-- root/root usr/include/php/Zend/zend_vm_execute.h
@ -116,7 +117,6 @@ drwxr-xr-x root/root usr/include/php/ext/hash/
-rw-r--r-- root/root usr/include/php/ext/hash/php_hash_sha.h
-rw-r--r-- root/root usr/include/php/ext/hash/php_hash_snefru.h
-rw-r--r-- root/root usr/include/php/ext/hash/php_hash_tiger.h
-rw-r--r-- root/root usr/include/php/ext/hash/php_hash_types.h
-rw-r--r-- root/root usr/include/php/ext/hash/php_hash_whirlpool.h
drwxr-xr-x root/root usr/include/php/ext/iconv/
-rw-r--r-- root/root usr/include/php/ext/iconv/php_have_bsd_iconv.h
@ -163,12 +163,16 @@ drwxr-xr-x root/root usr/include/php/ext/pcre/
drwxr-xr-x root/root usr/include/php/ext/pdo/
-rw-r--r-- root/root usr/include/php/ext/pdo/php_pdo.h
-rw-r--r-- root/root usr/include/php/ext/pdo/php_pdo_driver.h
-rw-r--r-- root/root usr/include/php/ext/pdo/php_pdo_error.h
drwxr-xr-x root/root usr/include/php/ext/phar/
-rw-r--r-- root/root usr/include/php/ext/phar/php_phar.h
drwxr-xr-x root/root usr/include/php/ext/session/
-rw-r--r-- root/root usr/include/php/ext/session/mod_files.h
-rw-r--r-- root/root usr/include/php/ext/session/mod_user.h
-rw-r--r-- root/root usr/include/php/ext/session/php_session.h
drwxr-xr-x root/root usr/include/php/ext/simplexml/
-rw-r--r-- root/root usr/include/php/ext/simplexml/php_simplexml.h
-rw-r--r-- root/root usr/include/php/ext/simplexml/php_simplexml_exports.h
drwxr-xr-x root/root usr/include/php/ext/spl/
-rw-r--r-- root/root usr/include/php/ext/spl/php_spl.h
-rw-r--r-- root/root usr/include/php/ext/spl/spl_array.h
@ -267,6 +271,7 @@ drwxr-xr-x root/root usr/include/php/main/
-rw-r--r-- root/root usr/include/php/main/php_output.h
-rw-r--r-- root/root usr/include/php/main/php_reentrancy.h
-rw-r--r-- root/root usr/include/php/main/php_scandir.h
-rw-r--r-- root/root usr/include/php/main/php_stdint.h
-rw-r--r-- root/root usr/include/php/main/php_streams.h
-rw-r--r-- root/root usr/include/php/main/php_syslog.h
-rw-r--r-- root/root usr/include/php/main/php_ticks.h

View File

@ -1 +1 @@
ef6d848756ea9d19b7a7e1a9d824d7c1 php-5.5.30.tar.xz
c726a86238017c2d9db0171b14d300e7 php-5.6.15.tar.xz

View File

@ -4,7 +4,7 @@
# Depends on: readline libpcre libxml2 curl db gdbm xz
name=php
version=5.5.30
version=5.6.15
release=1
source=(http://php.net/distributions/php-$version.tar.xz)

View File

@ -1,2 +1,3 @@
06ea92b0f86f29b4c468694918da09c6 rpcbind
850a62791c4b55a78e2dba8756c7a450 rpcbind-0.2.3.patch
c8875246b2688a1adfbd6ad43480278d rpcbind-0.2.3.tar.bz2

View File

@ -7,17 +7,22 @@ name=rpcbind
version=0.2.3
release=2
source=(http://downloads.sourceforge.net/project/$name/$name/$version/$name-$version.tar.bz2 \
rpcbind)
$name-$version.patch rpcbind)
build() {
cd $name-$version
patch -p1 -i $SRC/$name-$version.patch
./configure --prefix=/usr \
--bindir=/sbin \
--mandir=/usr/man \
--disable-libwrap \
--with-rpcuser=root \
--without-systemdsystemunitdir
make
make DESTDIR=$PKG install
install -D -m 755 $SRC/rpcbind $PKG/etc/rc.d/rpcbind
}

138
rpcbind/rpcbind-0.2.3.patch Normal file
View File

@ -0,0 +1,138 @@
commit de47f6323d8fb20feefee21d0195cf0529151e04
Author: Steve Dickson <steved@redhat.com>
Date: Thu Sep 17 15:57:35 2015 -0400
security.c: removed warning
src/security.c:100:8: warning: implicit declaration of function 'xlog'
[-Wimplicit-function-declaration]
Signed-off-by: Steve Dickson <steved@redhat.com>
diff --git a/src/security.c b/src/security.c
index 0c9453f..c54ce26 100644
--- a/src/security.c
+++ b/src/security.c
@@ -17,6 +17,8 @@
#include <syslog.h>
#include <netdb.h>
+#include "xlog.h"
+
/*
* XXX for special case checks in check_callit.
*/
commit d5dace219953c45d26ae42db238052b68540649a
Author: Olaf Kirch <okir@suse.de>
Date: Fri Oct 30 10:18:20 2015 -0400
Fix memory corruption in PMAP_CALLIT code
- A PMAP_CALLIT call comes in on IPv4 UDP
- rpcbind duplicates the caller's address to a netbuf and stores it in
FINFO[0].caller_addr. caller_addr->buf now points to a memory region A
with a size of 16 bytes
- rpcbind forwards the call to the local service, receives a reply
- when processing the reply, it does this in xprt_set_caller:
xprt->xp_rtaddr = *FINFO[0].caller_addr
It sends out the reply, and then frees the netbuf caller_addr and
caller_addr.buf.
However, it does not clear xp_rtaddr, so xp_rtaddr.buf now refers
to memory region A, which is free.
- When the next call comes in on the UDP/IPv4 socket, svc_dg_recv will
be called, which will set xp_rtaddr to the client's address.
It will reuse the buffer inside xp_rtaddr, ie it will write a
sockaddr_in to region A
Some time down the road, an incoming TCP connection is accepted,
allocating a fresh SVCXPRT. The memory region A is inside the
new SVCXPRT
- While processing the TCP call, another UDP call comes in, again
overwriting region A with the client's address
- TCP client closes connection. In svc_destroy, we now trip over
the garbage left in region A
We ran into the case where a commercial scanner was triggering
occasional rpcbind segfaults. The core file that was captured showed
a corrupted xprt->xp_netid pointer that was really a sockaddr_in.
Signed-off-by: Olaf Kirch <okir@suse.de>
Signed-off-by: Steve Dickson <steved@redhat.com>
diff --git a/src/rpcb_svc_com.c b/src/rpcb_svc_com.c
index ff9ce6b..4ae93f1 100644
--- a/src/rpcb_svc_com.c
+++ b/src/rpcb_svc_com.c
@@ -1183,12 +1183,33 @@ check_rmtcalls(struct pollfd *pfds, int nfds)
return (ncallbacks_found);
}
+/*
+ * This is really a helper function defined in libtirpc,
+ * but unfortunately, it hasn't been exported yet.
+ */
+static struct netbuf *
+__rpc_set_netbuf(struct netbuf *nb, const void *ptr, size_t len)
+{
+ if (nb->len != len) {
+ if (nb->len)
+ mem_free(nb->buf, nb->len);
+ nb->buf = mem_alloc(len);
+ if (nb->buf == NULL)
+ return NULL;
+
+ nb->maxlen = nb->len = len;
+ }
+ memcpy(nb->buf, ptr, len);
+ return nb;
+}
+
static void
xprt_set_caller(SVCXPRT *xprt, struct finfo *fi)
{
+ const struct netbuf *caller = fi->caller_addr;
u_int32_t *xidp;
- *(svc_getrpccaller(xprt)) = *(fi->caller_addr);
+ __rpc_set_netbuf(svc_getrpccaller(xprt), caller->buf, caller->len);
xidp = __rpcb_get_dg_xidp(xprt);
*xidp = fi->caller_xid;
}
commit 9194122389f2a56b1cd1f935e64307e2e963c2da
Author: Steve Dickson <steved@redhat.com>
Date: Mon Nov 2 17:05:18 2015 -0500
handle_reply: Don't use the xp_auth pointer directly
In the latest libtirpc version to access the xp_auth
one must use the SVC_XP_AUTH macro. To be backwards
compatible a couple ifdefs were added to use the
macro when it exists.
Signed-off-by: Steve Dickson <steved@redhat.com>
diff --git a/src/rpcb_svc_com.c b/src/rpcb_svc_com.c
index 4ae93f1..22d6c84 100644
--- a/src/rpcb_svc_com.c
+++ b/src/rpcb_svc_com.c
@@ -1295,10 +1295,17 @@ handle_reply(int fd, SVCXPRT *xprt)
a.rmt_localvers = fi->versnum;
xprt_set_caller(xprt, fi);
+#if defined(SVC_XP_AUTH)
+ SVC_XP_AUTH(xprt) = svc_auth_none;
+#else
xprt->xp_auth = &svc_auth_none;
+#endif
svc_sendreply(xprt, (xdrproc_t) xdr_rmtcall_result, (char *) &a);
+#if !defined(SVC_XP_AUTH)
SVCAUTH_DESTROY(xprt->xp_auth);
xprt->xp_auth = NULL;
+#endif
+
done:
if (buffer)
free(buffer);

View File

@ -1 +1 @@
fcb59c6c8a1d30cc6ffc21557a0046d3 samhain_signed-4.1.0.tar.gz
5323a1d89435b090e67679131aebb2cf samhain_signed-4.1.1.tar.gz

View File

@ -3,7 +3,7 @@
# Maintainer: Juergen Daubert, jue at crux dot nu
name=samhain
version=4.1.0
version=4.1.1
release=1
source=(http://la-samhna.de/archive/${name}_signed-$version.tar.gz)

View File

@ -1 +1 @@
74931054399a2d7acf35637efe8d6f45 sqlite-autoconf-3090100.tar.gz
bc4eb5b3fc5cfcb6e059794306cac1ca sqlite-autoconf-3090200.tar.gz

View File

@ -4,7 +4,7 @@
# Depends on: ncurses, readline
name=sqlite3
version=3.9.1
version=3.9.2
release=1
_version=$(printf "%i%.2i%.2i%.2i" ${version//./ })

View File

@ -1,2 +1,2 @@
be8031c772fc51aaa1a9fb22ecac6585 squid
5ddc53bd6ff78234691a7ebbcbc6aa38 squid-3.5.10.tar.xz
eb5e1cf3cf012e5b85d6f7ca78b7afab squid-3.5.11.tar.xz

View File

@ -3,7 +3,7 @@
# Maintainer: Juergen Daubert, jue at crux dot nu
name=squid
version=3.5.10
version=3.5.11
release=1
source=(http://www.squid-cache.org/Versions/v3/3.5/$name-$version.tar.xz
squid)

View File

@ -1,3 +1,3 @@
4d5387895f3a162d63a6ed76ebbafae8 stunnel
24ad1f10525181edcf82433aac8bad0b stunnel-5.24.tar.gz
326126f56a76eec974d3a31ebedb9623 stunnel-5.25.tar.gz
16694d0e035fdd5e908ff42bc44ea805 stunnel.conf

View File

@ -4,7 +4,7 @@
# Depends on: openssl tcp_wrappers zlib
name=stunnel
version=5.24
version=5.25
release=1
source=(https://www.stunnel.org/downloads/$name-$version.tar.gz \
$name.conf $name)