poppler-glib: update to 0.60.0
This commit is contained in:
parent
74b681afe0
commit
3b1572364f
@ -1,2 +1 @@
|
||||
6e44408a3b4f4a738f8a6770d0aea8a5 poppler-0.59.0.tar.xz
|
||||
2d8ea187fdf89d2562be28506265ae4a poppler-cmake.patch
|
||||
2cde7f726363dbcdc23c95002ac60cc6 poppler-0.60.0.tar.xz
|
||||
|
@ -1,6 +1,5 @@
|
||||
untrusted comment: verify with /etc/ports/opt.pub
|
||||
RWSE3ohX2g5d/QlMon+j6Q0NsUPZzyIGwN+S8OihyDB4kDZRJzoUXHoF42kqK/LJlZkn/FgNAOASynQ9j9HUWTBzXu69OCIyTAI=
|
||||
SHA256 (Pkgfile) = b5687cf015d37f72cd4fe4cfa1ee664bddd3f7688117cbab826c5528f4ca7c81
|
||||
RWSE3ohX2g5d/UEZwOAD2G+z88RcFG0OX8pOuQV8aF6u59aCR+JlyjiI9IGz9PY3WCRGfoAG6wSQrcqMvDXPMoIb6I5HPzQMkww=
|
||||
SHA256 (Pkgfile) = ae9192775ebb07f0de9c422baa2d2541e5f09a8b8a59a39ab9761a1e99a7c51b
|
||||
SHA256 (.footprint) = 7f982db800a0148c3e12d898e61c070f2d7038bfc561d2184a471a7eca442ee9
|
||||
SHA256 (poppler-0.59.0.tar.xz) = a3d626b24cd14efa9864e12584b22c9c32f51c46417d7c10ca17651f297c9641
|
||||
SHA256 (poppler-cmake.patch) = f170e24a8c9c515df3ab5362e873f3b74b063ef152d502650524436cdac14ae9
|
||||
SHA256 (poppler-0.60.0.tar.xz) = 1570774f44ba86c42ffacc5d9151a771e99584a55e6631bdf267123a2aed1c72
|
||||
|
@ -4,22 +4,21 @@
|
||||
# Depends on: gobject-introspection poppler
|
||||
|
||||
name=poppler-glib
|
||||
version=0.59.0
|
||||
version=0.60.0
|
||||
release=1
|
||||
source=(http://poppler.freedesktop.org/poppler-$version.tar.xz
|
||||
poppler-cmake.patch)
|
||||
source=(http://poppler.freedesktop.org/poppler-$version.tar.xz)
|
||||
|
||||
build() {
|
||||
cd poppler-$version
|
||||
|
||||
patch -p0 -i $SRC/poppler-cmake.patch
|
||||
|
||||
# fix version string
|
||||
sed -i '/POPPLER_MINOR_VERSION/s/59/60/' CMakeLists.txt
|
||||
|
||||
cmake . \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DENABLE_XPDF_HEADERS=OFF \
|
||||
-DENABLE_UTILS=OFF \
|
||||
-DENABLE_SPLASH=ON \
|
||||
-DENABLE_CAIRO=ON \
|
||||
-DENABLE_CPP=OFF \
|
||||
-DENABLE_GLIB=ON \
|
||||
-DENABLE_QT4=OFF \
|
||||
|
@ -1,139 +0,0 @@
|
||||
--- CMakeLists.txt.orig 2017-09-03 22:54:06.000000000 +0200
|
||||
+++ CMakeLists.txt 2017-09-04 14:38:15.234927567 +0200
|
||||
@@ -36,8 +36,14 @@
|
||||
option(BUILD_QT5_TESTS "Whether compile the Qt5 test programs." ON)
|
||||
option(BUILD_CPP_TESTS "Whether compile the CPP test programs." ON)
|
||||
option(ENABLE_SPLASH "Build the Splash graphics backend." ON)
|
||||
+option(ENABLE_CAIRO "Build the Cairo graphics backend." ON)
|
||||
option(ENABLE_UTILS "Compile poppler command line utils." ON)
|
||||
option(ENABLE_CPP "Compile poppler cpp wrapper." ON)
|
||||
+option(ENABLE_GLIB "Compile poppler glib wrapper." ON)
|
||||
+option(ENABLE_QT4 "Compile poppler QT4 wrapper." ON)
|
||||
+option(ENABLE_QT5 "Compile poppler QT5 wrapper." ON)
|
||||
+option(ENABLE_NSS3 "Build with NSS3 support." OFF)
|
||||
+
|
||||
set(ENABLE_LIBOPENJPEG "auto" CACHE STRING "Use libopenjpeg for JPX streams. Possible values: auto, openjpeg1, openjpeg2, unmaintained, none. 'auto' prefers openjpeg2 over openjpeg1 if both are available. 'unmaintained' gives you the internal unmaintained decoder. Use at your own risk. 'none' compiles no JPX decoder at all. Default: auto")
|
||||
set(ENABLE_CMS "auto" CACHE STRING "Use color management system. Possible values: auto, lcms1, lcms2. 'auto' prefers lcms2 over lcms1 if both are available. Unset to disable color management system.")
|
||||
set(ENABLE_DCTDECODER "libjpeg" CACHE STRING "Use libjpeg for DCT streams. Possible values: libjpeg, unmaintained, none. will use libjpeg if available or fail if not. 'unmaintained' gives you the internal unmaintained decoder. Use at your own risk. 'none' compiles no DCT decoder at all. Default: libjpeg")
|
||||
@@ -130,38 +136,47 @@
|
||||
message(FATAL_ERROR "Invalid ENABLE_DCTDECODER value.")
|
||||
endif()
|
||||
macro_optional_find_package(Qt4)
|
||||
-find_package(Qt5Core)
|
||||
-find_package(Qt5Gui)
|
||||
-find_package(Qt5Xml)
|
||||
-find_package(Qt5Widgets)
|
||||
-find_package(Qt5Test)
|
||||
-if (Qt5Core_FOUND AND Qt5Gui_FOUND AND Qt5Xml_FOUND AND Qt5Widgets_FOUND AND Qt5Test_FOUND)
|
||||
- set(QT5_FOUND true)
|
||||
-else ()
|
||||
- message("-- Package Qt5Core or Qt5Gui or Qt5Xml or Qt5Widgets or Qt5Test not found")
|
||||
- set(QT5_FOUND false)
|
||||
+
|
||||
+
|
||||
+if(ENABLE_QT5)
|
||||
+ find_package(Qt5Core)
|
||||
+ find_package(Qt5Gui)
|
||||
+ find_package(Qt5Xml)
|
||||
+ find_package(Qt5Widgets)
|
||||
+ find_package(Qt5Test)
|
||||
+ if (Qt5Core_FOUND AND Qt5Gui_FOUND AND Qt5Xml_FOUND AND Qt5Widgets_FOUND AND Qt5Test_FOUND)
|
||||
+ set(QT5_FOUND true)
|
||||
+ else ()
|
||||
+ message("-- Package Qt5Core or Qt5Gui or Qt5Xml or Qt5Widgets or Qt5Test not found")
|
||||
+ set(QT5_FOUND false)
|
||||
+ endif()
|
||||
endif()
|
||||
|
||||
-macro_optional_find_package(Cairo ${CAIRO_VERSION})
|
||||
-if(CAIRO_FOUND)
|
||||
- set(HAVE_CAIRO ${CAIRO_FOUND})
|
||||
- set(CAIRO_FEATURE "#define POPPLER_HAS_CAIRO 1")
|
||||
- set(CAIRO_REQ "cairo")
|
||||
- set(POPPLER_GLIB_DISABLE_DEPRECATED "")
|
||||
- set(POPPLER_GLIB_DISABLE_SINGLE_INCLUDES "")
|
||||
- macro_optional_find_package(GLIB)
|
||||
- if(GLIB_FOUND)
|
||||
- set(ENABLE_GLIB ON)
|
||||
- # Check for introspection
|
||||
- macro_optional_find_package(GObjectIntrospection 0.9.12)
|
||||
- set(HAVE_INTROSPECTION ${INTROSPECTION_FOUND})
|
||||
- set(POPPLER_GLIB_DISABLE_DEPRECATED "${POPPLER_GLIB_DISABLE_DEPRECATED} -DG_DISABLE_DEPRECATED")
|
||||
- set(POPPLER_GLIB_DISABLE_SINGLE_INCLUDES "${POPPLER_GLIB_DISABLE_SINGLE_INCLUDES} -DG_DISABLE_SINGLE_INCLUDES")
|
||||
- macro_optional_find_package(GTK)
|
||||
+
|
||||
+if(ENABLE_CAIRO)
|
||||
+ macro_optional_find_package(Cairo ${CAIRO_VERSION})
|
||||
+ if(CAIRO_FOUND)
|
||||
+ set(HAVE_CAIRO ${CAIRO_FOUND})
|
||||
+ set(CAIRO_FEATURE "#define POPPLER_HAS_CAIRO 1")
|
||||
+ set(CAIRO_REQ "cairo")
|
||||
+ set(POPPLER_GLIB_DISABLE_DEPRECATED "")
|
||||
+ set(POPPLER_GLIB_DISABLE_SINGLE_INCLUDES "")
|
||||
+ macro_optional_find_package(GLIB)
|
||||
+ if(ENABLE_GLIB)
|
||||
+ set(ENABLE_GLIB ON)
|
||||
+ # Check for introspection
|
||||
+ macro_optional_find_package(GObjectIntrospection 0.9.12)
|
||||
+ set(HAVE_INTROSPECTION ${INTROSPECTION_FOUND})
|
||||
+ set(POPPLER_GLIB_DISABLE_DEPRECATED "${POPPLER_GLIB_DISABLE_DEPRECATED} -DG_DISABLE_DEPRECATED")
|
||||
+ set(POPPLER_GLIB_DISABLE_SINGLE_INCLUDES "${POPPLER_GLIB_DISABLE_SINGLE_INCLUDES} -DG_DISABLE_SINGLE_INCLUDES")
|
||||
+ macro_optional_find_package(GTK)
|
||||
+ endif()
|
||||
+ else()
|
||||
+ set(CAIRO_FEATURE "#undef POPPLER_HAS_CAIRO")
|
||||
endif()
|
||||
-else()
|
||||
- set(CAIRO_FEATURE "#undef POPPLER_HAS_CAIRO")
|
||||
endif()
|
||||
+
|
||||
+
|
||||
if(ENABLE_CPP)
|
||||
macro_optional_find_package(Iconv)
|
||||
set(ENABLE_CPP ${ICONV_FOUND})
|
||||
@@ -275,7 +290,7 @@
|
||||
include_directories(${ZLIB_INCLUDE_DIR})
|
||||
endif()
|
||||
|
||||
-if (NSS3_FOUND)
|
||||
+if (ENABLE_NSS3 AND NSS3_FOUND)
|
||||
add_definitions(${NSS3_CFLAGS})
|
||||
set(ENABLE_NSS3 ON)
|
||||
endif()
|
||||
@@ -716,10 +731,10 @@
|
||||
add_subdirectory(glib)
|
||||
endif()
|
||||
add_subdirectory(test)
|
||||
-if(QT4_FOUND)
|
||||
+if(ENABLE_QT4)
|
||||
add_subdirectory(qt4)
|
||||
endif()
|
||||
-if(QT5_FOUND)
|
||||
+if(ENABLE_QT5)
|
||||
add_subdirectory(qt5)
|
||||
endif()
|
||||
if(ENABLE_CPP)
|
||||
@@ -743,10 +758,10 @@
|
||||
if(ENABLE_SPLASH)
|
||||
poppler_create_install_pkgconfig(poppler-splash.pc lib${LIB_SUFFIX}/pkgconfig)
|
||||
endif()
|
||||
-if(QT4_FOUND)
|
||||
+if(ENABLE_QT4)
|
||||
poppler_create_install_pkgconfig(poppler-qt4.pc lib${LIB_SUFFIX}/pkgconfig)
|
||||
endif()
|
||||
-if(QT5_FOUND)
|
||||
+if(ENABLE_QT5)
|
||||
poppler_create_install_pkgconfig(poppler-qt5.pc lib${LIB_SUFFIX}/pkgconfig)
|
||||
endif()
|
||||
if(ENABLE_GLIB)
|
||||
@@ -767,8 +782,8 @@
|
||||
message(" with CMYK support")
|
||||
endif()
|
||||
show_end_message_yesno("cairo output" CAIRO_FOUND)
|
||||
-show_end_message_yesno("qt4 wrapper" QT4_FOUND)
|
||||
-show_end_message_yesno("qt5 wrapper" QT5_FOUND)
|
||||
+show_end_message_yesno("qt4 wrapper" ENABLE_QT4)
|
||||
+show_end_message_yesno("qt5 wrapper" ENABLE_QT5)
|
||||
show_end_message_yesno("glib wrapper" ENABLE_GLIB)
|
||||
show_end_message_yesno(" introspection" INTROSPECTION_FOUND)
|
||||
show_end_message_yesno("cpp wrapper" ENABLE_CPP)
|
Loading…
x
Reference in New Issue
Block a user