msntp: removed

This commit is contained in:
Juergen Daubert 2019-02-03 12:57:07 +01:00
parent 429e7a395e
commit 3be50020e1
4 changed files with 0 additions and 100 deletions

View File

@ -1,7 +0,0 @@
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/sbin/
-rwxr-xr-x root/root usr/sbin/msntp
drwxr-xr-x root/root usr/share/
drwxr-xr-x root/root usr/share/man/
drwxr-xr-x root/root usr/share/man/man1/
-rw-r--r-- root/root usr/share/man/man1/msntp.1.gz

View File

@ -1,6 +0,0 @@
untrusted comment: verify with /etc/ports/opt.pub
RWSE3ohX2g5d/VWTVAjtQ4UlkBNSIRoE6Jcht96O6yp//G25Qsf1by/vsly3U6Oj399IxK6YcSm+qVLtIzuHp6EgF2WLmMsn1gE=
SHA256 (Pkgfile) = 46efc23033120de27a7ee8941f776caad223b97135e0a2e4c20baea46a7115ca
SHA256 (.footprint) = d4cb1d3a9a0ae554ebc0bc81fa18cf63e6626bf276c811d2d517a02342cf5578
SHA256 (msntp-1.6.tar.gz) = 30d170734d5ef8e7a5ba68ec2add4206a2133b43e3c7150100689304cf6528e5
SHA256 (msntp-1.6.patch) = ff1acb783afbdca64f979ec0aed9017f17fde8b0deb9c34a7cd2942a81da971c

View File

@ -1,18 +0,0 @@
# Description: Simple Network Time Protocol server/client/utility
# URL: http://www.hpcf.cam.ac.uk/export/
# Maintainer: Juergen Daubert, jue at crux dot nu
name=msntp
version=1.6
release=3
source=(http://distcache.freebsd.org/ports-distfiles/$name-$version.tar.gz \
$name-$version.patch)
build () {
cd $name-$version
patch -p1 -i $SRC/$name-$version.patch
make
install -d $PKG/usr/{sbin,share/man/man1}
install msntp $PKG/usr/sbin
install -m 0644 msntp.1 $PKG/usr/share/man/man1
}

View File

@ -1,69 +0,0 @@
diff -Nru msntp-1.6.orig/Makefile msntp-1.6/Makefile
--- msntp-1.6.orig/Makefile 2016-11-30 13:36:11.403554863 +0100
+++ msntp-1.6/Makefile 2016-11-30 13:36:37.049294512 +0100
@@ -11,7 +11,7 @@
# CC = cc
# CFLAGS = -O
# LDFLAGS =
-# LIBS = -lm
+LIBS = -lm
# Compiling this sort of ANSI C under SunOS 4.1 is a mug's game, because Sun's
# Unix headers make GNU C vomit even in compatibility mode, but the following
diff -Nru msntp-1.6.orig/header.h msntp-1.6/header.h
--- msntp-1.6.orig/header.h 2016-11-30 13:36:11.403554863 +0100
+++ msntp-1.6/header.h 2016-11-30 13:37:07.741518412 +0100
@@ -19,10 +19,10 @@
#define MAX_SOCKETS 10 /* Maximum number of addresses */
#ifndef LOCKNAME
- #define LOCKNAME "/etc/msntp.pid" /* Stores the pid */
+ #define LOCKNAME "/var/run/msntp.pid" /* Stores the pid */
#endif
#ifndef SAVENAME
- #define SAVENAME "/etc/msntp.state" /* Stores the recovery state */
+ #define SAVENAME "/var/run/msntp.state" /* Stores the recovery state */
#endif
@@ -65,7 +65,7 @@
/* Defined in socket.c */
-extern void open_sockets (int which, char *hostnames, int timespan);
+extern void open_socket (int which, char *hostnames, int timespan);
extern void write_socket (int which, void *packet, int length);
diff -Nru msntp-1.6.orig/msntp.1 msntp-1.6/msntp.1
--- msntp-1.6.orig/msntp.1 2016-11-30 13:36:11.403554863 +0100
+++ msntp-1.6/msntp.1 2016-11-30 13:36:37.052627724 +0100
@@ -143,7 +143,7 @@
one copy of
.I msntp
running at once. The default is installation-dependent, but will usually be
-.IR /etc/msntp.pid .
+.IR /var/run/msntp.pid .
.TP
.BI \-e " minerr"
sets the maximum ignorable variation between the clocks to
@@ -214,7 +214,7 @@
Note that the file will be created with the default ownerships and permissions,
using standard C facilities. The default is installation-dependent, but will
usually be
-.IR /etc/msntp.state .
+.IR /var/run/msntp.state .
.PP
.B address(es)
are the DNS names or IP numbers of hosts to use for the challenge and response
diff -Nru msntp-1.6.orig/unix.c msntp-1.6/unix.c
--- msntp-1.6.orig/unix.c 2016-11-30 13:36:11.403554863 +0100
+++ msntp-1.6/unix.c 2016-11-30 13:37:36.770469102 +0100
@@ -10,6 +10,7 @@
#include "header.h"
#include <sys/types.h>
+#include <signal.h>
#include <unistd.h>
#include <syslog.h>