sqlite3: update to 3.6.11

This commit is contained in:
Juergen Daubert 2009-02-18 16:25:44 +01:00
parent 6feabd84dd
commit 3f97f97b1b
3 changed files with 7 additions and 58 deletions

View File

@ -1,2 +1 @@
0c3f1333cc3dd5179b59ee9f4b2ef4c3 sqlite-amalgamation-3.6.10.tar.gz
06d5c38bac4e5589e559f1e1e9bb67ea sqlite3-pkgconfig.patch
da1f95c6b173fd56d2760bcfd2a3c756 sqlite-amalgamation-3.6.11.tar.gz

View File

@ -4,22 +4,18 @@
# Depends on: ncurses, readline
name=sqlite3
version=3.6.10
version=3.6.11
release=1
source=(http://www.sqlite.org/sqlite-amalgamation-$version.tar.gz
sqlite3-pkgconfig.patch)
source=(http://www.sqlite.org/sqlite-amalgamation-$version.tar.gz)
build () {
cd sqlite-amalgamation-$version
cd sqlite-$version
patch -p1 -i $SRC/sqlite3-pkgconfig.patch
# http://www.sqlite.org/cvstrac/tktview?tn=3583
sed -i 's/@RELEASE@/@VERSION@/' sqlite3.pc.in
autoreconf -f
libtoolize -fq
CFLAGS="$CFLAGS -DNDEBUG" \
./configure --prefix=/usr
./configure --prefix=/usr CFLAGS="$CFLAGS -DNDEBUG"
make
make DESTDIR=$PKG install

View File

@ -1,46 +0,0 @@
# Patch to add support for the pkgconfig-file sqlite3.pc, needed by at least firefox.
# See my upstream bugreport here http://www.sqlite.org/cvstrac/tktview?tn=3583.
# We want the amalgamation version of the sources, because we otherwise have to install
# tcl to build sqlite3 with special options like -DSQLITE_ENABLE_FTS3=1
#
# 2009-01-14 jue
diff -Nru sqlite-amalgamation-3.6.9.orig/Makefile.am sqlite-amalgamation-3.6.9/Makefile.am
--- sqlite-amalgamation-3.6.9.orig/Makefile.am 2009-01-14 14:13:11.000000000 +0100
+++ sqlite-amalgamation-3.6.9/Makefile.am 2009-01-14 17:04:30.000000000 +0100
@@ -12,3 +12,5 @@
include_HEADERS = sqlite3.h sqlite3ext.h
+pkgconfigdir = ${libdir}/pkgconfig
+pkgconfig_DATA = sqlite3.pc
diff -Nru sqlite-amalgamation-3.6.9.orig/configure.ac sqlite-amalgamation-3.6.9/configure.ac
--- sqlite-amalgamation-3.6.9.orig/configure.ac 2009-01-14 14:13:11.000000000 +0100
+++ sqlite-amalgamation-3.6.9/configure.ac 2009-01-14 14:58:02.000000000 +0100
@@ -24,7 +24,8 @@
# Check for library functions that SQLite can optionally use.
AC_CHECK_FUNCS([fdatasync usleep fullfsync localtime_r gmtime_r])
-AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([Makefile sqlite3.pc])
+AC_SUBST(BUILD_CFLAGS)
#-----------------------------------------------------------------------
# --enable-readline
diff -Nru sqlite-amalgamation-3.6.9.orig/sqlite3.pc.in sqlite-amalgamation-3.6.9/sqlite3.pc.in
--- sqlite-amalgamation-3.6.9.orig/sqlite3.pc.in 1970-01-01 01:00:00.000000000 +0100
+++ sqlite-amalgamation-3.6.9/sqlite3.pc.in 2009-01-14 12:49:13.000000000 +0100
@@ -0,0 +1,13 @@
+# Package Information for pkg-config
+
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
+includedir=@includedir@
+
+Name: SQLite
+Description: SQL database engine
+Version: @VERSION@
+Libs: -L${libdir} -lsqlite3
+Libs.private: @LIBS@
+Cflags: -I${includedir}