sqlite3: update to 3.5.6

This commit is contained in:
Juergen Daubert 2008-02-13 12:33:44 +01:00
parent 7d58cab2c0
commit 461016ba1c
3 changed files with 4 additions and 30 deletions

View File

@ -1,2 +1 @@
f17da840eed792e896c3408d0ce97718 sqlite-3.5.4.tar.gz
b0887758b555ff4ae51754491c5d2786 sqlite3-without_tcl.patch
903c9e935c538af392364a9172a3d98d sqlite-3.5.6.tar.gz

View File

@ -4,15 +4,13 @@
# Depends on: ncurses, readline
name=sqlite3
version=3.5.4
release=2
version=3.5.6
release=1
source=(http://www.sqlite.org/sqlite-$version.tar.gz \
$name-without_tcl.patch)
source=(http://www.sqlite.org/sqlite-$version.tar.gz)
build () {
cd sqlite-$version
patch -p1 -i $SRC/$name-without_tcl.patch
./configure --prefix=/usr \
--enable-threadsafe \
--disable-tcl

View File

@ -1,23 +0,0 @@
diff -Nru sqlite-3.5.4.orig/Makefile.in sqlite-3.5.4/Makefile.in
--- sqlite-3.5.4.orig/Makefile.in 2007-12-17 10:23:23.000000000 +0100
+++ sqlite-3.5.4/Makefile.in 2007-12-17 10:25:05.000000000 +0100
@@ -317,18 +317,11 @@
-rpath $(libdir)/sqlite \
-version-info "8:6:8"
-testcli$(TEXE): $(TOP)/src/shell.c libsqlite3.la sqlite3.h
+sqlite3$(TEXE): $(TOP)/src/shell.c libsqlite3.la sqlite3.h
$(LTLINK) $(READLINE_FLAGS) $(LIBPTHREAD) \
-o $@ $(TOP)/src/shell.c libsqlite3.la \
$(LIBREADLINE) $(TLIBS)
-sqlite3$(EXE): $(TOP)/src/shell.c sqlite3.c sqlite3.h
- $(LTLINK) $(READLINE_FLAGS) -o $@ \
- -DSQLITE_MAX_SQL_LENGTH=1000000000 \
- -USQLITE_THREADSAFE -DSQLITE_THREADSAFE=0 \
- $(TOP)/src/shell.c sqlite3.c \
- $(LIBREADLINE) $(TLIBS) $(THREADLIB)
-
# This target creates a directory named "tsrc" and fills it with
# copies of all of the C source code and header files needed to
# build on the target system. Some of the C source code and header