libcap: new port

This commit is contained in:
Antti Nykanen 2008-10-14 13:24:03 +03:00
parent 28b41ec2d3
commit 4cb15c920d
4 changed files with 87 additions and 0 deletions

41
libcap/.footprint Normal file
View File

@ -0,0 +1,41 @@
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/include/
drwxr-xr-x root/root usr/include/sys/
-rw-r--r-- root/root usr/include/sys/capability.h
drwxr-xr-x root/root usr/lib/
-rw-r--r-- root/root usr/lib/libcap.a
lrwxrwxrwx root/root usr/lib/libcap.so -> libcap.so.2
lrwxrwxrwx root/root usr/lib/libcap.so.2 -> libcap.so.2.12
-rw-r--r-- root/root usr/lib/libcap.so.2.12
drwxr-xr-x root/root usr/man/
drwxr-xr-x root/root usr/man/man3/
-rw-r--r-- root/root usr/man/man3/cap_clear.3.gz
-rw-r--r-- root/root usr/man/man3/cap_clear_flag.3.gz
-rw-r--r-- root/root usr/man/man3/cap_compare.3.gz
-rw-r--r-- root/root usr/man/man3/cap_copy_ext.3.gz
-rw-r--r-- root/root usr/man/man3/cap_copy_int.3.gz
-rw-r--r-- root/root usr/man/man3/cap_dup.3.gz
-rw-r--r-- root/root usr/man/man3/cap_free.3.gz
-rw-r--r-- root/root usr/man/man3/cap_from_name.3.gz
-rw-r--r-- root/root usr/man/man3/cap_from_text.3.gz
-rw-r--r-- root/root usr/man/man3/cap_get_fd.3.gz
-rw-r--r-- root/root usr/man/man3/cap_get_file.3.gz
-rw-r--r-- root/root usr/man/man3/cap_get_flag.3.gz
-rw-r--r-- root/root usr/man/man3/cap_get_pid.3.gz
-rw-r--r-- root/root usr/man/man3/cap_get_proc.3.gz
-rw-r--r-- root/root usr/man/man3/cap_init.3.gz
-rw-r--r-- root/root usr/man/man3/cap_set_fd.3.gz
-rw-r--r-- root/root usr/man/man3/cap_set_file.3.gz
-rw-r--r-- root/root usr/man/man3/cap_set_flag.3.gz
-rw-r--r-- root/root usr/man/man3/cap_set_proc.3.gz
-rw-r--r-- root/root usr/man/man3/cap_size.3.gz
-rw-r--r-- root/root usr/man/man3/cap_to_name.3.gz
-rw-r--r-- root/root usr/man/man3/cap_to_text.3.gz
-rw-r--r-- root/root usr/man/man3/capgetp.3.gz
-rw-r--r-- root/root usr/man/man3/capsetp.3.gz
-rw-r--r-- root/root usr/man/man3/libcap.3.gz
drwxr-xr-x root/root usr/sbin/
-rwxr-xr-x root/root usr/sbin/capsh
-rwxr-xr-x root/root usr/sbin/getcap
-rwxr-xr-x root/root usr/sbin/getpcaps
-rwxr-xr-x root/root usr/sbin/setcap

2
libcap/.md5sum Normal file
View File

@ -0,0 +1,2 @@
c67b2d105f48d9413f0f5a16b2162f70 libcap-2.12-makefile.patch
fd306198931960d16d1dc53d305e01d2 libcap-2.12.tar.gz

26
libcap/Pkgfile Normal file
View File

@ -0,0 +1,26 @@
# Description: POSIX.1e capabilities library
# URL: http://linux.kernel.org/pub/linux/libs/security/linux-privs/
# Maintainer: Antti Nykanen, aon at iki dot fi
# Depends on: libattr
name=libcap
version=2.12
release=1
source=(ftp://ftp.kernel.org/pub/linux/libs/security/linux-privs/kernel-2.6/libcap-$version.tar.gz
$name-$version-makefile.patch)
build () {
cd libcap-$version
patch -p1 -i $SRC/$name-$version-makefile.patch
make
make \
INCDIR=$PKG/usr/include \
LIBDIR=$PKG/usr/lib \
SBINDIR=$PKG/usr/sbin \
MANDIR=$PKG/usr/man install
# man8 is empty, cap{set,get}(2) come from core/man-pages
rm -rf $PKG/usr/man/man{2,8}
}

View File

@ -0,0 +1,18 @@
diff -ruN libcap-2.11.orig/libcap/Makefile libcap-2.11/libcap/Makefile
--- libcap-2.11.orig/libcap/Makefile 2008-07-30 22:06:54.000000000 +0300
+++ libcap-2.11/libcap/Makefile 2008-07-30 22:07:52.000000000 +0300
@@ -21,13 +21,8 @@
all: $(MINLIBNAME) $(STALIBNAME)
-ifeq ($(shell gperf --version > /dev/null 2>&1 && echo yes),yes)
-USE_GPERF_OUTPUT = $(GPERF_OUTPUT)
-INCLUDE_GPERF_OUTPUT = -include $(GPERF_OUTPUT)
-endif
-
_makenames: _makenames.c cap_names.sed
- $(BUILD_CC) $(BUILD_CFLAGS) $< -o $@
+ $(BUILD_CC) $(BUILD_CFLAGS) $< -o $@ -I./include
cap_names.h: _makenames
./_makenames > cap_names.h