dtc: fix build if swig is installed

This commit is contained in:
Juergen Daubert 2023-08-31 09:04:41 +02:00
parent ecede9334f
commit 538ea58b15
3 changed files with 25 additions and 4 deletions

View File

@ -1,5 +1,6 @@
untrusted comment: verify with /etc/ports/opt.pub
RWSE3ohX2g5d/Uz1ZPelufLUm160jtOkiVA2KIfb1Yq6ZCm9G1cmF4p8wxgG39bYsq15jZ8lAq8QANAEItPBKhaNBSLg5qqAzQE=
SHA256 (Pkgfile) = e12186d72e675899a01aa658b4c94db8aa426221f3851850619fa7f5f7ba42d9
RWSE3ohX2g5d/eIIa9GkuWvuvdIyiO0XTUcFWb3/qibaSp79tPE5zv51xA4HKqvF18ZteivNhfxfMBDzA56s4UG3xocimZwwFgI=
SHA256 (Pkgfile) = 51e1f36cc124e0f80d45a266d1136e12ebfb333204b6cdf1e63a8d786a78046f
SHA256 (.footprint) = d11e3a31345e5fb0aad1b36197a5b9aec939421d67c4957b506198126a56f15a
SHA256 (dtc-1.7.0.tar.xz) = 29edce3d302a15563d8663198bbc398c5a0554765c83830d0d4c0409d21a16c4
SHA256 (pyscm.patch) = 332f69313911cd174758ee5462b67d96ae3cfe7810eb7b94cb340524ce7d1665

View File

@ -4,12 +4,14 @@
name=dtc
version=1.7.0
release=1
source=(https://www.kernel.org/pub/software/utils/$name/$name-$version.tar.xz)
release=2
source=(https://www.kernel.org/pub/software/utils/$name/$name-$version.tar.xz
pyscm.patch)
build() {
sed '/version:/s/6/7/' -i $name-$version/{,libfdt}/meson.build
CFLAGS+=" -ffat-lto-objects"
patch -p1 -d $name-$version -i $SRC/pyscm.patch
meson setup build $name-$version \
--prefix=/usr \

18
dtc/pyscm.patch Normal file
View File

@ -0,0 +1,18 @@
diff --git a/setup.py b/setup.py
index e82a832..da01efd 100755
--- a/setup.py
+++ b/setup.py
@@ -49,11 +49,8 @@ class build_py(_build_py):
setup(
name='libfdt',
- use_scm_version={
- "root": srcdir,
- },
cmdclass = {'build_py' : build_py},
- setup_requires = ['setuptools_scm'],
+ version="1.7.0",
author='Simon Glass',
author_email='sjg@chromium.org',
description='Python binding for libfdt',