Merge branch '3.0' into 3.1

Conflicts:
	mod_php/.md5sum
	mod_php/Pkgfile
This commit is contained in:
Juergen Daubert 2014-03-01 19:09:52 +01:00
commit 550784062c
9 changed files with 23 additions and 87 deletions

View File

@ -1 +1 @@
3418f5a829315f40f3d0a7bdaeb765b6 s-nail-14_6_1.tar.xz
36823dd48933f21d3e92e2fa7d4f171e s-nail-14_6_2.tar.xz

View File

@ -4,7 +4,7 @@
# Depends on: openssl readline
name=mailx
version=14.6.1
version=14.6.2
release=1
source=(http://downloads.sourceforge.net/project/s-nail/s-nail-${version//./_}.tar.xz)

View File

@ -1,3 +1,3 @@
975f587ff761a60ac25dbe6c00865925 quota-4.00.tar.gz
5c2c31e321d2e1322ce12d69ae5c66d6 quota-4.01.tar.gz
b26ac767894bb8847215906da137ea68 quotagrpadmins
70fecd0bd0f9390dec10ce4d0ce7c3d7 warnquota.conf

View File

@ -5,7 +5,7 @@
# Depends on: e2fsprogs tcp_wrappers
name=quota
version=4.00
version=4.01
release=1
source=(http://download.sourceforge.net/linuxquota/$name-$version.tar.gz \
warnquota.conf quotagrpadmins)

View File

@ -1,3 +1,2 @@
23e32c1e292f2fc94ed88195ffe60023 spectrwm-2.4.0.tgz
1ebde41a8b57b6e116e6effd7a911dc9 spectrwm-fix_unbind.patch
be5fdf53ebac908ad037ad937de5ba3a spectrwm-remove_libswmhack.patch
22355256693393779b2d366d312c4577 spectrwm-2.5.0.tgz
12a904c0dd99879c18abb51e5e697bac spectrwm-remove_libswmhack.patch

View File

@ -4,15 +4,14 @@
# Depends on: xorg-libxrender fontconfig xorg-xcb-util-keysyms xorg-xcb-util-wm
name=spectrwm
version=2.4.0
release=2
version=2.5.0
release=1
source=(https://opensource.conformal.com/snapshots/$name/$name-$version.tgz
$name-fix_unbind.patch $name-remove_libswmhack.patch)
$name-remove_libswmhack.patch)
build () {
cd $name-$version/linux
patch -p 1 -d .. -i $SRC/$name-remove_libswmhack.patch
patch -p 1 -d .. -i $SRC/$name-fix_unbind.patch
make PREFIX=/usr MANDIR=/usr/man DESTDIR=$PKG install
rm $PKG/usr/man/man1/spectrwm_*.1
ln -sf spectrwm $PKG/usr/bin/scrotwm

View File

@ -1,64 +0,0 @@
commit 844157986de0e1fb9a50c7674eaae527eec23349
Author: Reginald Kennedy <rk@rejii.com>
Date: Sat Nov 16 23:21:15 2013 +0800
Fix 'bind[] = ...' not unbinding as expected.
Fixes #23
diff --git a/spectrwm.c b/spectrwm.c
index 34a49be..251b746 100644
--- a/spectrwm.c
+++ b/spectrwm.c
@@ -6398,6 +6398,9 @@ setconfspawn(const char *selector, const char *value, int flags)
{
char *args;
+ if (selector == NULL || strlen(selector) == 0)
+ return (1);
+
args = expand_tilde(value);
DNPRINTF(SWM_D_SPAWN, "setconfspawn: [%s] [%s]\n", selector, args);
@@ -6646,8 +6649,9 @@ setconfbinding(const char *selector, const char *value, int flags)
/* suppress unused warning since var is needed */
(void)flags;
- DNPRINTF(SWM_D_KEY, "setconfbinding: enter\n");
- if (selector == NULL) {
+ DNPRINTF(SWM_D_KEY, "setconfbinding: enter selector: [%s], "
+ "value: [%s]\n", selector, value);
+ if (selector == NULL || strlen(selector) == 0) {
DNPRINTF(SWM_D_KEY, "setconfbinding: unbind %s\n", value);
if (parsekeys(value, mod_key, &mod, &ks) == 0) {
kfid = KF_INVALID;
@@ -7164,7 +7168,7 @@ setconfquirk(const char *selector, const char *value, int flags)
/* suppress unused warning since var is needed */
(void)flags;
- if (selector == NULL)
+ if (selector == NULL || strlen(selector) == 0)
return (0);
if ((str = strdup(selector)) == NULL)
@@ -7277,9 +7281,6 @@ setconfvalue(const char *selector, const char *value, int flags)
int i, ws_id, num_screens;
char *b, *str;
- /* suppress unused warning since var is needed */
- (void)selector;
-
switch (flags) {
case SWM_S_BAR_ACTION:
free(bar_argv[0]);
@@ -7519,7 +7520,9 @@ setconfmodkey(const char *selector, const char *value, int flags)
int
setconfcolor(const char *selector, const char *value, int flags)
{
- setscreencolor(value, ((selector == NULL)?-1:atoi(selector)), flags);
+ setscreencolor(value,
+ (selector == NULL || strlen(selector) == 0) ? -1 : atoi(selector),
+ flags);
return (0);
}

View File

@ -1,13 +1,15 @@
diff -Nru spectrwm-2.4.0.orig/linux/Makefile spectrwm-2.4.0/linux/Makefile
--- spectrwm-2.4.0.orig/linux/Makefile 2013-11-27 12:41:41.935783480 +0100
+++ spectrwm-2.4.0/linux/Makefile 2013-11-27 12:44:47.562396671 +0100
@@ -1,5 +1,5 @@
diff -Nru spectrwm-2.5.0.orig/linux/Makefile spectrwm-2.5.0/linux/Makefile
--- spectrwm-2.5.0.orig/linux/Makefile 2014-02-27 10:30:41.708091165 +0100
+++ spectrwm-2.5.0/linux/Makefile 2014-02-27 10:32:12.751479280 +0100
@@ -6,7 +6,7 @@
LVERS= $(shell . ../lib/shlib_version; echo $$major.$$minor)
CFLAGS+= -std=c99 -Wmissing-prototypes -Wall -Wextra -Wshadow -Wno-uninitialized -g
-CFLAGS+= -D_GNU_SOURCE -I. -I/usr/include/freetype2 -DSWM_LIB=\"libswmhack.so.$(LVERS)\"
-CFLAGS+= -D_GNU_SOURCE -I. -I/usr/include/freetype2 -DSWM_LIB=\"$(LIBDIR)/libswmhack.so.$(LVERS)\"
+CFLAGS+= -D_GNU_SOURCE -I. -I/usr/include/freetype2
LDADD+= -lX11 -lX11-xcb -lxcb -lxcb-icccm -lxcb-randr -lxcb-keysyms -lxcb-util -lxcb-xtest -lXft -lXcursor
PREFIX?= /usr/local
CC?= cc
@@ -16,7 +16,7 @@
CFLAGS+= -DSPECTRWM_BUILDSTR=\"$(BUILDVERSION)\"
endif
@ -33,10 +35,10 @@ diff -Nru spectrwm-2.4.0.orig/linux/Makefile spectrwm-2.4.0/linux/Makefile
clean:
rm -f spectrwm *.o *.so libswmhack.so.* spectrwm.c swm_hack.c version.h
diff -Nru spectrwm-2.4.0.orig/spectrwm.c spectrwm-2.4.0/spectrwm.c
--- spectrwm-2.4.0.orig/spectrwm.c 2013-11-27 12:41:41.935783480 +0100
+++ spectrwm-2.4.0/spectrwm.c 2013-11-27 12:50:27.810081824 +0100
@@ -273,9 +273,9 @@
diff -Nru spectrwm-2.5.0.orig/spectrwm.c spectrwm-2.5.0/spectrwm.c
--- spectrwm-2.5.0.orig/spectrwm.c 2014-02-27 10:30:41.708091165 +0100
+++ spectrwm-2.5.0/spectrwm.c 2014-02-27 10:31:08.557124812 +0100
@@ -299,9 +299,9 @@
#define SWM_CONF_DEFAULT (0)
#define SWM_CONF_KEYMAPPING (1)
@ -48,7 +50,7 @@ diff -Nru spectrwm-2.4.0.orig/spectrwm.c spectrwm-2.4.0/spectrwm.c
char **start_argv;
xcb_atom_t a_state;
@@ -3117,7 +3117,7 @@
@@ -3317,7 +3317,7 @@
close(xcb_get_file_descriptor(conn));

View File

@ -6,7 +6,7 @@
name=stunnel
version=4.56
release=1
source=(ftp://ftp.stunnel.org/stunnel/archive/4.x/$name-$version.tar.gz \
source=(https://www.stunnel.org/downloads/$name-$version.tar.gz \
$name-config.patch $name)
build () {