qemu-all: update to 8.1.2

This commit is contained in:
Juergen Daubert 2023-10-17 18:27:40 +02:00
parent 53c07315ff
commit 61e4a5c302
3 changed files with 5 additions and 101 deletions

View File

@ -1,6 +1,5 @@
untrusted comment: verify with /etc/ports/opt.pub
RWSE3ohX2g5d/eKzdL4rl+4ONkoN+dGFOUFD2ssp5qtN7sxXLB98/H52boxMp7xi8W3llYX2R/38PbGDIDhN0TfJN2ulECt1Jg8=
SHA256 (Pkgfile) = f04a424a8ef9e44ae1b1602270e6dc08af92ed377c389fb4aadb15df5ce62c7d
RWSE3ohX2g5d/Tt++Lw4H7AIosKoS31LR8bVxnrWvK/WL9UG5XzG/bbk8Y6Xxjq2o+FxPVsmzCGZYgFKUtdf0K8cA2H4wCKnnws=
SHA256 (Pkgfile) = 55735e1eadf996e2d8a01b46ac2705632a503de19e6e905f1371fcf41ca8dd17
SHA256 (.footprint) = 8ee3bd36bba7b21ab3110157b5e2eeffbd39dfa66d2b9f2991cdaf69904efeb7
SHA256 (qemu-8.1.1.tar.xz) = 37ce2ef5e500fb752f681117c68b45118303ea49a7e26bd54080ced54fab7def
SHA256 (keyutils.patch) = 1ed4ffac0568e3ca62ed09429eaa2f896bc42bfbce7eafce502264101e59feb1
SHA256 (qemu-8.1.2.tar.xz) = 541526a764576eb494d2ff5ec46aeb253e62ea29035d1c23c0a8af4e6cd4f087

View File

@ -4,18 +4,13 @@
# Depends on: dtc glib libusb linux-pam xorg-libpixman
# Optional: alsa-lib fuse3 gnutls libaio libjpeg-turbo libpng libsdl2 libseccomp libslirp libssh liburing libxkbcommon nettle nfs-utils numactl pipewire pulseaudio python3-sphinx python3-sphinx_rtd_theme sdl2_image snappy xkeyboard-config xkeyboard-config
name=qemu-all
version=8.1.1
version=8.1.2
release=1
source=(https://download.qemu.org/qemu-$version.tar.xz
keyutils.patch)
source=(https://download.qemu.org/qemu-$version.tar.xz)
build() {
cd qemu-$version
## https://lore.kernel.org/qemu-devel/20230824094208.255279-1-thuth@redhat.com/
patch -Np1 -i $SRC/keyutils.patch
## only needed for qemu-keymap
if [[ ! -e /usr/include/xkbcommon/xkbcommon-x11.h ]] && ! prt-get isinst xkeyboard-config; then

View File

@ -1,90 +0,0 @@
From: Thomas Huth <thuth@redhat.com>
To: qemu-devel@nongnu.org, "Daniel P. Berrangé" <berrange@redhat.com>
Cc: qemu-stable@nongnu.org, "Paolo Bonzini" <pbonzini@redhat.com>,
"Marc-André Lureau" <marcandre.lureau@redhat.com>,
"Philippe Mathieu-Daudé" <philmd@linaro.org>,
antischmock@googlemail.com
Subject: [PATCH] meson.build: Make keyutils independent from keyring
Date: Thu, 24 Aug 2023 11:42:08 +0200 [thread overview]
Message-ID: <20230824094208.255279-1-thuth@redhat.com> (raw)
Commit 0db0fbb5cf ("Add conditional dependency for libkeyutils")
tried to provide a possibility for the user to disable keyutils
if not required by makeing it depend on the keyring feature. This
looked reasonable at a first glance (the unit test in tests/unit/
needs both), but the condition in meson.build fails if the feature
is meant to be detected automatically, and there is also another
spot in backends/meson.build where keyutils is used independently
from keyring. So let's remove the dependency on keyring again and
introduce a proper meson build option instead.
Cc: qemu-stable@nongnu.org
Fixes: 0db0fbb5cf ("Add conditional dependency for libkeyutils")
Resolves: https://gitlab.com/qemu-project/qemu/-/issues/1842
Signed-off-by: Thomas Huth <thuth@redhat.com>
---
meson.build | 6 ++++--
meson_options.txt | 2 ++
scripts/meson-buildoptions.sh | 3 +++
3 files changed, 9 insertions(+), 2 deletions(-)
diff --git a/meson.build b/meson.build
index 98e68ef0b1..5756148576 100644
--- a/meson.build
+++ b/meson.build
@@ -1771,8 +1771,9 @@ if gnutls.found()
method: 'pkg-config')
endif
keyutils = not_found
-if get_option('keyring').enabled()
- keyutils = dependency('libkeyutils', required: false, method: 'pkg-config')
+if not get_option('libkeyutils').auto() or have_block
+ keyutils = dependency('libkeyutils', required: get_option('libkeyutils'),
+ method: 'pkg-config')
endif
has_gettid = cc.has_function('gettid')
@@ -4211,6 +4212,7 @@ endif
summary_info += {'AF_ALG support': have_afalg}
summary_info += {'rng-none': get_option('rng_none')}
summary_info += {'Linux keyring': have_keyring}
+summary_info += {'Linux keyutils': keyutils}
summary(summary_info, bool_yn: true, section: 'Crypto')
# UI
diff --git a/meson_options.txt b/meson_options.txt
index aaea5ddd77..ae6d8f469d 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -119,6 +119,8 @@ option('avx512bw', type: 'feature', value: 'auto',
description: 'AVX512BW optimizations')
option('keyring', type: 'feature', value: 'auto',
description: 'Linux keyring support')
+option('libkeyutils', type: 'feature', value: 'auto',
+ description: 'Linux keyutils support')
option('attr', type : 'feature', value : 'auto',
description: 'attr/xattr support')
diff --git a/scripts/meson-buildoptions.sh b/scripts/meson-buildoptions.sh
index 9da3fe299b..d7020af175 100644
--- a/scripts/meson-buildoptions.sh
+++ b/scripts/meson-buildoptions.sh
@@ -120,6 +120,7 @@ meson_options_help() {
printf "%s\n" ' libdaxctl libdaxctl support'
printf "%s\n" ' libdw debuginfo support'
printf "%s\n" ' libiscsi libiscsi userspace initiator'
+ printf "%s\n" ' libkeyutils Linux keyutils support'
printf "%s\n" ' libnfs libnfs block device driver'
printf "%s\n" ' libpmem libpmem support'
printf "%s\n" ' libssh ssh block device support'
@@ -341,6 +342,8 @@ _meson_option_parse() {
--libexecdir=*) quote_sh "-Dlibexecdir=$2" ;;
--enable-libiscsi) printf "%s" -Dlibiscsi=enabled ;;
--disable-libiscsi) printf "%s" -Dlibiscsi=disabled ;;
+ --enable-libkeyutils) printf "%s" -Dlibkeyutils=enabled ;;
+ --disable-libkeyutils) printf "%s" -Dlibkeyutils=disabled ;;
--enable-libnfs) printf "%s" -Dlibnfs=enabled ;;
--disable-libnfs) printf "%s" -Dlibnfs=disabled ;;
--enable-libpmem) printf "%s" -Dlibpmem=enabled ;;
--
2.39.3