lesstif: 0.95.0 -> 0.95.2

This commit is contained in:
Thomas Penteker 2010-02-28 02:57:18 +01:00
parent 2ea9c6886a
commit 65ddc8f6ea
6 changed files with 20 additions and 93 deletions

View File

@ -1,6 +1,7 @@
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/motif-config
-rwxr-xr-x root/root usr/bin/mwm
-rwxr-xr-x root/root usr/bin/mxmkmf
-rwxr-xr-x root/root usr/bin/uil
-rwxr-xr-x root/root usr/bin/xmbind

View File

@ -1,4 +1 @@
2aa80ecd7ffb27de50e0562dbe4302aa lesstif-0.95.0-disable_mwm.patch
4f0720e1597631fc31c2b14d7346e74a lesstif-0.95.0-libxpm.patch
42adb1b2da3652c3fec182c9188ebfb2 lesstif-0.95.0-vendorsp.patch
ab895165c149d7f95843c7584b1c7ad4 lesstif-0.95.0.tar.bz2
754187dbac09fcf5d18296437e72a32f lesstif-0.95.2.tar.bz2

View File

@ -4,31 +4,26 @@
# Depends on: freetype, xorg-libxt
name=lesstif
version=0.95.0
release=3
source=(http://dl.sf.net/$name/lesstif-$version.tar.bz2
$name-$version-libxpm.patch
$name-$version-vendorsp.patch
$name-$version-disable_mwm.patch)
version=0.95.2
release=1
source=(http://dl.sf.net/$name/lesstif-$version.tar.bz2)
build() {
cd $name-$version
patch -p0 -i $SRC/$name-$version-libxpm.patch
patch -p0 -i $SRC/$name-$version-vendorsp.patch
patch -p0 -i $SRC/$name-$version-disable_mwm.patch
./configure \
--prefix=/usr \
--enable-nonstandard-conversions \
--disable-debug \
--with-editres \
--with-xdnd
make
make DESTDIR=$PKG install
cd $name-$version
./configure \
--prefix=/usr \
--enable-nonstandard-conversions \
--disable-debug \
--with-editres \
--with-xdnd \
--mandir=/usr/man
make
make DESTDIR=$PKG install
# remove xprint stuff
rm $PKG/usr/include/Xm/Print{SP,}.h
sed -i -e 's/.*Print.h.*//' $PKG/usr/include/Xm/XmAll.h
# remove xprint stuff
rm $PKG/usr/include/Xm/Print{SP,}.h
sed -i -e 's/.*Print.h.*//' $PKG/usr/include/Xm/XmAll.h
rm -rf $PKG/usr/LessTif $PKG/usr/lib/X11/ \
$PKG/usr/man/man{1/mwm.1,5/mwmrc.5}
rm -rf $PKG/usr/LessTif $PKG/usr/lib/X11/ \
$PKG/usr/man/man{1/mwm.1,5/mwmrc.5}
}

View File

@ -1,11 +0,0 @@
--- clients/Motif-2.1/Makefile.in~ 2008-06-17 18:17:50.845050248 +0300
+++ clients/Motif-2.1/Makefile.in 2008-06-17 18:17:55.406361652 +0300
@@ -243,7 +243,7 @@
xmREVISION = @xmREVISION@
xmVERSION = @xmVERSION@
xmVer = @xmVer@
-SUBDIRS = mwm xmbind uil
+SUBDIRS = xmbind uil
MAINTAINERCLEANFILES = Makefile.in
all: all-recursive

View File

@ -1,38 +0,0 @@
--- lib/Xm-2.1/Xpmscan.c.orig 2005-03-02 17:00:16.415070960 +0100
+++ lib/Xm-2.1/Xpmscan.c 2005-03-02 17:01:38.949709879 +0100
@@ -672,8 +672,8 @@
char *dst;
unsigned int *iptr;
char *data;
- unsigned int x, y, i;
- int bits, depth, ibu, ibpp, offset;
+ unsigned int x, y;
+ int bits, depth, ibu, ibpp, offset, i;
unsigned long lbt;
Pixel pixel, px;
@@ -684,6 +684,9 @@
ibpp = image->bits_per_pixel;
offset = image->xoffset;
+ if (image->bitmap_unit < 0)
+ return (XpmNoMemory);
+
if ((image->bits_per_pixel | image->depth) == 1) {
ibu = image->bitmap_unit;
for (y = 0; y < height; y++)
--- lib/Xm-2.1/Xpmcreate.c.orig 2005-03-02 17:02:00.626412844 +0100
+++ lib/Xm-2.1/Xpmcreate.c 2005-03-02 17:02:35.183562480 +0100
@@ -1265,10 +1265,10 @@
register char *src;
register char *dst;
register unsigned int *iptr;
- register unsigned int x, y, i;
+ register unsigned int x, y;
register char *data;
Pixel pixel, px;
- int nbytes, depth, ibu, ibpp;
+ int nbytes, depth, ibu, ibpp, i;
data = image->data;
iptr = pixelindex;

View File

@ -1,17 +0,0 @@
--- include/Motif-2.1/Xm/VendorSP.h~ 2007-05-20 01:41:58.258974348 +0300
+++ include/Motif-2.1/Xm/VendorSP.h 2007-05-20 01:42:22.353298608 +0300
@@ -28,12 +28,13 @@
#include <Xm/XmP.h>
#include <Xm/VendorS.h>
-#include <X11/ShellP.h>
#ifdef __cplusplus
extern "C" {
#endif
+#include <X11/ShellP.h>
+
XMLIBEXPORT extern Cardinal _XmFilterResources(XtResource *resources,
Cardinal numResources,
WidgetClass filterClass,