This commit is contained in:
Fredrik Rinnestam 2011-09-06 20:47:04 +02:00
parent d9c3ea0648
commit 66bb601518
3 changed files with 55 additions and 5 deletions

View File

@ -1,2 +1,3 @@
43b71655e1307c7f62896339e70c9aed firefox-6.0.1.source.tar.bz2
8a99d37c764840d41ef6b8fe9d4a9e6f coreconf-linux3.patch
140ca0cfd57905139f8f71a527afb283 firefox-6.0.2.source.tar.bz2
37a5f703fda0c702fead28716a9ca01f mozconfig

View File

@ -4,10 +4,10 @@
# Depends on: libidl, gtk, python, alsa-lib, yasm, mesa3d
name=firefox
version=6.0.1
version=6.0.2
release=1
source=(http://releases.mozilla.org/pub/mozilla.org/$name/releases/$version/source/$name-$version.source.tar.bz2
mozconfig)
mozconfig coreconf-linux3.patch)
build() {
export MOZ_CO_PROJECT=browser
@ -16,9 +16,8 @@ build() {
export MOZILLA_FIVE_HOME=/usr/lib/firefox
cd mozilla-release
patch -p1 -i $SRC/coreconf-linux3.patch
sed -e "s/#CFLAGS#/$CFLAGS/" $SRC/mozconfig > .mozconfig
# fix broken part
cp security/coreconf/Linux2.6.mk security/coreconf/Linux3.0.mk
./configure
make

View File

@ -0,0 +1,50 @@
Index: mozilla/security/coreconf/Linux.mk
===================================================================
RCS file: /cvsroot/mozilla/security/coreconf/Linux.mk,v
--- mozilla/security/coreconf/Linux.mk 13 Aug 2010 01:31:13 -0000 1.48
+++ mozilla/security/coreconf/Linux.mk 3 Jul 2011 06:00:38 -0000
@@ -187,8 +187,20 @@
ifeq ($(BUILD_SUN_PKG), 1)
ifeq ($(USE_64), 1)
RPATH = -Wl,-rpath,'$$ORIGIN:/opt/sun/private/lib64:/opt/sun/private/lib'
else
RPATH = -Wl,-rpath,'$$ORIGIN:/opt/sun/private/lib'
endif
endif
+OS_REL_CFLAGS += -DLINUX2_1
+MKSHLIB = $(CC) $(DSO_LDOPTS) -Wl,-soname -Wl,$(@:$(OBJDIR)/%.so=%.so) $(RPATH)
+
+ifdef MAPFILE
+ MKSHLIB += -Wl,--version-script,$(MAPFILE)
+endif
+PROCESS_MAP_FILE = grep -v ';-' $< | \
+ sed -e 's,;+,,' -e 's; DATA ;;' -e 's,;;,,' -e 's,;.*,;,' > $@
+
+ifeq ($(OS_RELEASE),2.4)
+DEFINES += -DNO_FORK_CHECK
+endif
Index: mozilla/security/coreconf/config.mk
===================================================================
RCS file: /cvsroot/mozilla/security/coreconf/config.mk,v
--- mozilla/security/coreconf/config.mk 25 Aug 2009 22:35:11 -0000 1.30
+++ mozilla/security/coreconf/config.mk 3 Jul 2011 06:00:39 -0000
@@ -58,17 +58,17 @@
# (dependent upon <architecture> tags) #
# #
# We are moving towards just having a $(OS_TARGET).mk file #
# as opposed to multiple $(OS_TARGET)$(OS_RELEASE).mk files, #
# one for each OS release. #
#######################################################################
TARGET_OSES = FreeBSD BSD_OS NetBSD OpenUNIX OS2 QNX Darwin BeOS OpenBSD \
- AIX RISCOS WINNT WIN95 WINCE
+ AIX RISCOS WINNT WIN95 WINCE Linux
ifeq (,$(filter-out $(TARGET_OSES),$(OS_TARGET)))
include $(CORE_DEPTH)/coreconf/$(OS_TARGET).mk
else
include $(CORE_DEPTH)/coreconf/$(OS_TARGET)$(OS_RELEASE).mk
endif
#######################################################################