uptimed: moved to attic

This commit is contained in:
Tilman Sauerbeck 2006-10-18 17:43:47 +00:00
parent 165aa26319
commit 69d40481c4
6 changed files with 0 additions and 122 deletions

View File

@ -1,23 +0,0 @@
drwxr-xr-x root/root etc/
drwxr-xr-x root/root etc/rc.d/
-rwxr-xr-x root/root etc/rc.d/uptimed
-rw-r--r-- root/root etc/uptimed.conf
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/uprecords
drwxr-xr-x root/root usr/lib/
-rw-r--r-- root/root usr/lib/libuptimed.a
-rwxr-xr-x root/root usr/lib/libuptimed.la
lrwxrwxrwx root/root usr/lib/libuptimed.so -> libuptimed.so.0.0.0
lrwxrwxrwx root/root usr/lib/libuptimed.so.0 -> libuptimed.so.0.0.0
-rwxr-xr-x root/root usr/lib/libuptimed.so.0.0.0
drwxr-xr-x root/root usr/man/
drwxr-xr-x root/root usr/man/man1/
-rw-r--r-- root/root usr/man/man1/uprecords.1.gz
drwxr-xr-x root/root usr/man/man8/
-rw-r--r-- root/root usr/man/man8/uptimed.8.gz
drwxr-xr-x root/root usr/sbin/
-rwxr-xr-x root/root usr/sbin/uptimed
drwxr-xr-x root/root var/
drwxr-xr-x root/root var/spool/
drwxr-xr-x root/root var/spool/uptimed/

View File

@ -1,3 +0,0 @@
fba8e3746e614730bbfce882eb25d60b uptimed-0.3.7.tar.bz2
6d01a848abe25a0b664592edc34c2b52 uptimed.patch
a26b348758346733a443f78f4ad735aa uptimed.rc

View File

@ -1,24 +0,0 @@
# Description: System uptime record daemon
# URL: http://podgorny.cz/uptimed/
# Maintainer:
# Packager: Jukka Heino, jukka dot heino at gmail dot com
# Depends on:
name=uptimed
version=0.3.7
release=1
source=(http://podgorny.cz/$name/releases/$name-$version.tar.bz2 \
$name.patch \
$name.rc)
build() {
cd $name-$version
patch -p1 < $SRC/$name.patch
./configure --prefix=/usr --sysconfdir=/etc
make
make DESTDIR=$PKG install
mv $PKG/etc/$name.conf-dist $PKG/etc/$name.conf
install -D -m 0755 $SRC/$name.rc $PKG/etc/rc.d/$name
}

View File

@ -1,12 +0,0 @@
REQUIREMENTS
PRE-INSTALL
POST-INSTALL
Add the following lines to the bottom of /etc/rc:
# Create uptimed bootid
/usr/sbin/uptimed -b
PRECAUTION

View File

@ -1,37 +0,0 @@
diff -Nru uptimed-0.3.7.orig/Makefile.am uptimed-0.3.7/Makefile.am
--- uptimed-0.3.7.orig/Makefile.am 2004-06-18 18:26:39.000000000 +0300
+++ uptimed-0.3.7/Makefile.am 2006-02-17 18:11:34.000000000 +0200
@@ -7,4 +7,4 @@
sample-cgi/uprecords.footer uptimed.spec depcomp
install-data-local:
- $(INSTALL) -d /var/spool/uptimed
+ $(INSTALL) -d $(DESTDIR)/var/spool/uptimed
diff -Nru uptimed-0.3.7.orig/Makefile.in uptimed-0.3.7/Makefile.in
--- uptimed-0.3.7.orig/Makefile.in 2004-06-20 13:45:54.000000000 +0300
+++ uptimed-0.3.7/Makefile.in 2006-02-17 18:11:18.000000000 +0200
@@ -428,7 +428,7 @@
install-data-local:
- $(INSTALL) -d /var/spool/uptimed
+ $(INSTALL) -d $(DESTDIR)/var/spool/uptimed
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT:
diff -Nru uptimed-0.3.7.orig/etc/uptimed.conf-dist uptimed-0.3.7/etc/uptimed.conf-dist
--- uptimed-0.3.7.orig/etc/uptimed.conf-dist 2004-06-18 18:26:38.000000000 +0300
+++ uptimed-0.3.7/etc/uptimed.conf-dist 2006-02-17 18:11:18.000000000 +0200
@@ -25,10 +25,10 @@
SEND_EMAIL=0
# We need a sendmail compatible mailer, though.
-SENDMAIL=/usr/lib/sendmail -t
+SENDMAIL=/usr/sbin/sendmail -t
# Where to note our PID
-PIDFILE=/var/run/uptimed
+PIDFILE=/var/run/uptimed.pid
# Milestones are configurable now.
# Syntax is pretty easy: MILESTONE=time:description

View File

@ -1,23 +0,0 @@
#!/bin/sh
#
# /etc/rc.d/uptimed: start/stop uptimed daemon
#
case $1 in
start)
/usr/sbin/uptimed
;;
stop)
kill $( < /var/run/uptimed.pid )
;;
restart)
$0 stop
sleep 2
$0 start
;;
*)
echo "usage: $0 [start|stop|restart]"
;;
esac
# End of file