slim: added patch for building with gcc 11+, cleanups

This commit is contained in:
Matt Housh 2023-02-01 15:29:00 -06:00
parent 259d150c88
commit 6d0bd9a31c
4 changed files with 34 additions and 33 deletions

View File

@ -1,8 +1,8 @@
untrusted comment: verify with /etc/ports/opt.pub
RWSE3ohX2g5d/Vxqsw+A1c+URyGLZ/u9BtJ4I4z8B8tfFMpF8NHrasgmwzjb5qPF4TtLFcOJzWoBoHKlUQeTs5J7HzOEpLkYmwM=
SHA256 (Pkgfile) = 3aff9b2ec6ef62ee48532827040a8aff7da53a70694004eb87ff3ec268f1e7ea
RWSE3ohX2g5d/QdS95cGmC/eB3kqAALQTf8z/QXMIxBFTvvZFupeuWorizczX7gU96n7PBIiiiXq444wqnaxNNfjH0Ks6J1Zrgk=
SHA256 (Pkgfile) = 4746205cfe8a07e57fccffcb762dee22e03456a823554be8d225065d11b3a0da
SHA256 (.footprint) = 58d4f98570e611e4d175f24b0afa122c075444f01ec5c2ffb9dc9d5fda571976
SHA256 (slim-1.3.6.tar.gz) = 21defeed175418c46d71af71fd493cd0cbffd693f9d43c2151529125859810df
SHA256 (slim-crux-smooth.tar.gz) = 19d9106386b2965f151cf5813952f0da836138543dc713348a92c641ccf651fb
SHA256 (libpng.patch) = 9f018c2ff2c0c1788ef59c6e17c66f71ba5ecdf22099c5acc79ae293c7b097c4
SHA256 (slim.rc) = a59dd5e96b89b1b1f88fece37aa24bd00e643341057bf08d361d761043942ef0
SHA256 (signed-comparison.patch) = 8a9f9c4af9359c3622799ac60e92ec82574702a98d02c7556a663883c443592b

View File

@ -6,27 +6,31 @@
name=slim
version=1.3.6
release=1
source=(http://downloads.sourceforge.net/project/slim.berlios/slim-$version.tar.gz \
http://crux.nu/~tek/slim-crux-smooth.tar.gz libpng.patch $name.rc)
source=(http://downloads.sourceforge.net/project/slim.berlios/slim-$version.tar.gz
http://crux.nu/~tek/slim-crux-smooth.tar.gz $name.rc
signed-comparison.patch)
build () {
cd $name-$version
cd $name-$version
# do NOT build slimlock (because of pam)
sed -i -e '224d' CMakeLists.txt
# https://bugs.gentoo.org/786498
patch -p1 -i $SRC/signed-comparison.patch
cmake -DCMAKE_INSTALL_PREFIX=/usr
# do NOT build slimlock (because of pam)
sed -i -e '224d' CMakeLists.txt
make
make DESTDIR=$PKG install
mkdir $PKG/etc/rc.d
install -m 755 ../$name.rc $PKG/etc/rc.d/$name
cd ../
cmake -DCMAKE_INSTALL_PREFIX=/usr
rm -f slim-crux-smooth/README
cp -r slim-crux-smooth $PKG/usr/share/slim/themes/crux-smooth
chmod 0644 $PKG/usr/share/slim/themes/crux-smooth/*
make
make DESTDIR=$PKG install
mkdir $PKG/etc/rc.d
install -m 755 ../$name.rc $PKG/etc/rc.d/$name
cd ../
# no systemd support
rm -r $PKG/lib $PKG/usr/share/man/man1/slimlock.1
rm -f slim-crux-smooth/README
cp -r slim-crux-smooth $PKG/usr/share/slim/themes/crux-smooth
chmod 0644 $PKG/usr/share/slim/themes/crux-smooth/*
# no systemd support
rm -r $PKG/lib $PKG/usr/share/man/man1/slimlock.1
}

View File

@ -1,14 +0,0 @@
--- a/image.cpp 2012-06-26 04:20:14.000000000 -0400
+++ b/image.cpp 2012-06-27 11:41:34.000000000 -0400
@@ -781,7 +781,11 @@
(png_infopp) NULL);
}
+#if PNG_LIBPNG_VER_MAJOR >= 1 && PNG_LIBPNG_VER_MINOR >= 4
+ if (setjmp(png_jmpbuf((png_ptr)))) {
+#else
if (setjmp(png_ptr->jmpbuf)) {
+#endif
goto png_destroy;
}

View File

@ -0,0 +1,11 @@
--- 1/panel.cpp
+++ 1/panel.cpp
@@ -48,7 +48,7 @@
gcm = GCGraphicsExposures;
gcv.graphics_exposures = False;
WinGC = XCreateGC(Dpy, Win, gcm, &gcv);
- if (WinGC < 0) {
+ if (WinGC == 0) {
cerr << APPNAME
<< ": failed to create pixmap\n.";
exit(ERR_EXIT);