xulrunner: updated to 1.9.1.

This commit is contained in:
Predrag Ivanovic 2009-07-04 13:08:12 +02:00 committed by Tilman Sauerbeck
parent 82c77c5c46
commit 70b2f0d198
4 changed files with 3916 additions and 3739 deletions

File diff suppressed because it is too large Load Diff

View File

@ -1,3 +1,3 @@
b509f7c05e9566ed290e2c098316c7c3 firefox-3.0.11-source.tar.bz2 6dd59399db08963ef022a1d0e5010053 firefox-3.5-source.tar.bz2
3a043809a9e0dbf39efe95359fcc5fe7 mozconfig 3a043809a9e0dbf39efe95359fcc5fe7 mozconfig
7a5151f90cb360bc1ea911e5cf7208e9 xulrunner.diff 766231296c5e03d6ba68342628183805 xulrunner.diff

View File

@ -1,19 +1,19 @@
# Description: Mozilla Web Browser Component # Description: Mozilla Web Browser Component
# URL: http://www.mozilla.com/firefox/ # URL: http://www.mozilla.com/firefox/
# Maintainer: Tilman Sauerbeck, tilman at crux dot nu # Maintainer: Tilman Sauerbeck, tilman at crux dot nu
# Depends on: libidl, nss, gtk, perl, python, dbus-glib # Depends on: libidl, nss, gtk, perl, python, dbus-glib, alsa-lib
name=xulrunner name=xulrunner
version=1.9.0.11 version=1.9.1
release=1 release=1
source=(http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.0.11/source/firefox-3.0.11-source.tar.bz2 source=(http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.5/source/firefox-3.5-source.tar.bz2
mozconfig $name.diff) mozconfig $name.diff)
build() { build() {
export MOZ_CO_PROJECT="xulrunner" export MOZ_CO_PROJECT="xulrunner"
export XCFLAGS="$CFLAGS" export XCFLAGS="$CFLAGS"
cd mozilla cd mozilla-$version
patch -Np1 -i $SRC/$name.diff patch -Np1 -i $SRC/$name.diff

View File

@ -1,15 +1,15 @@
--- ---
xulrunner/installer/Makefile.in | 17 ++++++++++++++--- xulrunner/installer/Makefile.in | 15 ++++++++++++---
xulrunner/installer/libxul-embedding-unstable.pc.in | 2 +- xulrunner/installer/libxul-embedding-unstable.pc.in | 2 +-
xulrunner/installer/libxul-embedding.pc.in | 2 +- xulrunner/installer/libxul-embedding.pc.in | 2 +-
xulrunner/installer/mozilla-nss.pc.in | 6 +++--- xulrunner/installer/mozilla-nss.pc.in | 6 +++---
4 files changed, 19 insertions(+), 8 deletions(-) 4 files changed, 17 insertions(+), 8 deletions(-)
Index: mozilla/xulrunner/installer/Makefile.in Index: mozilla/xulrunner/installer/Makefile.in
=================================================================== ===================================================================
--- mozilla.orig/xulrunner/installer/Makefile.in --- mozilla.orig/xulrunner/installer/Makefile.in
+++ mozilla/xulrunner/installer/Makefile.in +++ mozilla/xulrunner/installer/Makefile.in
@@ -90,40 +90,51 @@ @@ -91,29 +91,38 @@
mozilla-plugin.pc \ mozilla-plugin.pc \
mozilla-gtkmozembed.pc \ mozilla-gtkmozembed.pc \
mozilla-gtkmozembed-embedding.pc \ mozilla-gtkmozembed-embedding.pc \
@ -34,7 +34,7 @@ Index: mozilla/xulrunner/installer/Makefile.in
-ifndef MOZ_NATIVE_NSS -ifndef MOZ_NATIVE_NSS
-pkg_config_files += mozilla-nss.pc -pkg_config_files += mozilla-nss.pc
+ifdef MOZ_NATIVE_NSS +ifdef MOZ_NATIVE_NSS
+NSS_VERSION=$(shell $(NSS_CONFIG) --version) +NSPR_VERSION=$(shell $(NSS_CONFIG) --version)
+FULL_NSS_CFLAGS=$(shell $(NSS_CONFIG) --cflags) +FULL_NSS_CFLAGS=$(shell $(NSS_CONFIG) --cflags)
+FULL_NSS_LIBS=$(shell $(NSS_CONFIG) --libs) +FULL_NSS_LIBS=$(shell $(NSS_CONFIG) --libs)
+else +else
@ -44,26 +44,13 @@ Index: mozilla/xulrunner/installer/Makefile.in
endif endif
+pkg_config_files += mozilla-nss.pc +pkg_config_files += mozilla-nss.pc
%.pc: $(srcdir)/%.pc.in Makefile.in Makefile $(DEPTH)/config/autoconf.mk ifdef MOZ_OJI
cat $< | sed \ OJIDEF=-DOJI
-e "s|%prefix%|$(prefix)|" \ else
-e "s|%includedir%|$(includedir)|" \ OJIDEF=
-e "s|%idldir%|$(idldir)|" \ endif
-e "s|%sdkdir%|$(sdkdir)|" \
-e "s|%MOZ_APP_NAME%|$(MOZ_APP_NAME)|" \
-e "s|%MOZILLA_VERSION%|$(MOZ_APP_VERSION)|" \
-e "s|%FULL_NSPR_LIBS%|$(FULL_NSPR_LIBS)|" \
-e "s|%FULL_NSPR_CFLAGS%|$(FULL_NSPR_CFLAGS)|" \
+ -e "s|%FULL_NSS_LIBS%|$(FULL_NSS_LIBS)|" \
+ -e "s|%FULL_NSS_CFLAGS%|$(FULL_NSS_CFLAGS)|" \
-e "s|%NSPR_NAME%|$(NSPR_NAME)|" \
-e "s|%NSPR_VERSION%|$(NSPR_VERSION)|" > $@
chmod 644 $@
install:: $(pkg_config_files)
@echo pkg_config_file: $(pkg_config_files)
$(SYSINSTALL) $(IFLAGS1) $^ $(DESTDIR)$(libdir)/pkgconfig
%.pc: $(srcdir)/%.pc.in $(GLOBAL_DEPS)
Index: mozilla/xulrunner/installer/libxul-embedding-unstable.pc.in Index: mozilla/xulrunner/installer/libxul-embedding-unstable.pc.in
=================================================================== ===================================================================
--- mozilla.orig/xulrunner/installer/libxul-embedding-unstable.pc.in --- mozilla.orig/xulrunner/installer/libxul-embedding-unstable.pc.in
@ -77,8 +64,8 @@ Index: mozilla/xulrunner/installer/libxul-embedding-unstable.pc.in
Description: Static library for version-independent embedding of the Mozilla runtime (unstable API) Description: Static library for version-independent embedding of the Mozilla runtime (unstable API)
Version: %MOZILLA_VERSION% Version: %MOZILLA_VERSION%
Libs: -L${sdkdir}/lib -lxpcomglue Libs: -L${sdkdir}/lib -lxpcomglue
-Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} -fshort-wchar -Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} %WCHAR_CFLAGS%
+Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} -fshort-wchar %FULL_NSPR_CFLAGS% +Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} %WCHAR_CFLAGS% %FULL_NSPR_CFLAGS%
Index: mozilla/xulrunner/installer/libxul-embedding.pc.in Index: mozilla/xulrunner/installer/libxul-embedding.pc.in
=================================================================== ===================================================================
--- mozilla.orig/xulrunner/installer/libxul-embedding.pc.in --- mozilla.orig/xulrunner/installer/libxul-embedding.pc.in
@ -92,8 +79,8 @@ Index: mozilla/xulrunner/installer/libxul-embedding.pc.in
Description: Static library for version-independent embedding of the Mozilla runtime Description: Static library for version-independent embedding of the Mozilla runtime
Version: %MOZILLA_VERSION% Version: %MOZILLA_VERSION%
Libs: -L${sdkdir}/lib -lxpcomglue Libs: -L${sdkdir}/lib -lxpcomglue
-Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} -fshort-wchar -Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} %WCHAR_CFLAGS%
+Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} -fshort-wchar %FULL_NSPR_CFLAGS% +Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} %WCHAR_CFLAGS% %FULL_NSPR_CFLAGS%
Index: mozilla/xulrunner/installer/mozilla-nss.pc.in Index: mozilla/xulrunner/installer/mozilla-nss.pc.in
=================================================================== ===================================================================
--- mozilla.orig/xulrunner/installer/mozilla-nss.pc.in --- mozilla.orig/xulrunner/installer/mozilla-nss.pc.in