shared-mime-info: deal with the intltool dependency.
This commit is contained in:
parent
4d62a0bba5
commit
716485b7d7
@ -1,2 +1 @@
|
||||
01d72161f7d88123fbccd378871f02f0 shared-mime-info-0.51.tar.bz2
|
||||
b86d8cec337de147e3921af38727f3fc shared-mime-info.diff
|
||||
|
@ -1,23 +1,20 @@
|
||||
# Description: core database of common types
|
||||
# URL: http://freedesktop.org/Software/shared-mime-info
|
||||
# Maintainer: Tilman Sauerbeck, tilman at crux dot nu
|
||||
# Depends on: glib,libxml2,p5-xml-parser
|
||||
# Depends on: glib,libxml2,intltool
|
||||
# Group: gnome
|
||||
|
||||
name=shared-mime-info
|
||||
version=0.51
|
||||
release=1
|
||||
source=(http://freedesktop.org/~hadess/$name-$version.tar.bz2
|
||||
$name.diff)
|
||||
source=(http://freedesktop.org/~hadess/$name-$version.tar.bz2)
|
||||
|
||||
build() {
|
||||
cd $name-$version
|
||||
|
||||
# kill nls support. don't depend on intltool.
|
||||
patch -Np1 -i $SRC/$name.diff
|
||||
autoreconf
|
||||
|
||||
./configure --prefix=/usr --mandir=/usr/man
|
||||
make
|
||||
make -j1 DESTDIR=$PKG install
|
||||
|
||||
rm -rf $PKG/usr/share/locale
|
||||
}
|
||||
|
@ -1,35 +0,0 @@
|
||||
diff -aur shared-mime-info-0.51.orig/Makefile.am shared-mime-info-0.51/Makefile.am
|
||||
--- shared-mime-info-0.51.orig/Makefile.am 2008-07-22 16:49:20.000000000 +0200
|
||||
+++ shared-mime-info-0.51/Makefile.am 2008-07-23 19:15:35.240373400 +0200
|
||||
@@ -1,4 +1,3 @@
|
||||
-SUBDIRS=po
|
||||
|
||||
INCLUDES = $(ALL_CFLAGS)
|
||||
|
||||
@@ -36,15 +35,12 @@
|
||||
po/shared-mime-info.pot
|
||||
|
||||
CLEANFILES = freedesktop.org.xml po/stamp-it
|
||||
-DISTCLEANFILES = intltool-extract intltool-merge intltool-update
|
||||
|
||||
pkgconfigdir = $(datadir)/pkgconfig
|
||||
pkgconfig_DATA = shared-mime-info.pc
|
||||
|
||||
$(pkgconfig_DATA): config.status
|
||||
|
||||
-@INTLTOOL_XML_RULE@
|
||||
-@INTLTOOL_DESKTOP_RULE@
|
||||
|
||||
install-data-hook:
|
||||
if ENABLE_UPDATE_MIMEDB
|
||||
diff -aur shared-mime-info-0.51.orig/configure.in shared-mime-info-0.51/configure.in
|
||||
--- shared-mime-info-0.51.orig/configure.in 2008-07-23 12:44:41.000000000 +0200
|
||||
+++ shared-mime-info-0.51/configure.in 2008-07-23 19:13:01.407374720 +0200
|
||||
@@ -11,7 +11,6 @@
|
||||
AC_C_CONST
|
||||
|
||||
|
||||
-IT_PROG_INTLTOOL([0.35.0])
|
||||
|
||||
GETTEXT_PACKAGE=shared-mime-info
|
||||
AC_SUBST(GETTEXT_PACKAGE)
|
Loading…
x
Reference in New Issue
Block a user