lua: 5.2.3 -> 5.3.1
This commit is contained in:
parent
15586b56b6
commit
71a1d31a78
@ -1,7 +1,9 @@
|
||||
drwxr-xr-x root/root usr/
|
||||
drwxr-xr-x root/root usr/bin/
|
||||
-rwxr-xr-x root/root usr/bin/lua
|
||||
lrwxrwxrwx root/root usr/bin/lua5.3 -> /usr/bin/lua
|
||||
-rwxr-xr-x root/root usr/bin/luac
|
||||
lrwxrwxrwx root/root usr/bin/luac5.3 -> /usr/bin/luac
|
||||
drwxr-xr-x root/root usr/include/
|
||||
-rw-r--r-- root/root usr/include/lauxlib.h
|
||||
-rw-r--r-- root/root usr/include/lua.h
|
||||
@ -10,11 +12,10 @@ drwxr-xr-x root/root usr/include/
|
||||
-rw-r--r-- root/root usr/include/lualib.h
|
||||
drwxr-xr-x root/root usr/lib/
|
||||
-rw-r--r-- root/root usr/lib/liblua.a
|
||||
lrwxrwxrwx root/root usr/lib/liblua.so -> liblua.so.5.2
|
||||
lrwxrwxrwx root/root usr/lib/liblua.so.5.2 -> liblua.so.5.2.3
|
||||
-rw-r--r-- root/root usr/lib/liblua.so.5.2.3
|
||||
-rw-r--r-- root/root usr/lib/liblua.so.5.3
|
||||
-rw-r--r-- root/root usr/lib/liblua.so.5.3.1
|
||||
drwxr-xr-x root/root usr/lib/lua/
|
||||
drwxr-xr-x root/root usr/lib/lua/5.2/
|
||||
drwxr-xr-x root/root usr/lib/lua/5.3/
|
||||
drwxr-xr-x root/root usr/lib/pkgconfig/
|
||||
-rw-r--r-- root/root usr/lib/pkgconfig/lua.pc
|
||||
drwxr-xr-x root/root usr/man/
|
||||
@ -23,4 +24,4 @@ drwxr-xr-x root/root usr/man/man1/
|
||||
-rw-r--r-- root/root usr/man/man1/luac.1.gz
|
||||
drwxr-xr-x root/root usr/share/
|
||||
drwxr-xr-x root/root usr/share/lua/
|
||||
drwxr-xr-x root/root usr/share/lua/5.2/
|
||||
drwxr-xr-x root/root usr/share/lua/5.3/
|
||||
|
@ -1,3 +1,3 @@
|
||||
bdc663c7b82ffc0b5df67611621fb625 liblua.so.patch
|
||||
dc7f94ec6ff15c985d2d6ad0f1b35654 lua-5.2.3.tar.gz
|
||||
85fe4e5f780376457eba3bc23d2cb2d3 liblua.so.patch
|
||||
797adacada8d85761c079390ff1d9961 lua-5.3.1.tar.gz
|
||||
e7ba6c2b695b0b84a5ea0cbff5fc9067 lua.pc
|
||||
|
14
lua/Pkgfile
14
lua/Pkgfile
@ -5,8 +5,8 @@
|
||||
# Depends on: readline
|
||||
|
||||
name=lua
|
||||
version=5.2.3
|
||||
release=2
|
||||
version=5.3.1
|
||||
release=1
|
||||
source=(http://www.lua.org/ftp/$name-$version.tar.gz
|
||||
liblua.so.patch lua.pc)
|
||||
|
||||
@ -14,18 +14,18 @@ build() {
|
||||
cd $name-$version
|
||||
|
||||
patch -p 1 -i $SRC/liblua.so.patch
|
||||
export CFLAGS="$CFLAGS -fPIC"
|
||||
export CFLAGS="$CFLAGS -fPIC -DLUA_COMPAT_5_2 -DLUA_COMPAT_5_1"
|
||||
|
||||
make MYCFLAGS="$CFLAGS" MYLDFLAGS="$LDFLAGS" linux
|
||||
|
||||
make \
|
||||
TO_LIB="liblua.a liblua.so.$version" \
|
||||
TO_LIB="liblua.a liblua.so.${version:0:3} liblua.so.$version" \
|
||||
INSTALL_TOP=$PKG/usr install
|
||||
|
||||
ln -sf liblua.so.$version $PKG/usr/lib/liblua.so.${version:0:3}
|
||||
ln -sf liblua.so.${version:0:3} $PKG/usr/lib/liblua.so
|
||||
ln -sf /usr/bin/lua $PKG/usr/bin/lua${version:0:3}
|
||||
ln -sf /usr/bin/luac $PKG/usr/bin/luac${version:0:3}
|
||||
|
||||
#make pc > lua.pc
|
||||
sed "s/%VER%/${version%.*}/g;s/%REL%/$version/g" $SRC/lua.pc > lua.pc
|
||||
sed "s/%VER%/${version:0:3}/g;s/%REL%/$version/g" $SRC/lua.pc > lua.pc
|
||||
install -m 0644 -D lua.pc $PKG/usr/lib/pkgconfig/lua.pc
|
||||
}
|
||||
|
@ -1,7 +1,8 @@
|
||||
diff -ru lua-5.2.1/Makefile lua-5.2.1.new/Makefile
|
||||
--- lua-5.2.1/Makefile 2012-05-17 16:05:54.000000000 +0200
|
||||
+++ lua-5.2.1.new/Makefile 2012-09-12 22:39:07.162748096 +0200
|
||||
@@ -52,7 +52,7 @@
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 7fa91c8..dccf485 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -52,7 +52,7 @@ R= $V.0
|
||||
all: $(PLAT)
|
||||
|
||||
$(PLATS) clean:
|
||||
@ -10,30 +11,19 @@ diff -ru lua-5.2.1/Makefile lua-5.2.1.new/Makefile
|
||||
|
||||
test: dummy
|
||||
src/lua -v
|
||||
diff -ru lua-5.2.1/src/luaconf.h lua-5.2.1.new/src/luaconf.h
|
||||
--- lua-5.2.1/src/luaconf.h 2012-05-11 16:14:42.000000000 +0200
|
||||
+++ lua-5.2.1.new/src/luaconf.h 2012-09-12 22:40:27.986622772 +0200
|
||||
@@ -100,7 +100,7 @@
|
||||
#else /* }{ */
|
||||
|
||||
#define LUA_VDIR LUA_VERSION_MAJOR "." LUA_VERSION_MINOR "/"
|
||||
-#define LUA_ROOT "/usr/local/"
|
||||
+#define LUA_ROOT "/usr/"
|
||||
#define LUA_LDIR LUA_ROOT "share/lua/" LUA_VDIR
|
||||
#define LUA_CDIR LUA_ROOT "lib/lua/" LUA_VDIR
|
||||
#define LUA_PATH_DEFAULT \
|
||||
diff -ru lua-5.2.1/src/Makefile lua-5.2.1.new/src/Makefile
|
||||
--- lua-5.2.1/src/Makefile 2012-03-09 17:32:16.000000000 +0100
|
||||
+++ lua-5.2.1.new/src/Makefile 2012-09-12 22:38:08.591386896 +0200
|
||||
@@ -29,6 +29,7 @@
|
||||
PLATS= aix ansi bsd freebsd generic linux macosx mingw posix solaris
|
||||
diff --git a/src/Makefile b/src/Makefile
|
||||
index 2e7a412..fa5769f 100644
|
||||
--- a/src/Makefile
|
||||
+++ b/src/Makefile
|
||||
@@ -29,6 +29,7 @@ MYOBJS=
|
||||
PLATS= aix bsd c89 freebsd generic linux macosx mingw posix solaris
|
||||
|
||||
LUA_A= liblua.a
|
||||
+LUA_SO= liblua.so
|
||||
CORE_O= lapi.o lcode.o lctype.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o \
|
||||
lmem.o lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o \
|
||||
ltm.o lundump.o lvm.o lzio.o
|
||||
@@ -43,7 +44,7 @@
|
||||
@@ -43,7 +44,7 @@ LUAC_T= luac
|
||||
LUAC_O= luac.o
|
||||
|
||||
ALL_O= $(BASE_O) $(LUA_O) $(LUAC_O)
|
||||
@ -42,7 +32,7 @@ diff -ru lua-5.2.1/src/Makefile lua-5.2.1.new/src/Makefile
|
||||
ALL_A= $(LUA_A)
|
||||
|
||||
# Targets start here.
|
||||
@@ -59,6 +60,12 @@
|
||||
@@ -59,6 +60,12 @@ $(LUA_A): $(BASE_O)
|
||||
$(AR) $@ $(BASE_O)
|
||||
$(RANLIB) $@
|
||||
|
||||
@ -55,3 +45,16 @@ diff -ru lua-5.2.1/src/Makefile lua-5.2.1.new/src/Makefile
|
||||
$(LUA_T): $(LUA_O) $(LUA_A)
|
||||
$(CC) -o $@ $(LDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
|
||||
|
||||
diff --git a/src/luaconf.h b/src/luaconf.h
|
||||
index fd28d21..e2662cc 100644
|
||||
--- a/src/luaconf.h
|
||||
+++ b/src/luaconf.h
|
||||
@@ -175,7 +175,7 @@
|
||||
|
||||
#else /* }{ */
|
||||
|
||||
-#define LUA_ROOT "/usr/local/"
|
||||
+#define LUA_ROOT "/usr/"
|
||||
#define LUA_LDIR LUA_ROOT "share/lua/" LUA_VDIR "/"
|
||||
#define LUA_CDIR LUA_ROOT "lib/lua/" LUA_VDIR "/"
|
||||
#define LUA_PATH_DEFAULT \
|
||||
|
Loading…
x
Reference in New Issue
Block a user