[notify] firefox: updated to 15.0.

Resolves several serious security issues.
see https://www.mozilla.org/security/known-vulnerabilities/firefox.html
port now uses external nspr/nss libraries due to issues with the bundled versions.
This commit is contained in:
Fredrik Rinnestam 2012-08-31 23:36:10 +02:00
parent a759c74a1e
commit 727ca2e292
5 changed files with 255 additions and 465 deletions

File diff suppressed because it is too large Load Diff

View File

@ -1,3 +1,2 @@
b05589ad2c690da20822710d7e691ff7 bz736961.patch
c2f884f0f6c41c65cf20f678a1ee7191 firefox-14.0.1.source.tar.bz2
eeb3ab01e0974e7385b09d7bc98f304a mozconfig
64220887a349515f16e5aa990acb4db3 firefox-15.0.source.tar.bz2
d773bdb2aa402c2e8dcdf2d09698595d mozconfig

View File

@ -1,13 +1,13 @@
# Description: The Mozilla Firefox browser
# URL: http://www.mozilla.com/firefox/
# Maintainer: Fredrik Rinnestam, fredrik at crux dot nu
# Depends on: libidl, gtk, python, alsa-lib, yasm, mesa3d
# Depends on: nss, libidl, gtk, python, alsa-lib, yasm, mesa3d
name=firefox
version=14.0.1
version=15.0
release=1
source=(ftp://ftp.mozilla.org/pub/firefox/releases/$version/source/firefox-$version.source.tar.bz2
mozconfig bz736961.patch)
mozconfig)
build() {
export MOZ_CO_PROJECT=browser
@ -16,7 +16,6 @@ build() {
export MOZILLA_FIVE_HOME=/usr/lib/firefox
cd mozilla-release
patch -p0 -i $SRC/bz736961.patch
export CFLAGS="$CFLAGS -mno-avx"
sed -e "s/#CFLAGS#/$CFLAGS/" $SRC/mozconfig > .mozconfig
./configure

View File

@ -1,112 +0,0 @@
--- config/rules.mk.orig Wed May 2 05:16:35 2012
+++ config/rules.mk Fri May 11 08:42:50 2012
@@ -1479,7 +1487,7 @@ $(XPIDL_GEN_DIR)/%.h: %.idl $(XPIDL_DEPS) $(XPIDL_GEN_
$(PYTHON_PATH) \
-I$(topsrcdir)/other-licenses/ply \
-I$(topsrcdir)/xpcom/idl-parser \
- $(topsrcdir)/xpcom/idl-parser/header.py --cachedir=$(DEPTH)/xpcom/idl-parser $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
+ $(topsrcdir)/xpcom/idl-parser/header.py --cachedir=$(DEPTH)/xpcom/idl-parser/cache $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
@if test -n "$(findstring $*.h, $(EXPORTS))"; \
then echo "*** WARNING: file $*.h generated from $*.idl overrides $(srcdir)/$*.h"; else true; fi
@@ -1492,7 +1500,7 @@ $(XPIDL_GEN_DIR)/%.xpt: %.idl $(XPIDL_DEPS) $(XPIDL_GE
-I$(topsrcdir)/other-licenses/ply \
-I$(topsrcdir)/xpcom/idl-parser \
-I$(topsrcdir)/xpcom/typelib/xpt/tools \
- $(topsrcdir)/xpcom/idl-parser/typelib.py --cachedir=$(DEPTH)/xpcom/idl-parser $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
+ $(topsrcdir)/xpcom/idl-parser/typelib.py --cachedir=$(DEPTH)/xpcom/idl-parser/cache $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
# no need to link together if XPIDLSRCS contains only XPIDL_MODULE
ifneq ($(XPIDL_MODULE).idl,$(strip $(XPIDLSRCS)))
--- js/src/config/rules.mk.orig Fri May 11 08:42:57 2012
+++ js/src/config/rules.mk Fri May 11 08:43:15 2012
@@ -1479,7 +1479,7 @@ $(XPIDL_GEN_DIR)/%.h: %.idl $(XPIDL_DEPS) $(XPIDL_GEN_
$(PYTHON_PATH) \
-I$(topsrcdir)/other-licenses/ply \
-I$(topsrcdir)/xpcom/idl-parser \
- $(topsrcdir)/xpcom/idl-parser/header.py --cachedir=$(DEPTH)/xpcom/idl-parser $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
+ $(topsrcdir)/xpcom/idl-parser/header.py --cachedir=$(DEPTH)/xpcom/idl-parser/cache $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
@if test -n "$(findstring $*.h, $(EXPORTS))"; \
then echo "*** WARNING: file $*.h generated from $*.idl overrides $(srcdir)/$*.h"; else true; fi
@@ -1492,7 +1492,7 @@ $(XPIDL_GEN_DIR)/%.xpt: %.idl $(XPIDL_DEPS) $(XPIDL_GE
-I$(topsrcdir)/other-licenses/ply \
-I$(topsrcdir)/xpcom/idl-parser \
-I$(topsrcdir)/xpcom/typelib/xpt/tools \
- $(topsrcdir)/xpcom/idl-parser/typelib.py --cachedir=$(DEPTH)/xpcom/idl-parser $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
+ $(topsrcdir)/xpcom/idl-parser/typelib.py --cachedir=$(DEPTH)/xpcom/idl-parser/cache $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
# no need to link together if XPIDLSRCS contains only XPIDL_MODULE
ifneq ($(XPIDL_MODULE).idl,$(strip $(XPIDLSRCS)))
--- js/xpconnect/src/Makefile.in.orig Fri May 11 08:43:27 2012
+++ js/xpconnect/src/Makefile.in Fri May 11 08:44:03 2012
@@ -151,7 +151,7 @@ dom_quickstubs.cpp: $(srcdir)/dom_quickstubs.qsconf \
-I$(topsrcdir)/xpcom/idl-parser \
$(srcdir)/qsgen.py \
--idlpath=$(DEPTH)/dist/idl \
- --cachedir=$(DEPTH)/xpcom/idl-parser \
+ --cachedir=$(DEPTH)/xpcom/idl-parser/cache \
--header-output dom_quickstubs.h \
--stub-output dom_quickstubs.cpp \
--makedepend-output $(MDDEPDIR)/dom_qsgen.pp \
@@ -172,7 +172,7 @@ dombindings_gen.h: $(srcdir)/dombindings.conf \
-I$(topsrcdir)/xpcom/idl-parser \
$(srcdir)/dombindingsgen.py \
--idlpath=$(DEPTH)/dist/idl \
- --cachedir=$(DEPTH)/xpcom/idl-parser \
+ --cachedir=$(DEPTH)/xpcom/idl-parser/cache \
--header-output dombindings_gen.h \
$(srcdir)/dombindings.conf
@@ -189,7 +189,7 @@ dombindings_gen.cpp: $(srcdir)/dombindings.conf \
-I$(topsrcdir)/xpcom/idl-parser \
$(srcdir)/dombindingsgen.py \
--idlpath=$(DEPTH)/dist/idl \
- --cachedir=$(DEPTH)/xpcom/idl-parser \
+ --cachedir=$(DEPTH)/xpcom/idl-parser/cache \
--stub-output dombindings_gen.cpp \
--makedepend-output $(MDDEPDIR)/dombindingsgen.pp \
$(srcdir)/dombindings.conf
@@ -208,7 +208,7 @@ DictionaryHelpers.h: $(srcdir)/dictionary_helper_gen.c
-I$(topsrcdir)/xpcom/idl-parser \
$(srcdir)/dictionary_helper_gen.py \
-I $(DEPTH)/dist/idl \
- --cachedir=$(DEPTH)/xpcom/idl-parser \
+ --cachedir=$(DEPTH)/xpcom/idl-parser/cache \
--header-output DictionaryHelpers.h \
$(srcdir)/dictionary_helper_gen.conf
@@ -223,7 +223,7 @@ DictionaryHelpers.cpp: $(srcdir)/dictionary_helper_gen
-I$(topsrcdir)/xpcom/idl-parser \
$(srcdir)/dictionary_helper_gen.py \
-I $(DEPTH)/dist/idl \
- --cachedir=$(DEPTH)/xpcom/idl-parser \
+ --cachedir=$(DEPTH)/xpcom/idl-parser/cache \
--header-output DictionaryHelpers.h \
--stub-output DictionaryHelpers.cpp \
--makedepend-output $(MDDEPDIR)/dictionary_helper_gen.pp \
--- xpcom/idl-parser/Makefile.in.orig Fri May 11 08:44:10 2012
+++ xpcom/idl-parser/Makefile.in Fri May 11 08:44:29 2012
@@ -61,7 +61,7 @@ export:: $(PARSER_SRCS) $(PLY_PROGS)
$(PYTHON_PATH) \
-I$(topsrcdir)/other-licenses/ply \
-I$(topsrcdir)/xpcom/idl-parser \
- $(topsrcdir)/xpcom/idl-parser/header.py --cachedir=. --regen
+ $(topsrcdir)/xpcom/idl-parser/header.py --cachedir=$(DEPTH)/xpcom/idl-parser/cache --regen
check::
$(PYTHON_PATH) \
--- xpcom/typelib/xpidl/Makefile.in.orig Fri May 11 08:44:51 2012
+++ xpcom/typelib/xpidl/Makefile.in Fri May 11 08:45:09 2012
@@ -48,8 +48,8 @@ SDK_BINARY = \
$(topsrcdir)/xpcom/idl-parser/xpidl.py \
$(topsrcdir)/xpcom/idl-parser/header.py \
$(topsrcdir)/xpcom/idl-parser/typelib.py \
- $(DEPTH)/xpcom/idl-parser/xpidllex.py \
- $(DEPTH)/xpcom/idl-parser/xpidlyacc.py \
+ $(DEPTH)/xpcom/idl-parser/cache/xpidllex.py \
+ $(DEPTH)/xpcom/idl-parser/cache/xpidlyacc.py \
$(NULL)
ifndef MOZ_SYSTEM_PLY

View File

@ -13,6 +13,8 @@ ac_add_options --prefix=/usr
ac_add_options --with-system-jpeg
ac_add_options --with-system-zlib
ac_add_options --with-system-mng
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
#ac_add_options --enable-system-cairo
ac_add_options --with-pthreads
ac_add_options --enable-optimize="#CFLAGS#"