Revert "poppler: update to 0.58.0"

This reverts commit a1d6eb481c.

poppler 0.58.0 breaks cups-filters 1.16.4 and 1.17.2
This commit is contained in:
Juergen Daubert 2017-09-02 11:49:16 +02:00
parent b04a745f81
commit 75b19a0fef
5 changed files with 19 additions and 19 deletions

View File

@ -154,9 +154,9 @@ drwxr-xr-x root/root usr/lib/
lrwxrwxrwx root/root usr/lib/libpoppler-cpp.so -> libpoppler-cpp.so.0
lrwxrwxrwx root/root usr/lib/libpoppler-cpp.so.0 -> libpoppler-cpp.so.0.3.0
-rwxr-xr-x root/root usr/lib/libpoppler-cpp.so.0.3.0
lrwxrwxrwx root/root usr/lib/libpoppler.so -> libpoppler.so.69
lrwxrwxrwx root/root usr/lib/libpoppler.so.69 -> libpoppler.so.69.0.0
-rwxr-xr-x root/root usr/lib/libpoppler.so.69.0.0
lrwxrwxrwx root/root usr/lib/libpoppler.so -> libpoppler.so.68
lrwxrwxrwx root/root usr/lib/libpoppler.so.68 -> libpoppler.so.68.0.0
-rwxr-xr-x root/root usr/lib/libpoppler.so.68.0.0
drwxr-xr-x root/root usr/lib/pkgconfig/
-rw-r--r-- root/root usr/lib/pkgconfig/poppler-cairo.pc
-rw-r--r-- root/root usr/lib/pkgconfig/poppler-cpp.pc

View File

@ -1,2 +1,2 @@
7de34c4e1255351cc1c8a6e721355a18 poppler-0.58.0.tar.xz
95568300305341ccc95145c8fdb9ef08 poppler-cmake.patch
bc5a191741604552c90d484103229374 poppler-0.57.0.tar.xz
3550e95260ee788c6cc5ef0a579d3037 poppler-cmake.patch

View File

@ -1,6 +1,6 @@
untrusted comment: verify with /etc/ports/opt.pub
RWSE3ohX2g5d/WvVwGMF5Wc6ZtqnPT6lFmCTLRl/krQwZei31btebcF6zgBOx+6RZJijmSDb59KifiOPG2u+BZA8JzfC6z1Gmw4=
SHA256 (Pkgfile) = a49626b5e1084ad1ef70e924c8a78003187ee645d1ef5082b524600243bcaf71
SHA256 (.footprint) = 3bf3f1282f1c47461d465fd32b0b9206565068269f874a9b150bf84905a01b15
SHA256 (poppler-0.58.0.tar.xz) = 0e42e46419ae54b02d9f2b527c6475b6011d15816918b9057dfa3aae211af832
SHA256 (poppler-cmake.patch) = efed502816ed597cdabebfd1b1f65e40bec4ff616b57853411a8a2e46cfd30f3
RWSE3ohX2g5d/VeTSqDgJOUBAd41gZ3QBHTEq+n0knvX5EKrfbVYemiMoFB/esrYYz0DF/DxSbx5ytHVBmOGO9QtYXBRLFBj8Q0=
SHA256 (Pkgfile) = 1b2bcfe22d0bace686669e9b3b4b88a4d5ee4778f22c715e8dd8ac3156ac85f5
SHA256 (.footprint) = 3bb46ca2783dde9e912039140a3dc9b43f1ed02495a114a2933965a398bb0c1b
SHA256 (poppler-0.57.0.tar.xz) = 0ea37de71b7db78212ebc79df59f99b66409a29c2eac4d882dae9f2397fe44d8
SHA256 (poppler-cmake.patch) = 8a75147e58d5ecc2eb5baced98fcc405320ff94e2a8eb613c04c91aa8e441d5c

View File

@ -4,7 +4,7 @@
# Depends on: cmake cairo lcms2
name=poppler
version=0.58.0
version=0.57.0
release=1
source=(http://poppler.freedesktop.org/poppler-$version.tar.xz
poppler-cmake.patch)

View File

@ -1,6 +1,6 @@
--- CMakeLists.txt.orig 2017-09-01 20:11:09.000000000 +0200
+++ CMakeLists.txt 2017-09-02 11:01:59.451918361 +0200
@@ -36,8 +36,14 @@
--- CMakeLists.txt.orig 2017-05-21 23:01:39.000000000 +0200
+++ CMakeLists.txt 2017-05-22 14:12:44.635191266 +0200
@@ -35,8 +35,14 @@
option(BUILD_QT5_TESTS "Whether compile the Qt5 test programs." ON)
option(BUILD_CPP_TESTS "Whether compile the CPP test programs." ON)
option(ENABLE_SPLASH "Build the Splash graphics backend." ON)
@ -15,7 +15,7 @@
set(ENABLE_LIBOPENJPEG "auto" CACHE STRING "Use libopenjpeg for JPX streams. Possible values: auto, openjpeg1, openjpeg2, unmaintained, none. 'auto' prefers openjpeg2 over openjpeg1 if both are available. 'unmaintained' gives you the internal unmaintained decoder. Use at your own risk. 'none' compiles no JPX decoder at all. Default: auto")
set(ENABLE_CMS "auto" CACHE STRING "Use color management system. Possible values: auto, lcms1, lcms2. 'auto' prefers lcms2 over lcms1 if both are available. Unset to disable color management system.")
set(ENABLE_DCTDECODER "libjpeg" CACHE STRING "Use libjpeg for DCT streams. Possible values: libjpeg, unmaintained, none. will use libjpeg if available or fail if not. 'unmaintained' gives you the internal unmaintained decoder. Use at your own risk. 'none' compiles no DCT decoder at all. Default: libjpeg")
@@ -130,43 +136,46 @@
@@ -127,43 +133,46 @@
message(FATAL_ERROR "Invalid ENABLE_DCTDECODER value.")
endif()
macro_optional_find_package(Qt4)
@ -98,7 +98,7 @@
if(ENABLE_CPP)
macro_optional_find_package(Iconv)
set(ENABLE_CPP ${ICONV_FOUND})
@@ -280,10 +289,10 @@
@@ -277,10 +286,10 @@
include_directories(${ZLIB_INCLUDE_DIR})
endif(ENABLE_ZLIB)
@ -111,7 +111,7 @@
if(JPEG_FOUND)
include_directories(${JPEG_INCLUDE_DIR})
endif(JPEG_FOUND)
@@ -721,12 +730,12 @@
@@ -716,12 +725,12 @@
add_subdirectory(glib)
endif(ENABLE_GLIB)
add_subdirectory(test)
@ -128,7 +128,7 @@
if(ENABLE_CPP)
add_subdirectory(cpp)
endif(ENABLE_CPP)
@@ -748,12 +757,12 @@
@@ -743,12 +752,12 @@
if(ENABLE_SPLASH)
poppler_create_install_pkgconfig(poppler-splash.pc lib${LIB_SUFFIX}/pkgconfig)
endif(ENABLE_SPLASH)
@ -145,7 +145,7 @@
if(ENABLE_GLIB)
poppler_create_install_pkgconfig(poppler-glib.pc lib${LIB_SUFFIX}/pkgconfig)
endif(ENABLE_GLIB)
@@ -772,8 +781,8 @@
@@ -767,8 +776,8 @@
message(" with CMYK support")
endif()
show_end_message_yesno("cairo output" CAIRO_FOUND)