mdadm: update to 2.5

This commit is contained in:
Juergen Daubert 2006-06-15 11:15:18 +00:00
parent f08c12fc2a
commit 77bec139a6
3 changed files with 33 additions and 7 deletions

View File

@ -1 +1,2 @@
fa09e85ff0859296c0e4f0ab18dc5678 mdadm-2.4.1.tar.gz
2c8bc887affb2247ee5f4b50067fac8f mdadm-2.5.tar.gz
69c81b2973dd0a24e105a718b94b6892 mdadm-ssl.patch

View File

@ -1,16 +1,15 @@
# Description: Multiple device (RAID) admin tool
# URL: http://www.cse.unsw.edu.au/~neilb/source/mdadm/
# Packager: Gunter Coelle, gunter dot coelle at dbaudio dot com
# Maintainer: Jürgen Daubert, juergen dot daubert at t-online dot de
# Depends on:
name=mdadm
version=2.4.1
version=2.5
release=1
source=(http://www.kernel.org/pub/linux/utils/raid/$name/$name-$version.tar.gz)
source=(http://www.kernel.org/pub/linux/utils/raid/$name/$name-$version.tar.gz \
$name-ssl.patch)
build() {
cd $name-$version
make CXFLAGS="$CFLAGS"
make DESTDIR=$PKG MANDIR=/usr/man install
patch -p1 < $SRC/$name-ssl.patch
make CXFLAGS="$CFLAGS" USE_SSL=0 DESTDIR=$PKG MANDIR=/usr/man install
}

26
mdadm/mdadm-ssl.patch Normal file
View File

@ -0,0 +1,26 @@
diff -Nru mdadm-2.5.orig/Makefile mdadm-2.5/Makefile
--- mdadm-2.5.orig/Makefile 2006-06-15 12:49:16.000000000 +0200
+++ mdadm-2.5/Makefile 2006-06-15 12:52:54.000000000 +0200
@@ -32,7 +32,9 @@
TCC = tcc
UCLIBC_GCC = $(shell for nm in i386-uclibc-linux-gcc i386-uclibc-gcc; do which $$nm > /dev/null && { echo $$nm ; exit; } ; done; echo false No uclibc found )
DIET_GCC = diet gcc
-LDLIBS=-lssl
+ifeq ($(USE_SSL),1)
+LDLIBS=-lcrypto
+endif
KLIBC=/home/src/klibc/klibc-0.77
@@ -72,6 +74,11 @@
Create.c Detail.c Examine.c Grow.c Monitor.c dlink.c Kill.c Query.c \
mdopen.c super0.c super1.c bitmap.c restripe.c sysfs.c
+ifneq ($(USE_SSL),1)
+OBJS += SHA1.o sha1.o
+SRCS += SHA1.c sha1.c
+endif
+
ASSEMBLE_SRCS := mdassemble.c Assemble.c config.c dlink.c util.c super0.c super1.c
ASSEMBLE_FLAGS:= -DMDASSEMBLE
ifdef MDASSEMBLE_AUTO