wvdial: update to 1.60

This commit is contained in:
Juergen Daubert 2007-07-22 11:39:16 +02:00
parent d62908dfad
commit 8144e04f0e
4 changed files with 54 additions and 60 deletions

View File

@ -1,3 +1,3 @@
d084772c96db6c52371e36b29d95f332 wvdial-1.56.patch
45097f269c7847266e121e4a0f362be9 wvdial-1.56.tar.gz
eb34544384c951fd14470d583273e02a wvstreams-4.3.tar.gz
ca2d01b5c727d7ea62aa20b81028998b wvdial-1.60.patch
27fbbde89f8fd9f6e735a8efa5217fc9 wvdial-1.60.tar.gz
441c85c2347e118965e47124b0c867ff wvstreams-4.4.tar.gz

View File

@ -4,22 +4,22 @@
# Depends on: ppp, openssl
name=wvdial
version=1.56
release=3
version=1.60
release=1
source=(http://alumnit.ca/download/$name-$version.tar.gz \
http://alumnit.ca/download/wvstreams-4.3.tar.gz \
http://wvstreams.googlecode.com/files/wvstreams-4.4.tar.gz \
$name-$version.patch)
build() {
cd wvstreams-4.3
cd wvstreams-4.4
./configure --prefix=/usr \
--enable-verbose \
--without-{bdb,qdbm,pam,tcl,telephony,swig,qt,openslp}
--without-{pam,tcl,qt}
make
ln -s ../xplc/include/xplc include/xplc
cd $SRC/$name-$version
patch -p1 < $SRC/$name-$version.patch
make CXXOPTS="$CXXFLAGS" WVS=$SRC/wvstreams-4.3
make CXXOPTS="$CXXFLAGS" WVS=$SRC/wvstreams-4.4
make DESTDIR=$PKG install
}

View File

@ -1,51 +0,0 @@
diff -Nru wvdial-1.55.orig/Makefile wvdial-1.55/Makefile
--- wvdial-1.55.orig/Makefile 2006-02-12 19:22:27.000000000 +0100
+++ wvdial-1.55/Makefile 2006-02-12 20:55:49.000000000 +0100
@@ -1,30 +1,22 @@
ifeq ($(TOPDIR),)
TOPDIR=.
- prefix=/usr/local
- WVSTREAMS_INC=
- WVSTREAMS_LIB=
+ prefix=$(DESTDIR)/usr
+ WVSTREAMS_INC=$(WVS)/include
+ WVSTREAMS_LIB=$(WVS)
WVSTREAMS_BIN=$(prefix)/bin
WVSTREAMS_SRC=.
- PC_CFLAGS=$(shell pkg-config --cflags libwvstreams)
- ifeq ($(PC_CFLAGS),)
- $(error WvStreams does not appear to be installed)
- endif
- CPPFLAGS+=$(PC_CFLAGS)
-
- PC_LIBS=$(shell pkg-config --libs libwvstreams)
- ifeq ($(PC_LIBS),)
- $(error WvStreams does not appear to be installed)
- endif
- LIBS+=$(PC_LIBS)
+ LIBS = $(WVS)/libuniconf.a $(WVS)/libwvstreams.a $(WVS)/libwvutils.a $(WVS)/libwvbase.a $(WVS)/xplc/libxplc-cxx.a -lcrypto -lssl
else
XPATH=$(TOPDIR)/src
endif
BINDIR=${prefix}/bin
-MANDIR=${prefix}/share/man
-PPPDIR=/etc/ppp/peers
+MANDIR=${prefix}/man
+PPPDIR=$(DESTDIR)/etc/ppp/peers
+
+VERBOSE=1
include $(TOPDIR)/wvrules.mk
@@ -38,7 +30,7 @@
ifeq ($(WVSTREAMS_LIB),)
LIBUNICONF:=-luniconf
endif
-wvdial wvdialconf papchaptest pppmon: wvdial.a $(LIBUNICONF)
+wvdial wvdialconf papchaptest pppmon: wvdial.a
install-bin: all
[ -d ${BINDIR} ] || install -d ${BINDIR}

45
wvdial/wvdial-1.60.patch Normal file
View File

@ -0,0 +1,45 @@
diff -Nru wvdial-1.60.orig/Makefile wvdial-1.60/Makefile
--- wvdial-1.60.orig/Makefile 2007-07-21 11:24:37.000000000 +0200
+++ wvdial-1.60/Makefile 2007-07-21 11:42:43.000000000 +0200
@@ -1,25 +1,17 @@
-prefix=/usr/local
-WVSTREAMS_INC=
-WVSTREAMS_LIB=
+prefix=$(DESTDIR)/usr
+WVSTREAMS_INC=$(WVS)/include
+WVSTREAMS_LIB=$(WVS)
WVSTREAMS_BIN=$(prefix)/bin
WVSTREAMS_SRC=.
-PC_CFLAGS=$(shell pkg-config --cflags libwvstreams)
-ifeq ($(PC_CFLAGS),)
- $(error WvStreams does not appear to be installed)
-endif
-CPPFLAGS+=$(PC_CFLAGS)
-
-PC_LIBS=$(shell pkg-config --libs libwvstreams)
-ifeq ($(PC_LIBS),)
- $(error WvStreams does not appear to be installed)
-endif
-LIBS+=$(PC_LIBS)
+LIBS = $(WVS)/libuniconf.a $(WVS)/libwvstreams.a $(WVS)/libwvutils.a $(WVS)/libwvbase.a $(WVS)/xplc/libxplc-cxx.a -lcrypto -lssl
BINDIR=${prefix}/bin
-MANDIR=${prefix}/share/man
-PPPDIR=/etc/ppp/peers
+MANDIR=${prefix}/man
+PPPDIR=$(DESTDIR)/etc/ppp/peers
+
+VERBOSE=1
include wvrules.mk
@@ -30,7 +22,6 @@
wvdial.a: wvdialer.o wvmodemscan.o wvpapchap.o wvdialbrain.o \
wvdialmon.o
-wvdial: LDFLAGS+=-luniconf
wvdial wvdialconf papchaptest pppmon: wvdial.a