python: update to 2.5.1

This commit is contained in:
Juergen Daubert 2007-04-19 08:40:41 +02:00
parent 76e7ca3943
commit 82319b2461
5 changed files with 56 additions and 59 deletions

View File

@ -1236,7 +1236,7 @@ drwxr-xr-x root/root usr/lib/python2.5/idlelib/Icons/
-rw-r--r-- root/root usr/lib/python2.5/keyword.pyc
-rw-r--r-- root/root usr/lib/python2.5/keyword.pyo
drwxr-xr-x root/root usr/lib/python2.5/lib-dynload/
-rw-r--r-- root/root usr/lib/python2.5/lib-dynload/Python-2.5-py2.5.egg-info
-rw-r--r-- root/root usr/lib/python2.5/lib-dynload/Python-2.5.1-py2.5.egg-info
-rwxr-xr-x root/root usr/lib/python2.5/lib-dynload/_bisect.so
-rwxr-xr-x root/root usr/lib/python2.5/lib-dynload/_bsddb.so
-rwxr-xr-x root/root usr/lib/python2.5/lib-dynload/_codecs_cn.so
@ -1696,6 +1696,9 @@ drwxr-xr-x root/root usr/lib/python2.5/test/decimaltestdata/
-rw-r--r-- root/root usr/lib/python2.5/test/fork_wait.pyc
-rw-r--r-- root/root usr/lib/python2.5/test/fork_wait.pyo
-rw-r--r-- root/root usr/lib/python2.5/test/greyrgb.uue
-rw-r--r-- root/root usr/lib/python2.5/test/infinite_reload.py
-rw-r--r-- root/root usr/lib/python2.5/test/infinite_reload.pyc
-rw-r--r-- root/root usr/lib/python2.5/test/infinite_reload.pyo
-rw-r--r-- root/root usr/lib/python2.5/test/inspect_fodder.py
-rw-r--r-- root/root usr/lib/python2.5/test/inspect_fodder.pyc
-rw-r--r-- root/root usr/lib/python2.5/test/inspect_fodder.pyo
@ -1983,6 +1986,9 @@ drwxr-xr-x root/root usr/lib/python2.5/test/output/
-rw-r--r-- root/root usr/lib/python2.5/test/test_complex.py
-rw-r--r-- root/root usr/lib/python2.5/test/test_complex.pyc
-rw-r--r-- root/root usr/lib/python2.5/test/test_complex.pyo
-rw-r--r-- root/root usr/lib/python2.5/test/test_complex_args.py
-rw-r--r-- root/root usr/lib/python2.5/test/test_complex_args.pyc
-rw-r--r-- root/root usr/lib/python2.5/test/test_complex_args.pyo
-rw-r--r-- root/root usr/lib/python2.5/test/test_contains.py
-rw-r--r-- root/root usr/lib/python2.5/test/test_contains.pyc
-rw-r--r-- root/root usr/lib/python2.5/test/test_contains.pyo
@ -2570,6 +2576,9 @@ drwxr-xr-x root/root usr/lib/python2.5/test/output/
-rw-r--r-- root/root usr/lib/python2.5/test/test_struct.py
-rw-r--r-- root/root usr/lib/python2.5/test/test_struct.pyc
-rw-r--r-- root/root usr/lib/python2.5/test/test_struct.pyo
-rw-r--r-- root/root usr/lib/python2.5/test/test_structmembers.py
-rw-r--r-- root/root usr/lib/python2.5/test/test_structmembers.pyc
-rw-r--r-- root/root usr/lib/python2.5/test/test_structmembers.pyo
-rw-r--r-- root/root usr/lib/python2.5/test/test_structseq.py
-rw-r--r-- root/root usr/lib/python2.5/test/test_structseq.pyc
-rw-r--r-- root/root usr/lib/python2.5/test/test_structseq.pyo

View File

@ -1,2 +1,2 @@
ddb7401e711354ca83b7842b733825a3 Python-2.5.tar.bz2
3e31bd8cd171b942b523a894ef9204a4 python-2.5.patch
70084ffa561660f07de466c2c8c4842d Python-2.5.1.tar.bz2
56e270a4bca9479c3aa9a4bc19dba184 python-2.5.1.patch

View File

@ -4,7 +4,7 @@
# Depends on: db, gdbm, ncurses, openssl, readline, zlib
name=python
version=2.5
version=2.5.1
release=1
source=(http://www.python.org/ftp/$name/$version/Python-$version.tar.bz2 \
$name-$version.patch)
@ -18,7 +18,7 @@ build () {
--with-threads \
--enable-ipv6
make
make DESTDIR=$PKG install
make -j1 DESTDIR=$PKG install
ln -sf python2.5 $PKG/usr/bin/python
ln -sf python2.5 $PKG/usr/lib/python

42
python/python-2.5.1.patch Normal file
View File

@ -0,0 +1,42 @@
diff -Nru Python-2.5.1.orig/Lib/cgi.py Python-2.5.1/Lib/cgi.py
--- Python-2.5.1.orig/Lib/cgi.py 2007-04-18 16:48:34.000000000 +0200
+++ Python-2.5.1/Lib/cgi.py 2007-04-18 16:48:47.000000000 +0200
@@ -1,4 +1,4 @@
-#! /usr/local/bin/python
+#! /usr/bin/python
# NOTE: the above "/usr/local/bin/python" is NOT a mistake. It is
# intentionally NOT "/usr/bin/env python". On many systems
diff -Nru Python-2.5.1.orig/Modules/Setup.dist Python-2.5.1/Modules/Setup.dist
--- Python-2.5.1.orig/Modules/Setup.dist 2007-04-18 16:48:34.000000000 +0200
+++ Python-2.5.1/Modules/Setup.dist 2007-04-18 16:48:47.000000000 +0200
@@ -149,7 +149,7 @@
# modules are to be built as shared libraries (see above for more
# detail; also note that *static* reverses this effect):
-#*shared*
+*shared*
# GNU readline. Unlike previous Python incarnations, GNU readline is
# now incorporated in an optional module, configured in the Setup file
@@ -381,7 +381,7 @@
#
# First, look at Setup.config; configure may have set this for you.
-#dbm dbmmodule.c # dbm(3) may require -lndbm or similar
+dbm dbmmodule.c -DHAVE_NDBM_H -lgdbm_compat -lgdbm # dbm(3) may require -lndbm or similar
# Anthony Baxter's gdbm module. GNU dbm(3) will require -lgdbm:
#
diff -Nru Python-2.5.1.orig/configure Python-2.5.1/configure
--- Python-2.5.1.orig/configure 2007-04-18 16:48:34.000000000 +0200
+++ Python-2.5.1/configure 2007-04-18 16:48:47.000000000 +0200
@@ -3805,7 +3805,7 @@
# debug builds.
OPT="-g -Wall $STRICT_PROTO"
else
- OPT="-g -O3 -Wall $STRICT_PROTO"
+ OPT="$CFLAGS -Wall $STRICT_PROTO"
fi
;;
*)

View File

@ -1,54 +0,0 @@
diff -Nru Python-2.5.orig/Lib/cgi.py Python-2.5/Lib/cgi.py
--- Python-2.5.orig/Lib/cgi.py 2007-01-03 14:31:57.000000000 +0100
+++ Python-2.5/Lib/cgi.py 2007-01-03 14:32:13.000000000 +0100
@@ -1,4 +1,4 @@
-#! /usr/local/bin/python
+#! /usr/bin/python
# NOTE: the above "/usr/local/bin/python" is NOT a mistake. It is
# intentionally NOT "/usr/bin/env python". On many systems
diff -Nru Python-2.5.orig/Makefile.pre.in Python-2.5/Makefile.pre.in
--- Python-2.5.orig/Makefile.pre.in 2007-01-03 14:32:02.000000000 +0100
+++ Python-2.5/Makefile.pre.in 2007-01-03 14:32:33.000000000 +0100
@@ -62,7 +62,7 @@
# be able to build extension modules using the directories specified in the
# environment variables
CPPFLAGS= -I. -I$(srcdir)/Include @CPPFLAGS@
-LDFLAGS= @LDFLAGS@
+LDFLAGS= -L. @LDFLAGS@
LDLAST= @LDLAST@
SGI_ABI= @SGI_ABI@
CCSHARED= @CCSHARED@
diff -Nru Python-2.5.orig/Modules/Setup.dist Python-2.5/Modules/Setup.dist
--- Python-2.5.orig/Modules/Setup.dist 2007-01-03 14:32:02.000000000 +0100
+++ Python-2.5/Modules/Setup.dist 2007-01-03 14:32:13.000000000 +0100
@@ -149,7 +149,7 @@
# modules are to be built as shared libraries (see above for more
# detail; also note that *static* reverses this effect):
-#*shared*
+*shared*
# GNU readline. Unlike previous Python incarnations, GNU readline is
# now incorporated in an optional module, configured in the Setup file
@@ -381,7 +381,7 @@
#
# First, look at Setup.config; configure may have set this for you.
-#dbm dbmmodule.c # dbm(3) may require -lndbm or similar
+dbm dbmmodule.c -DHAVE_NDBM_H -lgdbm_compat -lgdbm # dbm(3) may require -lndbm or similar
# Anthony Baxter's gdbm module. GNU dbm(3) will require -lgdbm:
#
diff -Nru Python-2.5.orig/configure Python-2.5/configure
--- Python-2.5.orig/configure 2007-01-03 14:31:58.000000000 +0100
+++ Python-2.5/configure 2007-01-03 14:32:13.000000000 +0100
@@ -3800,7 +3800,7 @@
# debug builds.
OPT="-g -Wall $STRICT_PROTO"
else
- OPT="-g -O3 -Wall $STRICT_PROTO"
+ OPT="$CFLAGS -Wall $STRICT_PROTO"
fi
;;
*)