libgpg-error: 1.36 -> 1.37

This commit is contained in:
Thomas Penteker 2020-04-01 23:49:35 +02:00
parent 39df89e473
commit 8382c07d09
4 changed files with 9 additions and 173 deletions

View File

@ -10,9 +10,9 @@ drwxr-xr-x root/root usr/include/
drwxr-xr-x root/root usr/lib/
-rw-r--r-- root/root usr/lib/libgpg-error.a
-rwxr-xr-x root/root usr/lib/libgpg-error.la
lrwxrwxrwx root/root usr/lib/libgpg-error.so -> libgpg-error.so.0.27.0
lrwxrwxrwx root/root usr/lib/libgpg-error.so.0 -> libgpg-error.so.0.27.0
-rwxr-xr-x root/root usr/lib/libgpg-error.so.0.27.0
lrwxrwxrwx root/root usr/lib/libgpg-error.so -> libgpg-error.so.0.28.0
lrwxrwxrwx root/root usr/lib/libgpg-error.so.0 -> libgpg-error.so.0.28.0
-rwxr-xr-x root/root usr/lib/libgpg-error.so.0.28.0
drwxr-xr-x root/root usr/lib/pkgconfig/
-rw-r--r-- root/root usr/lib/pkgconfig/gpg-error.pc
drwxr-xr-x root/root usr/share/

View File

@ -1,6 +1,5 @@
untrusted comment: verify with /etc/ports/opt.pub
RWSE3ohX2g5d/dKz/rG4ZuBVOte3gc0wsWBJpI9spoxCtnot359G4etrHHA08g9j0UBVZ3P6tXjKYAbkCG+hsLOA071192PzEQ4=
SHA256 (Pkgfile) = 9b4a3910cbefc851dcc18cd2d8e4c23ba489b6fba38fc09c1ccd3d2ec5b5d0c7
SHA256 (.footprint) = 95609660b2ffe1c6dc7d4bbfc6d0e3f8e2e283a3178ad5f8ef16bcdb51259c9e
SHA256 (libgpg-error-1.36.tar.bz2) = babd98437208c163175c29453f8681094bcaf92968a15cafb1a276076b33c97c
SHA256 (gawk.patch) = f6030ebc1b14723b36adb4e5de80693c3875932b444bbb7baaa5e81779f05797
RWSE3ohX2g5d/cVfD3jXK3TVUCoJTWQncFiuy3e++wH6WAn2eMSYFsjlTDimBJHzgZMAOGE0wJVd7PCGjWiQWXC+7TE/uuS/6ws=
SHA256 (Pkgfile) = 6c6ea5d40d18dd9f6f3d4ae9d4aed948ed96d876873acf5eab747d94046fdf9e
SHA256 (.footprint) = e2ab8569f0976abf45ce2db2b67823b0c6c6c04c5c5f0037a478e53c7552caf9
SHA256 (libgpg-error-1.37.tar.bz2) = b32d6ff72a73cf79797f7f2d039e95e9c6f92f0c1450215410840ab62aea9763

View File

@ -3,18 +3,13 @@
# Maintainer: Thomas Penteker, tek at serverop dot de
name=libgpg-error
version=1.36
version=1.37
release=1
source=(https://www.gnupg.org/ftp/gcrypt/$name/$name-$version.tar.bz2
gawk.patch)
source=(https://www.gnupg.org/ftp/gcrypt/$name/$name-$version.tar.bz2)
build() {
cd $name-$version
patch -p1 -i $SRC/gawk.patch
autoreconf
./configure --prefix=/usr \
--disable-nls \
--enable-static

View File

@ -1,158 +0,0 @@
From 7865041c77f4f7005282f10f9b6666b19072fbdf Mon Sep 17 00:00:00 2001
From: NIIBE Yutaka <gniibe@fsij.org>
Date: Mon, 15 Apr 2019 15:10:44 +0900
Subject: [PATCH] awk: Prepare for Gawk 5.0.
* src/Makefile.am: Use pkg_namespace (instead of namespace).
* src/mkerrnos.awk: Likewise.
* lang/cl/mkerrcodes.awk: Don't escape # in regexp.
* src/mkerrcodes.awk, src/mkerrcodes1.awk, src/mkerrcodes2.awk: Ditto.
--
In Gawk 5.0, regexp routines are replaced by Gnulib implementation,
which only allows escaping specific characters.
GnuPG-bug-id: 4459
Reported-by: Marius Schamschula
Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
---
lang/cl/mkerrcodes.awk | 2 +-
src/Makefile.am | 2 +-
src/mkerrcodes.awk | 2 +-
src/mkerrcodes1.awk | 2 +-
src/mkerrcodes2.awk | 2 +-
src/mkerrnos.awk | 2 +-
src/mkstrtable.awk | 10 +++++-----
7 files changed, 11 insertions(+), 11 deletions(-)
diff --git a/lang/cl/mkerrcodes.awk b/lang/cl/mkerrcodes.awk
index ae29043..9a1fc18 100644
--- a/lang/cl/mkerrcodes.awk
+++ b/lang/cl/mkerrcodes.awk
@@ -122,7 +122,7 @@ header {
}
!header {
- sub (/\#.+/, "");
+ sub (/#.+/, "");
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
if (/^$/)
diff --git a/src/Makefile.am b/src/Makefile.am
index ce1b882..f2590cb 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -293,7 +293,7 @@ code-from-errno.h: mkerrcodes$(EXEEXT_FOR_BUILD) Makefile
errnos-sym.h: Makefile mkstrtable.awk errnos.in
$(AWK) -f $(srcdir)/mkstrtable.awk -v textidx=2 -v nogettext=1 \
- -v prefix=GPG_ERR_ -v namespace=errnos_ \
+ -v prefix=GPG_ERR_ -v pkg_namespace=errnos_ \
$(srcdir)/errnos.in >$@
diff --git a/src/mkerrcodes.awk b/src/mkerrcodes.awk
index 46d436c..e9c857c 100644
--- a/src/mkerrcodes.awk
+++ b/src/mkerrcodes.awk
@@ -85,7 +85,7 @@ header {
}
!header {
- sub (/\#.+/, "");
+ sub (/#.+/, "");
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
if (/^$/)
diff --git a/src/mkerrcodes1.awk b/src/mkerrcodes1.awk
index a771a73..4578e29 100644
--- a/src/mkerrcodes1.awk
+++ b/src/mkerrcodes1.awk
@@ -81,7 +81,7 @@ header {
}
!header {
- sub (/\#.+/, "");
+ sub (/#.+/, "");
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
if (/^$/)
diff --git a/src/mkerrcodes2.awk b/src/mkerrcodes2.awk
index ea58503..188f7a4 100644
--- a/src/mkerrcodes2.awk
+++ b/src/mkerrcodes2.awk
@@ -91,7 +91,7 @@ header {
}
!header {
- sub (/\#.+/, "");
+ sub (/#.+/, "");
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
if (/^$/)
diff --git a/src/mkerrnos.awk b/src/mkerrnos.awk
index f79df66..15b1aad 100644
--- a/src/mkerrnos.awk
+++ b/src/mkerrnos.awk
@@ -83,7 +83,7 @@ header {
}
!header {
- sub (/\#.+/, "");
+ sub (/#.+/, "");
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
if (/^$/)
diff --git a/src/mkstrtable.awk b/src/mkstrtable.awk
index c9de9c1..285e45f 100644
--- a/src/mkstrtable.awk
+++ b/src/mkstrtable.awk
@@ -77,7 +77,7 @@
#
# The variable prefix can be used to prepend a string to each message.
#
-# The variable namespace can be used to prepend a string to each
+# The variable pkg_namespace can be used to prepend a string to each
# variable and macro name.
BEGIN {
@@ -102,7 +102,7 @@ header {
print "/* The purpose of this complex string table is to produce";
print " optimal code with a minimum of relocations. */";
print "";
- print "static const char " namespace "msgstr[] = ";
+ print "static const char " pkg_namespace "msgstr[] = ";
header = 0;
}
else
@@ -110,7 +110,7 @@ header {
}
!header {
- sub (/\#.+/, "");
+ sub (/#.+/, "");
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
if (/^$/)
@@ -150,7 +150,7 @@ END {
else
print " gettext_noop (\"" last_msgstr "\");";
print "";
- print "static const int " namespace "msgidx[] =";
+ print "static const int " pkg_namespace "msgidx[] =";
print " {";
for (i = 0; i < coded_msgs; i++)
print " " pos[i] ",";
@@ -158,7 +158,7 @@ END {
print " };";
print "";
print "static GPG_ERR_INLINE int";
- print namespace "msgidxof (int code)";
+ print pkg_namespace "msgidxof (int code)";
print "{";
print " return (0 ? 0";
--
2.11.0