qt3: merge danm's 3.3.6 updates; Pkgfile cosmetic fixes

This commit is contained in:
Nick Steeves 2006-05-11 23:45:47 +00:00
parent d99b72d3de
commit 85f322cb6c
5 changed files with 35 additions and 69 deletions

View File

@ -420,10 +420,10 @@ drwxr-xr-x root/root usr/lib/
-rw-r--r-- root/root usr/lib/libqassistantclient.prl
-rw-r--r-- root/root usr/lib/libqt-mt.la
-rw-r--r-- root/root usr/lib/libqt-mt.prl
lrwxrwxrwx root/root usr/lib/libqt-mt.so -> libqt-mt.so.3.3.5
lrwxrwxrwx root/root usr/lib/libqt-mt.so.3 -> libqt-mt.so.3.3.5
lrwxrwxrwx root/root usr/lib/libqt-mt.so.3.3 -> libqt-mt.so.3.3.5
-rwxr-xr-x root/root usr/lib/libqt-mt.so.3.3.5
lrwxrwxrwx root/root usr/lib/libqt-mt.so -> libqt-mt.so.3.3.6
lrwxrwxrwx root/root usr/lib/libqt-mt.so.3 -> libqt-mt.so.3.3.6
lrwxrwxrwx root/root usr/lib/libqt-mt.so.3.3 -> libqt-mt.so.3.3.6
-rwxr-xr-x root/root usr/lib/libqt-mt.so.3.3.6
-rw-r--r-- root/root usr/lib/libqui.prl
lrwxrwxrwx root/root usr/lib/libqui.so -> libqui.so.1.0.0
lrwxrwxrwx root/root usr/lib/libqui.so.1 -> libqui.so.1.0.0
@ -456,6 +456,9 @@ lrwxrwxrwx root/root usr/share/qt/include -> ../../include/qt
lrwxrwxrwx root/root usr/share/qt/lib -> ../../lib
drwxr-xr-x root/root usr/share/qt/mkspecs/
lrwxrwxrwx root/root usr/share/qt/mkspecs/default -> linux-g++
drwxr-xr-x root/root usr/share/qt/mkspecs/linux-g++-32/
-rw-r--r-- root/root usr/share/qt/mkspecs/linux-g++-32/qmake.conf
-rw-r--r-- root/root usr/share/qt/mkspecs/linux-g++-32/qplatformdefs.h
drwxr-xr-x root/root usr/share/qt/mkspecs/linux-g++-64/
-rw-r--r-- root/root usr/share/qt/mkspecs/linux-g++-64/qmake.conf
-rw-r--r-- root/root usr/share/qt/mkspecs/linux-g++-64/qplatformdefs.h

View File

@ -1,4 +1,3 @@
9d91c83f4addae1830c68c63b8aa806c 0999_qt-3.3.5-qlistview.patch
05d04688c0c0230ed54e89102d689ca4 qt-x11-free-3.3.5.tar.bz2
a0420bc8ef951b0299b6055043988211 qt3-3.3.5-2-patches.tar.bz2
7d8d3356a17201832e361df69c63e9a4 qt3-3.3.5-gcc4.patch
dc1384c03ac08af21f6fefab32d982cf qt-x11-free-3.3.6.tar.bz2
7f17be4be458fd40e9bfb9c80a33b48a qt3-3.3.6-1-patches.tar.bz2
7d8d3356a17201832e361df69c63e9a4 qt3-3.3.6-gcc4.patch

View File

@ -1,33 +0,0 @@
Hi,
I finally figure out why kxmame mysteriously crashes using qt 3.3.5. This
is because QListView::clear() method doesn't reset d->highlighted to NULL.
This means that after a few tries of clearing and repopulating the item
list, d->highlighted might point to an invalid location. When
QListViewItem::takeItem is called, d->highlighted is used and causes
crash. Remarkably, due to the way it's coded, this bug doesn't appear in
Qt 3.3.4.
I included the fix patch below for your information. I don't want to
subscribe to another qt-devel list to send this bug info. So if anyone
here can help sending this patch to the proper place, please do.
Thanks a lot,
Toan
diff -uBbr qt-x11-free-3.3.5-old/src/widgets/qlistview.cpp
qt-x11-free-3.3.5/src/widgets/qlistview.cpp
--- qt-x11-free-3.3.5-old/src/widgets/qlistview.cpp 2005-09-02
05:43:15.000000000 -0700
+++ qt-x11-free-3.3.5/src/widgets/qlistview.cpp 2005-11-04
04:07:40.000000000 -0800
@@ -3231,6 +3231,7 @@
d->focusItem = 0;
d->selectAnchor = 0;
d->pressedItem = 0;
+ d->highlighted = 0;
// if it's down its downness makes no sense, so undown it
d->buttonDown = FALSE;

View File

@ -1,37 +1,34 @@
# Description: Qt Free Edition
# URL: http://www.trolltech.com
# Maintainer: Daniel Mueller, daniel at danm dot de
# Maintainer: sten, nick dot steeves at shaw dot ca
# Packager: Daniel Mueller, daniel at danm dot de
# Depends on: x11, freetype, libjpeg, libmng, libpng, fontconfig, expat
name=qt3
version=3.3.5
release=2
version=3.3.6
release=1
source=(ftp://ftp.trolltech.com/qt/source/qt-x11-free-$version.tar.bz2 \
http://crux.danm.de/files/dist/$name/$version/$name-$version-2-patches.tar.bz2 \
$name-$version-gcc4.patch 0999_qt-3.3.5-qlistview.patch)
http://crux.danm.de/files/dist/$name/$version/$name-$version-1-patches.tar.bz2 $name-$version-gcc4.patch)
build () {
build() {
cd qt-x11-free-$version
# KDE patches (http://websvn.kde.org/branches/qt/3.3/qt-copy/patches/?rev=507267)
for i in ../$name-patches/*.*; do
patch -p2 < $i
for i in $(ls $SRC/$name-patches/* | sort); do
patch -p2 -i $i
done
# gcc4 + 64bit issue
patch -p1 < $SRC/$name-$version-gcc4.patch
patch -p1 -i $SRC/$name-$version-gcc4.patch
local SQL
if [ "`pkginfo -i | grep mysql`" ];then
SQL="-qt-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
SQL="-qt-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
fi
# fix serious, crashy bugs in widgets/qlistview.cpp
patch -p1 < $SRC/0999_qt-$version-qlistview.patch
if [ -d /usr/include/nvidia ]; then
export CFLAGS="$CFLAGS -I/usr/include/nvidia"
export CXXFLAGS="$CXXFLAGS -I/usr/include/nvidia"
export CFLAGS="$CFLAGS -I/usr/include/nvidia"
export CXXFLAGS="$CXXFLAGS -I/usr/include/nvidia"
fi
# don't link against our currently installed libraries
@ -44,16 +41,16 @@ build () {
sed -i "s|-I. |$CXXFLAGS -I. |" qmake/Makefile.unix
./configure -prefix /usr/share/qt \
-bindir /usr/bin \
-headerdir /usr/include/qt \
-libdir /usr/lib \
-plugindir /usr/lib/qt \
-platform linux-g++ -release -shared -thread -sm \
-tablet -nis -verbose -qt-gif -system-zlib \
-{system-lib,plugin-imgfmt-}{png,jpeg,mng} \
-no-{cups,fast,exceptions,nas-sound} \
-x{cursor,ft,inerama,kb,randr,render} \
$SQL
-bindir /usr/bin \
-headerdir /usr/include/qt \
-libdir /usr/lib \
-plugindir /usr/lib/qt \
-platform linux-g++ -release -shared -thread -sm \
-tablet -nis -verbose -qt-gif -system-zlib \
-{system-lib,plugin-imgfmt-}{png,jpeg,mng} \
-no-{cups,fast,exceptions,nas-sound} \
-x{cursor,ft,inerama,kb,randr,render} \
$SQL
make src-moc sub-src
@ -63,7 +60,7 @@ build () {
make INSTALL_ROOT=$PKG install
for i in mergetr msg2qm qconfig qembed qvfb; do
(cd tools/$i/;make SUBLIBS="-lpng -lmng";mv $i $PKG/usr/bin/)
(cd tools/$i/;make SUBLIBS="-lpng -lmng";mv $i $PKG/usr/bin/)
done
mv bin/{findtr,qtrename140} $PKG/usr/bin/
@ -71,8 +68,8 @@ build () {
mv doc/man/man1 $PKG/usr/man
rm -rf `find $PKG/usr/share/qt/mkspecs/* | grep -v linux-g++` \
$PKG/usr/share/qt/{phrasebooks,templates,translations} \
$PKG/usr/include/qt/{j,n}*
$PKG/usr/share/qt/{phrasebooks,templates,translations} \
$PKG/usr/include/qt/{j,n}*
rm -f $PKG/usr/share/qt/mkspecs/linux-g++/linux-g++
ln -s ../../bin $PKG/usr/share/qt/bin