firefox: updated to version 2.0.0.7

This commit is contained in:
Matt Housh 2007-09-18 21:39:53 -05:00
parent 3d00bb7bfd
commit 9164857ad6
4 changed files with 54 additions and 2 deletions

View File

@ -1,4 +1,6 @@
16fb252fb7b0371894f7101b88fd9076 firefox-2.0.0.6-source.tar.bz2
25f355113cdee6800380c6e1a4cd38f0 firefox-2.0-add-ldflags.patch
ec14cf833d75d07190c4095345d688bd firefox-2.0.0.7-source.tar.bz2
f975d9aa6ec232da0dfa8f27398d2af3 firefox-nopangoxft.patch
0eceebd5fbc394248c8c94d66fc95d66 firefox.desktop
19ec3915f76e7eb820ad2c59730ee2be firefox.png
a95e9f62cc3b2b0c4ad906c2a9f44bcf mozconfig

View File

@ -4,9 +4,10 @@
# Depends on: libidl, gtk, libpng, libjpeg, zlib
name=firefox
version=2.0.0.6
version=2.0.0.7
release=1
source=(ftp://ftp.mozilla.org/pub/mozilla.org/$name/releases/$version/source/$name-$version-source.tar.bz2 \
$name-2.0-add-ldflags.patch $name-nopangoxft.patch \
http://crux.nu/files/$name/$name.desktop \
http://crux.nu/files/$name/$name.png \
mozconfig)
@ -18,6 +19,8 @@ build() {
export MOZILLA_FIVE_HOME=/usr/lib/firefox
cd mozilla
patch -p0 -i $SRC/$name-2.0-add-ldflags.patch
patch -p1 -i $SRC/$name-nopangoxft.patch
sed -e "s/#CFLAGS#/$CFLAGS/" $SRC/mozconfig > .mozconfig
./configure
make

View File

@ -0,0 +1,10 @@
--- layout/build/Makefile.in.orig 2006-10-25 21:02:08.000000000 +0000
+++ layout/build/Makefile.in 2006-10-25 21:02:44.000000000 +0000
@@ -226,6 +226,7 @@
ifdef MOZ_ENABLE_GTK2
EXTRA_DSO_LDOPTS += $(MOZ_GTK2_LIBS) \
+ -lX11 -lXrender \
$(NULL)
endif

View File

@ -0,0 +1,37 @@
--- mozilla/gfx/src/gtk/mozilla-decoder.cpp.noxft 2004-11-07 18:59:23.000000000 -0500
+++ mozilla/gfx/src/gtk/mozilla-decoder.cpp 2006-08-06 18:24:37.000000000 -0400
@@ -40,10 +40,9 @@
#define PANGO_ENABLE_ENGINE
#include "mozilla-decoder.h"
-#include <pango/pangoxft.h>
#include <pango/pangofc-fontmap.h>
#include <pango/pangofc-font.h>
-#include <gdk/gdkx.h>
+#include <gdk/gdkpango.h>
#include "nsString.h"
#include "nsIPersistentProperties2.h"
@@ -145,6 +144,13 @@ mozilla_decoders_init(void)
if (initialized)
return 0;
+ PangoContext* context = gdk_pango_context_get ();
+ PangoFontMap* fontmap = pango_context_get_font_map (context);
+ g_object_unref (context);
+
+ if (!PANGO_IS_FC_FONT_MAP (fontmap))
+ return -1;
+
encoder_hash = g_hash_table_new(g_str_hash, g_str_equal);
cmap_hash = g_hash_table_new(g_str_hash, g_str_equal);
wide_hash = g_hash_table_new(g_str_hash, g_str_equal);
@@ -208,7 +214,7 @@ mozilla_decoders_init(void)
}
}
- pango_fc_font_map_add_decoder_find_func(PANGO_FC_FONT_MAP(pango_xft_get_font_map(GDK_DISPLAY(),gdk_x11_get_default_screen())),
+ pango_fc_font_map_add_decoder_find_func(PANGO_FC_FONT_MAP(fontmap),
mozilla_find_decoder,
NULL,
NULL);