netpbm: updated to 10.35.57

This commit is contained in:
Antti Nykanen 2009-01-12 17:31:09 +02:00
parent 4407f8b85c
commit 92ea0141b4
3 changed files with 3 additions and 33 deletions

View File

@ -1,3 +1,2 @@
5aa32e99a1e58adbbd28928d1086183e Makefile.config
10495d2d5d88635df58c446a9ee01532 netpbm-10.35.52.diff
e931b5d284d9ee00d04bb44d4d1812d3 netpbm-10.35.52.tar.gz
c11124191e832f3f4abf5e8ce14a140f netpbm-10.35.57.tar.gz

View File

@ -4,17 +4,16 @@
# Depends on: ghostscript
name=netpbm
version=10.35.52
version=10.35.57
release=1
source=(http://crux.nu/~aon/$name/$name-$version.tar.gz
$name-$version.diff
Makefile.config)
build() {
export MAKEFLAGS="$MAKEFLAGS -j1"
cd netpbm-$version
patch -p0 -i $SRC/$name-$version.diff
# patch -p0 -i $SRC/$name-$version.diff
sed -e "s|#CFLAGS#|$CFLAGS|" $SRC/Makefile.config > Makefile.config
make
make pkgdir=$PKG/usr package

View File

@ -1,28 +0,0 @@
--- editor/pamcomp.c~ 2008-09-13 14:01:30.000000000 +0000
+++ editor/pamcomp.c 2008-09-13 14:01:47.000000000 +0000
@@ -325,25 +325,6 @@ validateComputableHeight(int const origi
static void
-validateComputableHeight(int const originTop,
- int const overRows) {
-
- if (originTop < 0) {
- if (originTop < -INT_MAX)
- pm_error("Overlay starts too far above the underlay image to be "
- "computable. Overlay can be at most %d rows above "
- "the underlay.", INT_MAX);
- } else {
- if (INT_MAX - originTop <= overRows)
- pm_error("Too many total rows involved to be computable. "
- "You must have a shorter overlay image or compose it "
- "higher on the underlay image.");
- }
-}
-
-
-
-static void
computeOverlayPosition(int const underCols,
int const underRows,
int const overCols,