poppler: update to 0.55.0

This commit is contained in:
Juergen Daubert 2017-05-22 14:48:08 +02:00
parent ee47c383e9
commit 9468661b66
4 changed files with 20 additions and 20 deletions

View File

@ -1,2 +1,2 @@
ed0b36e3f577e669dcc58bd408cacde6 poppler-0.54.0.tar.xz
5d8be2537e2944560bc309434edfbaaf poppler-cmake.patch
f7a8230626b6d2061acfdc852930b7dd poppler-0.55.0.tar.xz
3550e95260ee788c6cc5ef0a579d3037 poppler-cmake.patch

View File

@ -1,6 +1,6 @@
untrusted comment: verify with /etc/ports/opt.pub
RWSE3ohX2g5d/UreQttFVt87EhwsJj7Q3uJF+B+l7/cr9eOcd4JoI69JLl8eXRIGa2nGXHZc5QOkVEVz1OlU7vMwf7R9Y2/cSwY=
SHA256 (Pkgfile) = 6c355847c0e653686fa3ede4f11aed22f78bccd6ced3ac979131e13517fe5542
RWSE3ohX2g5d/YriNZcOnp+WfEnfDTLWbgKmMZMjZH9OT6LHE3npPffn9OfqUK7lNKja3Zyj8A8pq7D5e7352vYj5yl7W2DfBwU=
SHA256 (Pkgfile) = fbdd844376b2c35231d9394f509d2e7ab2a98b55494c5c80a83c2828d4712fea
SHA256 (.footprint) = bffab09c16d4ac90d238b8e5e4d420daec227f45d9f937752de93dff774c1d68
SHA256 (poppler-0.54.0.tar.xz) = 10cca9a67cc2e6f4f9024192b1067c444218bf94430891f43dc819d78536ca31
SHA256 (poppler-cmake.patch) = c93b1858601d949155c585a09b6313af40ca3ef81e360103ee0269cae840afa5
SHA256 (poppler-0.55.0.tar.xz) = 537f2bc60d796525705ad9ca8e46899dcc99c2e9480b80051808bae265cdc658
SHA256 (poppler-cmake.patch) = 8a75147e58d5ecc2eb5baced98fcc405320ff94e2a8eb613c04c91aa8e441d5c

View File

@ -4,7 +4,7 @@
# Depends on: cmake cairo lcms2
name=poppler
version=0.54.0
version=0.55.0
release=1
source=(http://poppler.freedesktop.org/poppler-$version.tar.xz
poppler-cmake.patch)
@ -26,7 +26,7 @@ build() {
-DENABLE_QT5=OFF \
-DENABLE_ZLIB=ON \
-DENABLE_CMS=lcms2 \
-DENABLE_LIBOPENJPEG=OFF \
-DENABLE_LIBOPENJPEG=none \
-DENABLE_NSS3=OFF \
-DBUILD_GTK_TESTS=OFF \
-DBUILD_QT4_TESTS=OFF \

View File

@ -1,5 +1,5 @@
--- CMakeLists.txt.orig 2017-03-24 14:01:29.290030602 +0100
+++ CMakeLists.txt 2017-03-24 14:04:03.207864095 +0100
--- CMakeLists.txt.orig 2017-05-21 23:01:39.000000000 +0200
+++ CMakeLists.txt 2017-05-22 14:12:44.635191266 +0200
@@ -35,8 +35,14 @@
option(BUILD_QT5_TESTS "Whether compile the Qt5 test programs." ON)
option(BUILD_CPP_TESTS "Whether compile the CPP test programs." ON)
@ -12,12 +12,12 @@
+option(ENABLE_QT5 "Compile poppler QT5 wrapper." ON)
+option(ENABLE_NSS3 "Build with NSS3 support." OFF)
+
set(ENABLE_LIBOPENJPEG "auto" CACHE STRING "Use libopenjpeg for JPX streams. Possible values: auto, openjpeg1, openjpeg2. 'auto' prefers openjpeg1 over openjpeg2 if both are available. Unset to not use openjpeg.")
set(ENABLE_LIBOPENJPEG "auto" CACHE STRING "Use libopenjpeg for JPX streams. Possible values: auto, openjpeg1, openjpeg2, unmaintained, none. 'auto' prefers openjpeg2 over openjpeg1 if both are available. 'unmaintained' gives you the internal unmaintained decoder. Use at your own risk. 'none' compiles no JPX decoder at all. Default: auto")
set(ENABLE_CMS "auto" CACHE STRING "Use color management system. Possible values: auto, lcms1, lcms2. 'auto' prefers lcms2 over lcms1 if both are available. Unset to disable color management system.")
option(ENABLE_LIBCURL "Build libcurl based HTTP support." OFF)
@@ -113,43 +119,46 @@
set(ENABLE_LIBJPEG ${JPEG_FOUND})
endif(JPEG_FOUND)
set(ENABLE_DCTDECODER "libjpeg" CACHE STRING "Use libjpeg for DCT streams. Possible values: libjpeg, unmaintained, none. will use libjpeg if available or fail if not. 'unmaintained' gives you the internal unmaintained decoder. Use at your own risk. 'none' compiles no DCT decoder at all. Default: libjpeg")
@@ -127,43 +133,46 @@
message(FATAL_ERROR "Invalid ENABLE_DCTDECODER value.")
endif()
macro_optional_find_package(Qt4)
-if(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}.${CMAKE_PATCH_VERSION} VERSION_GREATER 2.8.7)
- find_package(Qt5Core)
@ -98,7 +98,7 @@
if(ENABLE_CPP)
macro_optional_find_package(Iconv)
set(ENABLE_CPP ${ICONV_FOUND})
@@ -243,10 +252,10 @@
@@ -277,10 +286,10 @@
include_directories(${ZLIB_INCLUDE_DIR})
endif(ENABLE_ZLIB)
@ -110,8 +110,8 @@
+endif(ENABLE_NSS3 AND NSS3_FOUND)
if(JPEG_FOUND)
include_directories(${JPEG_INCLUDE_DIR})
set(ENABLE_LIBJPEG ON)
@@ -683,12 +692,12 @@
endif(JPEG_FOUND)
@@ -716,12 +725,12 @@
add_subdirectory(glib)
endif(ENABLE_GLIB)
add_subdirectory(test)
@ -128,7 +128,7 @@
if(ENABLE_CPP)
add_subdirectory(cpp)
endif(ENABLE_CPP)
@@ -710,12 +719,12 @@
@@ -743,12 +752,12 @@
if(ENABLE_SPLASH)
poppler_create_install_pkgconfig(poppler-splash.pc lib${LIB_SUFFIX}/pkgconfig)
endif(ENABLE_SPLASH)
@ -145,7 +145,7 @@
if(ENABLE_GLIB)
poppler_create_install_pkgconfig(poppler-glib.pc lib${LIB_SUFFIX}/pkgconfig)
endif(ENABLE_GLIB)
@@ -734,8 +743,8 @@
@@ -767,8 +776,8 @@
message(" with CMYK support")
endif()
show_end_message_yesno("cairo output" CAIRO_FOUND)