spectrwm: update to 3.0.0

This commit is contained in:
Juergen Daubert 2016-05-05 13:35:57 +02:00
parent 055526b6e2
commit 946df53250
4 changed files with 21 additions and 29 deletions

View File

@ -1,8 +1,7 @@
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
lrwxrwxrwx root/root usr/bin/scrotwm -> spectrwm
-rwxr-xr-x root/root usr/bin/spectrwm
drwxr-xr-x root/root usr/lib/
drwxr-xr-x root/root usr/man/
drwxr-xr-x root/root usr/man/man1/
-rw-r--r-- root/root usr/man/man1/spectrwm.1.gz
drwxr-xr-x root/root usr/share/
drwxr-xr-x root/root usr/share/man/
drwxr-xr-x root/root usr/share/man/man1/
-rwxr-xr-x root/root usr/share/man/man1/spectrwm.1.gz

View File

@ -1,2 +1,2 @@
4eb5cf576d8e70555bd199e4bb96b479 spectrwm-2.7.2.tgz
d91de7130497ef228380168dee01a79b spectrwm-remove_libswmhack.patch
49ff00f35b514a72f1e81ee613bbfa8b spectrwm-3.0.0.tgz
e294f5abac9b35c819256094c66150a2 spectrwm-remove_libswmhack.patch

View File

@ -4,7 +4,7 @@
# Depends on: xorg-libxrender fontconfig xorg-xcb-util-keysyms xorg-xcb-util-wm
name=spectrwm
version=2.7.2
version=3.0.0
release=1
source=(https://opensource.conformal.com/snapshots/$name/$name-$version.tgz
$name-remove_libswmhack.patch)
@ -12,7 +12,10 @@ source=(https://opensource.conformal.com/snapshots/$name/$name-$version.tgz
build () {
cd $name-$version/linux
patch -p 1 -d .. -i $SRC/$name-remove_libswmhack.patch
make PREFIX=/usr MANDIR=/usr/man DESTDIR=$PKG install
rm -r $PKG/usr/{man/??/,share}
ln -sf spectrwm $PKG/usr/bin/scrotwm
make PREFIX=/usr
#rm -r $PKG/usr/{man/??/,share}
#ln -sf spectrwm $PKG/usr/bin/scrotwm
install -d $PKG/usr/{bin,share/man/man1}
install spectrwm $PKG/usr/bin
install ../spectrwm.1 $PKG/usr/share/man/man1
}

View File

@ -1,6 +1,6 @@
diff -Nru spectrwm-2.7.2.orig/linux/Makefile spectrwm-2.7.2/linux/Makefile
--- spectrwm-2.7.2.orig/linux/Makefile 2015-05-28 19:03:31.640514721 +0200
+++ spectrwm-2.7.2/linux/Makefile 2015-05-28 19:03:51.140395900 +0200
diff -Nru spectrwm-3.0.0.orig/linux/Makefile spectrwm-3.0.0/linux/Makefile
--- spectrwm-3.0.0.orig/linux/Makefile 2016-05-05 12:01:59.903766554 +0200
+++ spectrwm-3.0.0/linux/Makefile 2016-05-05 12:02:13.257073357 +0200
@@ -10,7 +10,7 @@
LIBMAJORVERSION = $(shell . $(CURDIR)/../lib/shlib_version; echo $$major)
@ -10,20 +10,10 @@ diff -Nru spectrwm-2.7.2.orig/linux/Makefile spectrwm-2.7.2/linux/Makefile
MAINT_LDLIBS = -lX11 -lX11-xcb -lxcb -lxcb-icccm -lxcb-randr -lxcb-keysyms -lxcb-util -lxcb-xtest -lXft -lXcursor
ifneq ("${BUILDVERSION}", "")
@@ -48,9 +48,6 @@
install -m 755 -d $(DESTDIR)$(XSESSIONSDIR)
install -m 755 spectrwm $(DESTDIR)$(BINDIR)
ln -sf spectrwm $(DESTDIR)$(BINDIR)/scrotwm
- install -m 644 libswmhack.so.$(LIBVERSION) $(DESTDIR)$(LIBDIR)
- ln -sf libswmhack.so.$(LIBVERSION) $(DESTDIR)$(LIBDIR)/libswmhack.so.$(LIBMAJORVERSION)
- ln -sf libswmhack.so.$(LIBVERSION) $(DESTDIR)$(LIBDIR)/libswmhack.so
install -m 644 ../spectrwm.1 $(DESTDIR)$(MANDIR)/man1/spectrwm.1
install -m 644 ../spectrwm_es.1 $(DESTDIR)$(MANDIR)/es/man1/spectrwm.1
install -m 644 ../spectrwm_it.1 $(DESTDIR)$(MANDIR)/it/man1/spectrwm.1
diff -Nru spectrwm-2.7.2.orig/spectrwm.c spectrwm-2.7.2/spectrwm.c
--- spectrwm-2.7.2.orig/spectrwm.c 2015-05-28 19:03:31.640514721 +0200
+++ spectrwm-2.7.2/spectrwm.c 2015-05-28 19:03:51.143729213 +0200
@@ -310,9 +310,9 @@
diff -Nru spectrwm-3.0.0.orig/spectrwm.c spectrwm-3.0.0/spectrwm.c
--- spectrwm-3.0.0.orig/spectrwm.c 2016-05-05 12:01:59.903766554 +0200
+++ spectrwm-3.0.0/spectrwm.c 2016-05-05 12:02:13.260406683 +0200
@@ -273,9 +273,9 @@
#define SWM_CONF_DEFAULT (0)
#define SWM_CONF_KEYMAPPING (1)
@ -35,7 +25,7 @@ diff -Nru spectrwm-2.7.2.orig/spectrwm.c spectrwm-2.7.2/spectrwm.c
char **start_argv;
xcb_atom_t a_state;
@@ -3493,7 +3493,7 @@
@@ -3712,7 +3712,7 @@
close(xcb_get_file_descriptor(conn));